Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Taking very long to eject devices

05 Nov 2009   #1
riskyayush

Windows 7
 
 
Taking very long to eject devices

When I click the eject external device button, it takes about 30 seconds for the pop up window to show up (which gives me the option of selecting which device to eject).

Is anyone else also facing this problem?


My System SpecsSystem Spec
.
24 Nov 2009   #2
CarbonCopy

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by riskyayush View Post
When I click the eject external device button, it takes about 30 seconds for the pop up window to show up (which gives me the option of selecting which device to eject).

Is anyone else also facing this problem?

Yep - exactly the same problem here. Did you find a solution? I'm using an Asus P6T Deluxe.
My System SpecsSystem Spec
25 Nov 2009   #3
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Quote   Quote: Originally Posted by CarbonCopy View Post
Quote   Quote: Originally Posted by riskyayush View Post
When I click the eject external device button, it takes about 30 seconds for the pop up window to show up (which gives me the option of selecting which device to eject).

Is anyone else also facing this problem?

Yep - exactly the same problem here. Did you find a solution? I'm using an Asus P6T Deluxe.
Do you have enough memory? Is the device that you are ejecting, quality merchandise, with enough memory?

Are you copying to the device, a doucment with high Mb?

Any of these reasons can slow you down.
My System SpecsSystem Spec
.

25 Nov 2009   #4
riskyayush

Windows 7
 
 

Quote   Quote: Originally Posted by CarbonCopy View Post
Yep - exactly the same problem here. Did you find a solution? I'm using an Asus P6T Deluxe.
I have kaspersky internet security 2010 installed. When i disable its self protection, things become better.
My System SpecsSystem Spec
25 Nov 2009   #5
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Quote   Quote: Originally Posted by riskyayush View Post
Quote   Quote: Originally Posted by CarbonCopy View Post
Yep - exactly the same problem here. Did you find a solution? I'm using an Asus P6T Deluxe.
I have kaspersky internet security 2010 installed. When i disable its self protection, things become better.
A number of posters have mentioned problems with that A/V. Possibly you would be happier with MSE. A free combined anti virus, firewall from Microsoft. Microsoft Security Essentials, can be found at the Microsoft web site. The A/V was specifically made with windows in mind. In fact, you must use windows to take advantage of the product. If you cannot get your O/S to work with your present A/V, give my suggestion some thought. In any event, I wish you luck and a Happy Thanksgiving
My System SpecsSystem Spec
26 Nov 2009   #6
CarbonCopy

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by richc46 View Post
Quote   Quote: Originally Posted by riskyayush View Post
Quote   Quote: Originally Posted by CarbonCopy View Post
Yep - exactly the same problem here. Did you find a solution? I'm using an Asus P6T Deluxe.
I have kaspersky internet security 2010 installed. When i disable its self protection, things become better.
A number of posters have mentioned problems with that A/V. Possibly you would be happier with MSE. A free combined anti virus, firewall from Microsoft. Microsoft Security Essentials, can be found at the Microsoft web site. The A/V was specifically made with windows in mind. In fact, you must use windows to take advantage of the product. If you cannot get your O/S to work with your present A/V, give my suggestion some thought. In any event, I wish you luck and a Happy Thanksgiving
Many thanks for the responses and advice.

I have 3 GB memory and all the devices I use are good quality and I never try and eject whilst the device is in use. However, I am using Kaspersky Internet Security 2010 - looks like there might be a common theme here. Hope they fix it as I have used Kaspersky for several years and really do like it.

In the mean time I'll take a look at MSE.
My System SpecsSystem Spec
Reply

 Taking very long to eject devices




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 taking too long to shut down?
Lately I've noticed that my custom-built PC has been taking roughly 5-10 minutes to shut down, and upon start-up it takes 5-10 minutes to get past the screen for my motherboard. With my specs, I didn't think I'd have this problem. I just did a virus scan with avast free antivirus and it turned up...
General Discussion
Recycling a movie from my harddrive is taking long long time.
Why is this. Like 10 minutes plus and it still says recycling. It should only take a second. Is it bad to let it continue at its own pace or should I restart the PC and try it again?
General Discussion
Updates Taking Too Long To Install
gdawg65 Windows 7 Home Premium 32bit 8 posts
Windows Updates & Activation
Firefox 3.5.3 taking too long.
I'm running Windows 7 64bit (Got from houseparty). It takes about 10-15 seconds to launch Firefox but 1 second to launch IE8. I uninstalled and reinstalled Firefox but still slow. Anyone else have this problem?
Browsers & Mail
Devices slow to eject
When I click the eject external device button, it takes about 30 seconds for the pop up window to show up (which gives me the option of selecting which device to eject). Is anyone else also facing this problem?
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:22.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App