Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: External drive gives "Access denied" on reboot.

26 Jan 2015   #1

Windows 7 64 Pro
External drive gives "Access denied" on reboot.

I have an external drive (2Tb, Toshiba, USB3) which I wiped (formatted and created new volume on). I run Win7Pro64. The drive seemed to be working fine, until I rebooted, Then I got "Access denied" when I wanted to explore its contents. When I then tried to give the drive another label (in this case from M:\ to N:\) it again worked. Also when switching back to M:\ worked. However, when I reboot, I again get "Access denied".

In safe mode, the drive seems to work fine.

Any clue as to why this is? Any help is greatly appreciated - this is driving me nuts.


My System SpecsSystem Spec
26 Jan 2015   #2

Windows 7 64 Pro

Okay, so I found the solution to this myself after some struggling. My computer is an HP which comes with its own security software. It turns out the default setting is to not allow USB devices. Good to know for others who might be struggling with their HP desktops...
My System SpecsSystem Spec

 External drive gives "Access denied" on reboot.

Thread Tools

Similar help and support threads
Thread Forum
"access denied" when using "assoc" and "ftype" from cmdline?
I tried to associate the file extension .txt to a new editor program with the well known cmdline programs ASSOC and FTYPE. No, assigning them through WinExplorer menu does not work. But this is another problem which should not discussed here. When I type now one of the following...
General Discussion
"E:\ is not accessible. Access is denied" issue with my external hdd
Hi, I have some problem with my external harddrive. I use Windows 7 home premium 64bit. Normally, I can use my external harddrive with my laptop perfectly. But I dont know why few days ago I cannot access to my harddrive anymore and it shows "E:\ is not accessible. Access is denied" ...
Hardware & Devices
hard drive "access denied"
Hope this is the right place to post if not please excuse. I HAVE A hdd in another macine that won't let me access it.It shows this hdd on boot up also in disk management it shows as healthy,active,etc.Ihave checked ownership & permissions & all were correct.I downloaded a file recovery program &...
General Discussion
External hard drive suddenly "needs to be formatted" after a reboot
I just put about 25 gigs of data on this drive. It's an 80 gig drive and has about 20 gigs of space left on it before it's full. Out of all the files I cut and pasted over it got stuck on this last ISO file.. it refused to move this file.. so i stopped the move operation, and rebooted. I never had...
Hardware & Devices
C: drive shows "access is denied" when tried to open.
Hi i have an ACER laptop. a few weeks ago, i installed oracle 11g software twice and uninstalled it. it was after the 2nd uninstallation that i noticed, C: drive access is denied. the c: drive is now under NTFS. i tried system restore but there was no use. i tried making changes to admin and...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:55.
Twitter Facebook Google+