Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to access second hard drive

31 Jan 2015   #1

windows 7 home premium 64bit
Unable to access second hard drive


I was using my computer normally a few days ago when it suddenly shut down. When I rebooted I became stuck on the Windows 7 load screen.

Long story short I've narrowed down the issue to being related somehow with my second hard drive.

When I disconnect the second drive Windows loads fine. If I have the second drive connected and attempt to load into safe mode the PC hangs on loading CLASSPNP.SYS for several minutes before loading Windows where I can see the second hard drive but cannot access it or see its volumn and the drive letter has changed from D to E.

Things that I have done or tried:
-formatting my SSD that houses my Windows Home Premium 64bit OS
-switched the SATA cables between the hard drives
-ensured both hard drives were listed in SATA1-4 in the BIOS
-ensured the SSD was the first in the BIOS boot order
-tried running bootsect /nt60 all /force using my install disk but never gave me a success message for drive D
-tried connecting the SATA cable to the second drive after sucessfully loading with just the OS drive active

The BIOS recognizes the drive by name but in safe mode the device manager only lists it as Local Disk without a volume. Any attempt to click on the drive in safe mode results in a lock up.

As per normal I would like to recover the information before wiping the drive.

I would be greatful for any insight or solutions into what is preventing my second drive from being read.


My System SpecsSystem Spec
01 Feb 2015   #2

windows 7 home premium 64bit

I found a viable workaround to my issue.

Working under the assumption that the hard drive was intact and just couldn't be accessed by a windows OS I created a linux boot USB using 'puppy linux'.

From there I used the boot USB to access the hard drive and copy all relevant data to an external hard drive.

In an attempt to reclaim the use of my second hard drive I initiated a format of the drive using the linux boot USB in the hopes it would clear out what ever was blocking windows from accessing it. (Had no idea what I was doing in linux so the internet helped a TONNE)

After that I powered down the machine, disconnected all the external drives and launched the PC with my windows install disk. In the installer I could see the drive for the first time in days and it allowed me to format it. After the format I restarted the PC and launched windows normally without the install disk and it let me in. I tried copying a file I made over to the second hard drive and it copied without any issue.

It looks like the crisis is over, hope someone can find this helpful for their own issue!

Thanks :)
My System SpecsSystem Spec

 Unable to access second hard drive

Thread Tools

Similar help and support threads
Thread Forum
Unable to access NAS drive I have just installed.
Just completed installing and setting up a Netgear ReadyNAS Duo v1 - 2 discs each Raid0. On our home network we have 2 pcs (PC1 and PC2) a printer and a NAS drive. The problem I need help with is that PC1 saw the new drive and its main folders immediately the installation was complete. PC2...
Network & Sharing
Unable to access or format external hard drives
I have 2 ADATA 500 GB external hard drives. I plugged them into the USB port and the computer recognized them by name and installed the driver files. It assigned both of them a drive letter but then gave me a message saying that they needed to be formatted. I clicked ok since they are brand new...
Hardware & Devices
Unable to access Hard Drives in Windows 7 installation
One evening I attempted to install windows 8. After the installation it repeatedly booted back into the windows installation. After removing the install disk, it booted into windows 7 normally. I decided to install a clean copy of windows 7 and that's when the problem appeared. The windows insall...
General Discussion
External Hard Drive - Drive Letter changed - unable to change back
I have a USB external hard drive that I keep all my documents etc on (had it for years) I upgraded from Vista Home to & Home Premium then had to upgrade recently to Professional to run my Sage. Through all these upgrades my ext. drive ran fine. Occasionally the drvie letter would change if I...
Hardware & Devices
Unable to access DVD/CD Drive
This is the second time this problem has occurred. The first time I did a complete restore which resolved the problem, I see little point doing that again as the problem has recurred. I am unable to access my DVD/CD Drive, in Device Manager I can see the drive showing a problem, on its properties...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:56.
Twitter Facebook Google+