Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to format external HDD, USB 2.0

14 Feb 2015   #1

Windows 7 Home Premium x64 SP1
Unable to format external HDD, USB 2.0

Hi there, I recently found an old 160 gb external hard drive while cleaning the house, so I decided to format it and use it to store a system image, just in case. I started the format and went to bed, but it must have been bumped or something, because the format didn't complete. I tried it a couple more times, and both times it took ~4 hours to tell me that it couldn't complete and that there might be an I/O error, so I uninstalled and reinstalled the driver. Tried it again, and now it tells me that I should check to see if the drive is read only. Not sure how to get around this. Disk management reads the drive as one RAW partition, not active. Any help would be appreciated. Attached is a screenshot of the most recent error.

Attached Thumbnails
Unable to format external HDD, USB 2.0-drive_format_screen.png  
My System SpecsSystem Spec
14 Feb 2015   #2
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

My System SpecsSystem Spec
14 Feb 2015   #3

64-bit Windows 10 Pro

Hello Alasdair, and welcome to Seven Forums.

Double check to make sure that write protection is disabled for the drive using the tutorial below, then see if you may be able to format it. :)

Disk Write Protection - Enable or Disable in Windows - Windows 10 Forums
My System SpecsSystem Spec


 Unable to format external HDD, USB 2.0

Thread Tools

Similar help and support threads
Thread Forum
Unable to format external hard drive (single RAW partition)
I am quickly discovering all I don’t know about formatting and organizing hard drives. I have an old 2.5 inch, 160GB Segate laptop hard drive, which I have connected using a USB enclosure. At one time, it had a copy of Windows XP, but after I upgraded to a larger hard drive, I used this one for...
Hardware & Devices
Unable to access or format external hard drives
I have 2 ADATA 500 GB external hard drives. I plugged them into the USB port and the computer recognized them by name and installed the driver files. It assigned both of them a drive letter but then gave me a message saying that they needed to be formatted. I clicked ok since they are brand new...
Hardware & Devices
external hard drive problem, unable to detect or format
Hi there, I need some good advice here, I hope someone can help me. I just bought a usb3.0 320gb external hard drive the brand and model are: "Imation Apollo M100" I plugged it into a usb 3 port and it worked but I wanted to format it before i used it, so i right clicked on it in my ...
Hardware & Devices
Can't format external HDD, except to exFat and 'quick format' enabled
Hi, So, the title basically says it all. This is what happened: My 1TB external hard drive worked just fine. I used to store there everything. It was using NTFS file system. Last week I connected it to my laptop and it was really slow when I tried to move or delete files from my pc to the...
Hardware & Devices
Windows Unable to Format External Hard Drive
Hi! Simply as the title says, I was connecting my 1tb drive to my laptop when strangely it asks me to format my drive. I had assumed it had been disconnected improperly and decided to accept the loss and reformat. However, once commanding the drive to format Windows soon brings up an error...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:44.
Twitter Facebook Google+