Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mouse is has been acting a bit odd after new internet connection

16 Feb 2015   #1
Jesse Williams

Windows 10 Home 64-bit
 
 
Mouse is has been acting a bit odd after new internet connection

Ever since, we change internet providers my mouse has been acting odd. It acts like it doesn't want to scroll down or up. I have to force it to scroll or use my down arrow and up arrow keys which is a little better but not by much. Can we fix this problem?


My System SpecsSystem Spec
.
16 Feb 2015   #2
Jesse Williams

Windows 10 Home 64-bit
 
 

I don't mean to be rude or impatient, but it's been 10 hours since I posted this thread. But, when scrolling, my mouse has been acting up. I have to press the up or down keys to scroll better, but that's not better by much.

Anyhow, when I scroll with the mouse I have to do it twice. It doesn't scroll smoothly. It's choppy and sometimes won't scroll at all.
My System SpecsSystem Spec
16 Feb 2015   #3
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Try a new battery in your wireless mouse, or try a wired mouse if you have one.

Does your mouse have it's own software program that provides various settings that you could try.
My System SpecsSystem Spec
.

16 Feb 2015   #4
Jesse Williams

Windows 10 Home 64-bit
 
 

Okay. I will see if that works.
My System SpecsSystem Spec
16 Feb 2015   #5
Jesse Williams

Windows 10 Home 64-bit
 
 

I don't think it has its own software.
My System SpecsSystem Spec
16 Feb 2015   #6
Jesse Williams

Windows 10 Home 64-bit
 
 

It's still scrolling strangely. What could it be?
My System SpecsSystem Spec
16 Feb 2015   #7
Jesse Williams

Windows 10 Home 64-bit
 
 

The problem is mostly occurring on Facebook.
My System SpecsSystem Spec
17 Feb 2015   #8
maxie

windows 7 home 64bit
 
 

Have you tried a different Browser Jesse ?
My System SpecsSystem Spec
17 Feb 2015   #9
Jesse Williams

Windows 10 Home 64-bit
 
 

I use IE 11 and Google Chrome. The same thing is happening on both browsers. It occurs mostly on Facebook.
My System SpecsSystem Spec
17 Feb 2015   #10
maxie

windows 7 home 64bit
 
 

See if the Link below helps


My news feed isnā
My System SpecsSystem Spec
Reply

 Mouse is has been acting a bit odd after new internet connection




Thread Tools




Similar help and support threads
Thread Forum
mouse acting eratically when on internet.
I have a combo wireless mouse microsoft 1000 and a microsoft keyboard. When I am on the internet, it sometimes acts eratically I have W7 64 bit professional op system.
Drivers
Mouse touchpad not working and loss of internet connection
Hi I was hoping someone here could maybe give me some insight to a problem that has just occured. Earlier today I was using my laptop and there wasn't any problems at all, but I have returned to the laptop now and find that the cursor is not responding to anything I do on the mousepad. I also...
Hardware & Devices
Mouse(s) acting up
When these problems occur, it's happens for both my usb mouse and my touchpad. I'm using a laptop. Seemingly randomly and starting from last night, my mouse will all of a sudden start acting really weird. Left clicking results in right clicking and right clicking results in nothing. Or...
Hardware & Devices
Mouse is acting flaky. Can't narrow down to mouse or USB port
I have a Logitech MX518 optical gaming mouse. I've had it for a little over eight years. It's started acting a little flaky and I'm not sure if the mouse is the problem or the USB ports on my computer. The mouse just drops out completely. The red light goes out. It's as if the mouse has been...
Hardware & Devices
Internet connection is acting funny
Starting yesterday or today sometime, my internet connection has been acting funny. I click on links, and sometimes I get a "This page cannot be displayed" message, and other times it loads really slowly, and I get a version of the page without any images. Some sites are just fine. The problem...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:52.
Twitter Facebook Google+