Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: HDD with damaged filesystem refuses to be recognized

18 Feb 2015   #1

Windows 7 Ultimate x64
HDD with damaged filesystem refuses to be recognized

Hi everyone.

First post here.
I figured this forum is my best bet since this is where I usually find the best solutions for any computer problems I come across.

Still I dont have high hopes for this one to get resolved, because I tried so much already with nothing good for it.
But Im no computer expert, I just read read read trying to find solutions and basic knowledge when problems occur. Usually it is enough to get things solved, but not this time.
Hopefully someone have some bright idea that fixes everything in no time

A friend wanted me to look at her laptop that wouldnt boot anymore after some streaming software had been installed.
I figured it would be an easy fix, just some driver that messed things up.
But no no.
It wouldnt boot to safemode, or make any startup repairs.
I tried bootable USB sticks (win PE, ubcd4win, gparted), but either the software wont start or if it do, there is no way to access anything that has anything to do with the HDD.
It just wont be seen or recognized.
I can force a drive letter for the disk using Diskpart, and see that it is partitioned.
With Testdisk I can even see all the partition making up the disk (EFI, SystemReserved, OS).
But no way to access any of it, even just to save photos and files!

I cant be very specific with the steps taken because its been so much back and forth, but some errors/errormessages Ive come across are "data error cyclic redundancy check", "the disk is not formatted, do you want to format it?", chkdsk refusing to even touch the disk (cant remember the exakt errormessage). Ive tried so much with so many tools its ridiculous. But in the end it comes down to that no software wants to recognize this disk as accessible, and Ive never come across that before.

I mean when I take the disk out and put it in my own desktop, in hope to be able to access the files when it is just hooked up and not the one to be booted, it still manages to halt the system, forcing a chkdsk saying that one of the disks need repairs because of some Recovery partion but not getting any further than "usn journal verification" without locking up. Cant skip it either, just locks up the whole system.

This disk is probably GPT formatted, something I just learned about existing to be honest.
It may explain why no mbr repair would be executed...
But yeah, maybe a repair of the boot sectors/partitions would solve it.
Ive read that GPT formatted disks and these EFI bios use more security checks that are dependent on eachother.
But I dont know how to do that! Im so afraid of messing up the whole thing and making it absolute impossible to save any files from it.
One guide said to delete the EFI and SystemReserved partions with Gparted, and to use Diskpart to create new partions and fomat them accordingly, but as I never done any process like that before its a somewhat scary thing to do.

Ah, one more thing! I remember Testdisk getting read errors starting from cylinder 35.
I dont know what that means practically, if it indicates a real hardware failure or just that the filesystem is corrupted or something.

Sorry for the wall of text (and any bad english) talking about one sorry little disk. But its small in comparison to the frustration it evokes!

Some specs:

The disk is a Hitachi HTS545050A7E380, with I think som SSD built in. Atleast Diskpart shows a 30gb SSD listed.
It came in the Asus UX32A Notebook PC.
Installed OS is Win7 x64

Thanks in advance for any help!

My System SpecsSystem Spec
18 Feb 2015   #2

Windows 7 Home Premium 32 bit

Hi jacon6,

Welcome onboard.

And so I believe that that Hitachi HTS545050A7E380 500GB HDD with advanced formatting (4096byte sectors) is berthed on your desktop as a secondary drive. Right?

If so please post a screenshot of how it looks like in Windows Disk Management. Disk Management - Post a Screen Capture Image

I am still digging into your post and trying to get a grip or handle but I shall make just one comment for now.

You had tried TestDisk. You also said you are able to see all the partitions. Since the HDD uses advanced formatting with 4096B size sectors, somewhere along the TestDisk run you have to change the sector size from 512 to 4096 in the TestDisk-shown configuration data, for it to be able to read the HDD correctly. Try it.

Caution: Do not give any [write] command in TestDisk. If partitions are shown correctly after changing the sector size, select the partition and click on P (capital) to see the files. if shown copy those to another connected external drive. ( You have to have an external HDD with adequate space connected before you start TestDisk.)
My System SpecsSystem Spec
19 Feb 2015   #3

Windows 7 Ultimate x64

Thanks for the reply.

Yes I have had it as secondary drive on my desktop, but it wouldnt go past the startup logo then.
Just went straight to chkdsk and locked up.
I tried to connect sata/power cables after bootup, and then use Windows diskmanagement, but the HDD wasnt visible at all that way. No suprise.

The only way Ive been able to do Diskpart and Testdisk is through UBCD4WIN.
Gparted did see all partitions as well.
So there is no way to actually boot to windows when the disk is connected, either it is on my desktop or the laptop.
None of windows repair tools can be used either, when booting with a Win 7 dvd for example.

But I Im going to try what you said about Testdisk, by hooking it up to my desktop again and use UBCD4WIN.
If Im able to copy any files that way, I just need to clear some space and back it all up then.

What about repairing the boot partitions, any thoughts on that?

I just think its so strange the whole thing, that one disk can halt any system it is connected to an be next to impossible to access..
My System SpecsSystem Spec

19 Feb 2015   #4

Windows 7 Home Premium 32 bit

OK, your post makes things a little bit clear. You were all along booting with UBCD4Win . Unfortunately I am not very familiar with it.

But then we can try a lot of things. The first thing that comes to my mind is to check whether a live Linux can see your drive and the files..

Give this post a read and follow it. Is there any way of saving a completely unrecognisable hard drive?

You can also run TestDisk from UBCD4Win, though I would normally run TestDisk for DOS from a bootable DOS pen drive.. I have no objections. As cautioned earlier don't [write] but only copy files if seen.

We can also try to examine the sectors using bootice loaded into a WinPE disk alongwith AOMEI Partition Assistant. I cant say how successful an attempt it will be in your case ( though I had run it and checked it on my system reading and writing to the sectors on an otherwise normal external drive making them cranky. :) ) but we will try if necessary.

First let us see what Lucid Puppy sees. Incidentally it also has Gparted I think and also a screen capture Utility. You may post a screen capture how the drive looks in Gparted. Just play around with Lucid Puppy but take care not to write anything to the drive under test.You can save the screen capture to the lucid puppy pen drive or your system drive.

Today I am retiring a little bit soon since I was awake past midnight yesterday.

Will comeback after another 12 hours.
My System SpecsSystem Spec
19 Feb 2015   #5

Windows 7 Home Premium 32 bit

To carryon further,

Prepare your AOMEI WinPE pen drive as detailed in my post here random BSOD, stop code F4 & 7A, and wont create minidump

Now this will include AOMEI Partition Assistant, with Bootice and TestDisk added.( You can add any other portable tool you may want to)

Boot from this pendrive, run AOMEI Partition Assistant and post a screenshot of how your 500GB HDD looks like in it. You have to take a camera snapshot.

Use Bootice to examine the sectors. I would be interested in seeing the partition table, sector 0, sector 1 & 2.
On how to use bootice, Lost partitions!

You can also run TestDisk from this WInPE pen drive.

I have given you enough inputs to carryon the tasks as envisaged by you. Keep reporting on what you do.
My System SpecsSystem Spec
20 Feb 2015   #6

Windows 7 Ultimate x64

Ive been busy but will give all your suggestions a go now.
I will report back later.
Thanks again!
My System SpecsSystem Spec
20 Feb 2015   #7

Windows 7 Home Premium 32 bit

Take your own time and do it on your own pace. There is absolutely no need to hurry.

I am sure the data is still there and it is only a question of time and effort. As yourself have experienced, we may need to go back and forth, abandon one attempt and get onto another on the basis of any new information emerging etc., By its very nature of the devil, data recovery is going to be long and arduous except in very simple cases.

If you need any help in carrying out the suggestions, just give a shout.
My System SpecsSystem Spec
20 Feb 2015   #8

Windows 7 Professional 64-bit

I'm from the DOS 3.33-6.22, W31, WFW311 era where, with white powdered wigs, we did computing by candlelight. I'm wondering if similtaneous software streaming with other operations going on, over-powered Windows' write cache, hard-drive's write cache, and explorer.exe operations. My experiences with cross-linked files, CRC errors, unreadables...eventually lead to FDISK/Format/ReInstall Etal].
My System SpecsSystem Spec
20 Feb 2015   #9

Windows 7 Home Premium 32 bit

You seem to have missed the Fortran and Punched Cards bundle.
My System SpecsSystem Spec
20 Feb 2015   #10

Windows 7 Ultimate x64

Well, well, I have to thank you very much jumanji, even though some of the problem I had can be blamed on my lack of attention!

I started of with your first advice, using Testdisk again.
Instead of doing a deep search I did a Quick search (wich I did before but I was convinced a deep search was needed for some reason..).
Anyway the quick search did complete even though there were alot of errors reported, especially on the early sectors.
So, right away I started to look for the option capital "P", and there it was.
I hit the key, and all the files on the partition were listed!
Though I was somewhat unsure how to proceed I ended up with a backup of all the critical files on another disk :).

Even though I never did find, and probably never will find, the cause of the problem Im very very happy that the files could be saved atleast!
So yes, thanks for the suggestion about hitting P in Testdisk

This is pretty much the first time I ive been forced to use software with more or less no user interface, just text based.
But it was a good learning experience.
Technology have come a long way and most of the time its very easy for the user to get complexed things done in no time.
Sleek user interfaces and the click of a button is what I have been getting used to anyway.
Just shows how completely handfallen "the avarage user" feel when all that is pulled and you have to go back to use command-line based software and such.

Thanks for the help!

Edit: Just want to add that it probably was a hardware failure.
After backing up all the important files (of which 25% was damaged), I figured it doesnt matter if Im being drastic and just start to delete partitions and try to rebuild them.
But the EFI partition couldnt even be deleted. It just made that clicking sound indicating bad headers, and a message showing up saying something about I/O error. So the HDD is rapidly dying.
Im glad most could be saved atleast.
My System SpecsSystem Spec

 HDD with damaged filesystem refuses to be recognized

Thread Tools

Similar help and support threads
Thread Forum
WPD FileSystem Volume Driver & Audio
Not sure which discussion to place this in :p First my volume icon in the tray was displaying the muted symbol (i think, or could have been a red cross), i had a look and my Windows Audio service had stopped. I restarted it and audio works fine, but it randomly stops and im unsure why. Second...
General Discussion
Whole disk encryption for GPT filesystem running 7
If this is not the right spot for this post please move it. Thanks I have been working on a laptop for work and it has been very hard all the way around. Objective: Work has asked that I set up whole disk encryption on this laptop. Here is the story: This laptop originally had...
System Security
ZFS filesystem and NTFS filesystem
Hi, have a 20TB NAS box which runs on freenas. This box contains images / videos used for editing purpose. The software Fotostation is being used to manage images/videos. Issue is the images / videos are loaded very slow to the system (PC) from the NAS box. Iam checking the NAS box for resource...
General Discussion
HFS+ (Mac OS Extended) filesystem driver for windows?
Hi all, I have a question, is there a driver that will allow me to read/write HFS+ (mac os) partitions from windows 7? I have tried macdrive 8 but it wont find or open the disc. I tried HFSExplorer but that is read only, anyone got any ideas? Thanks, Sam
Win 7 copy corrupts Win XP filesystem
I have a new laptop, Win 7 Enterprise 64 bit. I have an old laptop Win XP SP3. I wanted to make a complete copy of my old hard drive to my new hard drive, so mounted the old laptop drive in an external USB enclosure and plugged it into the new laptop. Using Win 7's explorer, I select all the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:14.
Twitter Facebook Google+