Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Drive suddenly shows not initialized and not allocated

20 Feb 2015   #1

Windows 7 Professional 64bit
Drive suddenly shows not initialized and not allocated

I shouldn't say suddenly. It's a 2TB drive I had in an enclosure that took a bump off a short table the other day. It seemed fine when I tested it and pulled up all the folders. But when I went to move a file off of it, the drive disappeared. It shows up in drive manager as not initialized and not allocated. Working with a friend I tried Minitools Partition Wizard, Power Data Recovery, and Easy Recovery. None of them found anything, no partition and no files. I just wanted to check if there were any other suggestions before I gave it up. Seemed weird the folders and files showed up after the drop, then trying to actually access them made it trash itself. I figure it would be gone from the start. Thanks for any tips (if there are any).

My System SpecsSystem Spec
20 Feb 2015   #2

Windows 7 Home Premium 64 bit sp1

It looks like the drive is probably wrecked. It only takes a small knock to irreparably damage the heads particularly if the drive is actually powered & working at the time.
Some firms specialise in data recovery, but I have heard it is very expensive & would only be worth looking into, if the data on the drive was absolutely essential.
My System SpecsSystem Spec
21 Feb 2015   #3

Windows 7 Professional 64bit

Thanks. It actually wasn't powered when it bumped. I was hoping it would be okay. I just wanted to make sure there isn't anything else to try before throwing it away. There's some stuff I'd like to have off it, but am not going to send away and pay for.
My System SpecsSystem Spec


 Drive suddenly shows not initialized and not allocated

Thread Tools

Similar help and support threads
Thread Forum
External HDD shows Unknown, no size, Not Initialized
My external HDD has crashed after unplugging it accidentally while using it. I believe the directory structure has been corrupted. The external HDD shows Unknown, no size, and Not Initialized on the Disk Management screen: I have tried using MiniTool Partition Wizard as described in this...
Hardware & Devices
Portable 1TB WD Elements SE Un-allocated, Not Initialized & Unknown
Hello, My laptop's OS is 64 bit Win 7 Home Premium. I've been usng my Portable 1TB WD Elements SE external HDD for over 2 years. One fine day Win 7 displayed "Do you want to scan & fix removable drive G:" prompt. I check marked both subsequent boxes on the prompt and clicked Scan & Fix. After...
Hardware & Devices
disk manager shows DISK1 unknown and not initialized
Guys i have a similar problem but unlike the problem above my partition magic software does not read my external HD.. The device manager shows the HD is working properly.. and the disk manager shows DISK1 unknown and not initialized.. i m giving screen shot for both of them.. My external HD is WD...
Hardware & Devices
External HDD shows as Unknown, Not initialized, Unallocated. Restore?
Hello I got my 1tB WD external disk and it's not working as it used to. The problem came from nowhere, suddenly, totally unexpected. There is/was my precious data on it which I collected for 10+ years and I'd like not to lose it. Origin: It was working fine a day ago, no problems occured....
Backup and Restore
Previously functional USB3 external hard drive shows not initialized
Have a 1TB Iomega USB3 external hard drive that worked well on both a desktop and laptop Win7/64 system. Now it shows up as unidentified and not initialized using computer/manage/storage/disk management. Disk Management also gives the optiin to initialize it but I declined because I would like to...
Hardware & Devices
Flash drive suddenly shows as unformatted on win 7
hi, Basically, i want to transfer my music collection to my usb drive, but when i do so it transfers about 70% and then it says "could not find this item - this item is no longer located in...." it says that the item is not longer located on my usb... but i was trying to transfer it from my pc...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App