Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Invalid system partition

18 Aug 2013   #51

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Yes, it is fine for SSD.

My System SpecsSystem Spec
19 Aug 2013   #52

Windows 7 Home Premium 64-bit

Thanks SIW2. I tried it, googleing to see which one was my system partition. I thought it was C: 100mb so used that in disk part but didnt work. Then I got a reply from my friend saying no it's E: 60gb that I want. So I ran it again, trie that, and tried the boot mgr for all, but still doesnt work. I'm getting "Reboot and select proper boot device or insert boot media and press a key"...

My Bios is detecting my SSD but will not put it in the boot list??

Any ideas?

EDIT: AHA I'm getting somewhere, now I have got the SSD recognized as a boot device, I've got "BOOTMGR is missing
Press Ctrl Alt Del to restart"

My System SpecsSystem Spec
26 Mar 2014   #53

Win 7 x64

Hey guys - I'm in a bit of an emergency at work here.

I'm on an HP workstation, originally it has CentOS installed (I think on one HD), and XP on another - I installed another HD, and upgraded to Win 7. Everything has been working perfectly, even after about 4Gb of updates !
However, then what I needed to do was format the drive with XP on it so that I can use it to store our image sequences (VFX work).
After I killed the partition and told it to format (using free software from filehippo iirc) - it then won't boot into Win 7. It keeps trying to go into some kind of CentOS option list.
Using the previous commands - I can see that win 7 is still drive C/vol 1 but I can't seem to get it to boot at all.
(no options in the bios either) - I also tried disconnecting the other 2 HD's inside, and just the main Windows one but to no avail.

Argh, not sure what to do - and I've got a massive pile of work now haha.


lis vol

( find the vol letter e.g C or partition number e.g. 1 for the system partition )

sel vol C ( or sel vol 1 , obviously use the correct letter or number)



And tried

bootrec.exe /fixmbr
bootrec.exe /fixboot
bootrec.exe /ScanOs (finds it)
bootrec.exe /RebuildBcd (gives me the 3 options, yes/no/all - but says Eliment not found after Y or A)

I've got a feeling I need to some how get vol 1 set as primary.
My System SpecsSystem Spec

26 Mar 2014   #54

Win 7 x64

Hmm, according to the 'list partition' command it is primary.
No idea what to do - in a panic !

Disconnected the other drives again, and retrying the Win 7 DVD tools, it seems to have picked something up this time...

Ok I'm sort of getting somewhere.
When I disconnect the other 2 drives, whatever it did in that repair thing from the DVD allows me to boot up Win 7.
So I'm now trying to work out how to boot up but with the other drives connected, this seems to be what's causing a conflict.
My System SpecsSystem Spec
26 Mar 2014   #55

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Never mind that bootrec stuff, hit it with bcdboot.

bcdboot win7partitionletter:\windows /s otherdriveactivepartitionletter:

You don't have bcdboot.exe in your installed windows, so do it from the booted dvd.
My System SpecsSystem Spec
26 Mar 2014   #56

Win 7 x64

I shall give that a go in a moment, many thanks !
I'm just checking out Gparted to help out as well.
My System SpecsSystem Spec
26 Mar 2014   #57

Win 7 x64

Didn't work out for me, it's this ruddy Linux partition(s) - so I'm going to kill them, and someone else can install that another day

Well, I've re-arrange some cabling, pulled out the Linux drive and it boots into windows at least for now.
So I'll get our tech guy to look whenever he comes in next - serious weird stuff !
My System SpecsSystem Spec
26 Mar 2014   #58

windows 7 home basic

gparted is very bad.

if you have same issue again

use minitool media builder to create a usb flash partition manager.
boot from it
fix mbr or gpt whatever you had
My System SpecsSystem Spec
28 Mar 2014   #59

Win 7 x64

I found out why there was a problem, there is some kind of hard wired device in our systems that bring linux install thing up (and the SATA cabling order made a difference) !
So no amount of bits of software would actually solve my particular issue, anyway - for now it's cool and our tech guy will end up sorting something out in the future. But for now, thankfully things are ok.
My System SpecsSystem Spec
15 Sep 2015   #60

windows 7 professional 64bit
No valid system partition

Hi SIW2,

I've run into pretty much the same trouble and could really use your help. This is the most relevant page I've found.

I was using my pc when it just went to the bsod. No new hardware and since the problem disconnected all usb peripherals except my mouse. No new installation of software. I'm running windows 7 professional on an ocz vector ssd. I've tried swapping the memory sticks out as well and reconnecting the cables. I'm running the windows recovery wizard.

My ssd is no longer detected as a valid system partition. Both in command prompt (diskpart) and the partition wizard tool you linked to, my ssd is not listed at all. Is there anything else I could try? I can also no longer boot from the partition wizard iso cd and I'm given the error that it does not contain os files.
My System SpecsSystem Spec

 Invalid system partition

Thread Tools

Similar help and support threads
Thread Forum
Invalid Partition Table
I have been running Windows 7 Ultimate 64-bit for a loooong time and all of a sudden the other day while starting my PC I got a black screen (prior to windows loading) and the "Invalid Partition Table" Error. I have ran the WIN 7 fixers with zero luck bootrec /fixmbr bootrec /fixboot...
Hardware & Devices
invalid partition table
Hi all i am new to the forum, my problem is that i am running windows 7 32bit on my kids pc, but on my pc i am running windows 7 64bit. the problem is on my kids pc - don't know what they have or haven't done to it, but it won't boot up in windows and keeps saying invalid partition table. when i...
General Discussion
Invalid System Partition Problem
Hallo, So a couple days ago my Windows install decided to go kablooey. (I am dual-booting 7 and openSUSE but I'm removing SUSE once I fix Windows) I determined the cause to be an "invalid system partition." I found another thread involving some business about diskpart in the command line, so...
Backup and Restore
Partition invalid?????
Can anyone help please I have windows 7 installed into the only hard drive I have which is a 2tb, when I turn on my computer it won't load to windows instead I get a message: reboot and select proper boot device In system repair it says root cause found: boot sector code for system partition...
Hardware & Devices
Invalid partition table
also i can't run the Cd-rom for repairing....
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App