Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB not working after policy changes (Windows 7)

14 Mar 2015   #1

Win 7 HP 32bit.
USB not working after policy changes (Windows 7)

USB detail: Lexer 32GB

The cause of the problem or what I think it might be the cause:
I noticed that the transferring rate is very slow from my PC to the USB, so I change the policy setting for that USB drive to be more optimistic (I think the actual option is called cache something something with a check box) using Device Manager. However, the Lexar USB properties setting crashed while I was changing the USB policy. First I tried to stop the properties setting by using task manager, but that didn't work, so I unplugged the USB from the port and the entire DM and the properties setting close itself. However, now whenever I plug in that USB, it didn't work anymore.

To be more specific as to what happens when I plugged in that USB now. The light in the USB will always be on at all time. Not showing up in my computer nor auto running. Shows up in DM with message saying 'this device works properly', but when I go look at the capacity information, it display nothing, also tries updating the drive and uninstalling it while I was in DM, but always seem to be stuck. Tries to find it in Disk Manager, but couldn't find anything about a 32GB drive.

I have tried the following:
1. Plugging other USB mass storage device = works
2. Plugging that Lexer in another PC = works

So my conclusion is that my PC reads other USB mass storage drive, but not this Lexer one. What can I do so that I can use my Lexer USB again?
My System SpecsSystem Spec
20 Mar 2015   #2

Windows 7 Ultimate 64 bit

can the USB recognize in the task bar during installation?... if not..
Remove the USB.. switch of the pc... remove power cable..wait for 30 min... again plug in and restart your pc after that install the USB.. check it now..
Regards :)
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Group policy wallpaper not working for non-admin accounts
We have a special image that I am required to have on all PC's at my job and I usually just enable the desktop wallpaper in group policy and point it to the path. This has worked for as long as I can remember. In windows 7 group policy editor, I set the desktop wallpaper in: User Configuration...
Diagnostic Policy Service not working
Hello All I am looking for help with a problem I am having with my laptop Dell Inspiron 1545 O/S Windows 7 Home Pemium. It has stopped connecting to the internet through the house wireless router although all other devices in the house can connect. If I try to run troubleshooter I cannot and get...
Network & Sharing
Group Client Policy / Admin issues / links not working / files missing
Hi 2008 Dell Precision T7400 with Base Dual Intel Xeon E5420 (2.50GHz,1333FSB,2x6MB,Quad Core) Memory 8GB, 667MHz, ECC Memory (8x1GB) Video Card 512MB PCIe x16 nVidia Quadro FX 1700 (MRGA14L), Dual Monitor DVI or VGA Graphics Card Hard Drive 320GB (7,200 rpm) SATA 3.0Gb/s Hard Drive with...
General Discussion
Group Policy Applies Policy EXCEPT for 1 Setting!
Hi all! Windows 7 Pro 32 bit on a domain I've NEVER seen this before and I cant figure it out. I have a group policy set on an OU named LAPTOPS. The policy gets applied, however the User Config\Windows Setting\Scripts\Logon DOES NOT. When you run the GPRESULTS on the laptop, I see the...
General Discussion
Group Policy Editor or Local Security Policy
Will either of these allow me to restrict drive access to a single user only? I've tried to restrict drive access with Group Policy Editor but it applies the restriction globally--even to me the administrator. Could anyone let me know if this is possible and how to do it? Much thanks.
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:13.
Twitter Facebook