Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Ports Not Working

04 Apr 2015   #1
Devlin1888

Windows 7 Home Premium 64Bit
 
 
USB Ports Not Working

Hey there
Basically, I was just using my comp as normal, went to bed, got up, turned on pc and all of my usb ports weren't working, checked device manager they all had ! next to them, thought ok, il simply uninstall and reinstall and i should be fine. This was not the case, they just keep going back to the same state after reinstalling. Any ideas?
Cheers


My System SpecsSystem Spec
.
04 Apr 2015   #2
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

1. BIOS change (on its own mysteriously)
2. Fault in Southbridge
3. Fault in USB Controller (May be part of Southbridge)
4. Malware

I would suspect hardware though, to be honest.
My System SpecsSystem Spec
04 Apr 2015   #3
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

I had the same problem the other day. Uninstall the drivers and reboot fixed it.
My System SpecsSystem Spec
.

05 Apr 2015   #4
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

My System SpecsSystem Spec
05 Apr 2015   #5
Devlin1888

Windows 7 Home Premium 64Bit
 
 

Quote   Quote: Originally Posted by whs View Post
I had the same problem the other day. Uninstall the drivers and reboot fixed it.
Ive done that many times WHS, AGUY, Followed that as well, already done it several times to no avail
My System SpecsSystem Spec
05 Apr 2015   #6
Devlin1888

Windows 7 Home Premium 64Bit
 
 

My System SpecsSystem Spec
05 Apr 2015   #7
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

I'm glad I was wrong. Great that you got it fixed without a hardware problem. :)
My System SpecsSystem Spec
05 Apr 2015   #8
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Very good. The upper/lower filter problem used to be a big problem for optical drives in Vista. I had not seen that since a long time and never for USB drives. Good to know that this is a possibility for USBs too.
My System SpecsSystem Spec
05 Apr 2015   #9
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

We used to always recommend the upper/lower filters :) Hadn't seen it in quite a while

A Guy
My System SpecsSystem Spec
Reply

 USB Ports Not Working




Thread Tools




Similar help and support threads
Thread Forum
USB 3.0 Ports Not Working
I just bought a new Kingston Ultimate 32 GB USB 3.0 flash drive. It works fine in my 2.0 ports but will only light up in the 3.0 ports and Windows 7 64 bit does not see it. I have enabled the USB 3.0 ports in my BIOS and I have got the latest NEC USB 3.0 driver for my MSI P55-GD85 motherboard. ...
Hardware & Devices
USB Ports Not Working
Last night I was transferring some files from my laptop to my external hard drive and everything was working fine but then a couple hours later, I went to plug in some rechargeable USB batteries that I have and noticed that they weren't lighting up. I then tried plugging in several of my other USB...
Hardware & Devices
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
USB ports not working...PLEASE help!
My computer crashed and I had to take it in for repair. They put Windows 7 on it and I am liking it so far. However, none of the USB ports work. I work from home and all of my files are on an external hard drive so this is a big problem! I have a Dell Inspiron E1505. I have tried...
Hardware & Devices
USB ports not working
When a USB device such as a flash drive is plugged in, the computer does not react at all. It does not find the device nor does it show (not even as unknown) in the device list. However when I boot the computer with the device plugged in, it works fine. IThis may be related. I have an 'Unknown...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:24.
Twitter Facebook Google+