Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Device driver software was not successfully installed

07 Apr 2015   #1

Windows 7 Professional 64bit
Device driver software was not successfully installed

My system just recently getting this error message from Windows 7. All my keyboard and mouse are disabled due to this error. I tried all usb ports and once I plug in the device, it displays this error message, then stuck. I can once use my ps2 keyboard to access the windows, but now the windows locks up all my input devices.

Does anyone experience this before?

I used Malwarebytes to scan, nothing found.
I used Xfrot to scan for virus, nothing found.

Other than re-install the windows, any suggestion?
My System SpecsSystem Spec
07 Apr 2015   #2


Have you tried going into the device manager and looking for any yellow marked items? Something similar was seen with Vista as well with usb drives. USB Drive Problems with Vista

Either right clicking to uninstall followed by a full restart or to have Windows perform an automatic search won't always work. A manual search by selecting the device from the list of devices will often see Windows install the correct generic driver where you end up with "Windows has successfully installed your new hardware" type message.
My System SpecsSystem Spec
08 Apr 2015   #3

Windows 7 Ultimate 64 bit

We really need to know the make/model of your PC/Motherboard to help you further, In the meantime if you know these details go to the mobo website and download the chipset drivers and reinstall them
My System SpecsSystem Spec

09 Apr 2015   #4

Windows 7 Professional 64bit

I managed to use PS2 keyboard to boot up the system. I did the uninstall of some exclaimation marks unknown drivers, even the USB receiver driver was uninstalled. I then try to find the driver from the original Asus CD, but no driver can be found. After the reboot, even my ps2 port is locked up.

Asus MAXIMUS IV Extreme
Kingston HyperX 4x8GB 1600
Windows 7 Professional 64b
My System SpecsSystem Spec
10 Apr 2015   #5

Windows 7 Ultimate 64 bit

Try these one,
Download USB driver for Your mobo from here...USB driver ASUS Maximus iv Extreme
Hope it helps
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Device driver software not successfully installed.
So i've just took of windows 10 and put windows 7 on instead, im sure you know why. And since then none of my usb devices will connect and install their drivers. my usb mouse and keyboard essentially do not work. I've been at it for hours trying to update drivers and such but nothing is working. Im...
Device driver software not successfully installed--OK, but which?
Had a problem (user profile), so reverted to last usable configuration. Now I get a message that "device driver software was not successfully installed." That would be easier to fix if I knew which device was meant. Device Manager shows two USB devices with exclamation marks, each marked...
Device driver software was not successfully installed.
Screenshot I installed windows 7 Ult on my Toshiba satellite l50 laptop (which had no operating systems installed at the time). No programs were installed and 7 drivers weren't recognised. I used the same installation CD to install Windows 7 on VMware (on my desktop) and the drivers were...
Error: Device driver software was not successfully installed
Most times when I start my machine or just turn on my monitors (the Windows Display setting is set to turn off at 20 minutes, sleep is set to Never), I find that Windows is installing software. Sometimes it's successful, sometimes it fails. I see others have had this issue, but the offered...
General Discussion
Device driver software was not successfully installed, Daemon T, more
Yesterday I upgraded hardware from: AMD Athlon X2 4600+ & Mobo to: Core i5 3570K and Asus P8H77-I mobo. I think it's since then, that I can't install some drivers. I first noticed when I was going to use Daemon Tools Lite, there weren't any drives so i clicked "Add device" in D-tools...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:09.
Twitter Facebook