Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Devices in Windows 7 Problems (video)

08 Nov 2009   #1
Smile

Windows 7 64-bit
 
 
USB Devices in Windows 7 Problems (video)

Hello everybody! By now (if you have seen my other threads) you are getting tired of me looking for help :P but I still have not fixed this problem. USB devices are making my computer freeze and I will list below. I am uploading a video onto youtube as I am typing this. Also I tested all these devices on all 6 of my USB ports on my W7 Desktop the same results and all 3 USB ports on my W7 Laptop. They all work on my laptop. ALSO THERE IS NO "SAFELY REMOVE DEVICE" AT ALL.

USB Devices that freeze my PC (AT ONE STAGE THESE DEVICES WORKED)
  • Toshiba Flash Drive 2gb
  • WD Elements External Hard Drive 320gb; WD3200E035-00
  • Lexar Flash Drive 4gb
USB Devices that DON'T freeze my PC
  • Edifier USB Speakers
  • Logitek LX310 Laser Wireless Keyboard and mouse
  • PowerWave Xbox360 rip off controller
  • My Mobile Phone
  • My Camera used to make the video
  • GH3 X-Plorer guitar Xbox360 USB
VIDEO
[ame="http://www.youtube.com/watch?v=2Gqwn4rFYpM"]YouTube- USB Hard/Flash Drive freezes windows 7 D:[/ame]

Thank you and if you need specs they are all on my page, feel free to ask about my pc/specs more though.

~Smile


My System SpecsSystem Spec
.
08 Nov 2009   #2
whest

XP, Vista, W7 64bit Home Premium
 
 

Have you any unknown devices in device manager with a yellow asterisk next to them?
My System SpecsSystem Spec
08 Nov 2009   #3
Smile

Windows 7 64-bit
 
 

Quote   Quote: Originally Posted by whest View Post
Have you any unknown devices in device manager with a yellow asterisk next to them?
How can I check this? I have forgotten how to get there.

Thanks.

~Smile

EDIT: Device Manager; All objects in device manager are fine, just average icons.

My System SpecsSystem Spec
.

08 Nov 2009   #4
whest

XP, Vista, W7 64bit Home Premium
 
 

Just type device manager in search and select. I think there is a known problem with usb devces and they are working on a fix.

Only other thing i can think of is bios update, and do you have a sata drive, if so whats enabled under sata configuration? - sata as IDE, Raid or AHCI.
My System SpecsSystem Spec
08 Nov 2009   #5
Smile

Windows 7 64-bit
 
 

Quote   Quote: Originally Posted by whest View Post
Just type device manager in search and select. I think there is a known problem with usb devces and they are working on a fix.

Only other thing i can think of is bios update, and do you have a sata drive, if so whats enabled under sata configuration? - sata as IDE, Raid or AHCI.
Okay, I did get device manager up. Everything looked fine. I will look around to see how to find if i have a sata drive and if its IDE raid or AHCI. After my computers hard dive in device manager it says ATA if that means anything.


ALSO these devices used to work on my pc they just stopped randomly. and i have re-installed my OS.

Also I have a sata drive because the cords are the new ones not the old ones, apparantly by google. Now Ill go look at the options. Looked at all options in boot... nothing about SATA or IDE raid or AHCI.
My System SpecsSystem Spec
08 Nov 2009   #6
Smile

Windows 7 64-bit
 
 

Could you also give me a way to upgrade my bios? I have a EG31M-S2 and I have never tried bios updating before. Thanks.

~Smile
My System SpecsSystem Spec
08 Nov 2009   #7
zx81

Windows 7 Home Premium x64
 
 

My System SpecsSystem Spec
08 Nov 2009   #8
zx81

Windows 7 Home Premium x64
 
 

GIGABYTE - Support&Download - Motherboard - Manual Download

Is a manual of your system, in chapter 4 you find instructions how to upgrade/flash your BIOS.

Best regards,

zx81
My System SpecsSystem Spec
08 Nov 2009   #9
Smile

Windows 7 64-bit
 
 

Thank you ZX81, I have updated my bios to Rev. 2.0

Now just to see what happens when I plug USB's in.
My System SpecsSystem Spec
08 Nov 2009   #10
Smile

Windows 7 64-bit
 
 

After Plugging in a USB it does still freeze. Although:
Quote:
On-chip SATA Mode [Auto]
(Blanked out) PATA IDE Set to [Disabled]
SATA Port0/2 Set to [Ch.0 Master/Slave]
SATA Port1/3 Set to [Ch.1 Master/Slave]
Thats the only SATA related options in bios setup. I can see. Also After Opening up my PC The cord is plugged into SATA 2_0 and my DVD-Rom drive is SATA 2_1.


^ After Bios Update.
My System SpecsSystem Spec
Reply

 USB Devices in Windows 7 Problems (video)




Thread Tools




Similar help and support threads
Thread Forum
Video and image capture problems on windows 7 64 bits
Hello, I want to capture screen flow in video or image on windows 7 64 bits system, with NVidia Quadro 600 graphic card (driver is up to date). I use lib vlc for video capture, or "print screen" button for image capture. When I try to capture a fullscreen opengl application, or a QML...
Music, Pictures & Video
Problem - Audio Devices Disappear (video inside)
When i press "Playback Devices" \ "Recording Devices" I can see my devices for a split second. then they disappear. really weird problem is there a solution ? Video Example made by me: cC-rNzDmsBs (it happens also in task manager.) How can i fix that?
Sound & Audio
Windows 7 Audio and Video Problems
I know I'm too late coz' I just recently upgraded to windows 7 from XP :) But I'm having problems with my audio and video after installing winodws 7 I already installed latest drivers for both but my audio has some kind of static noise. It is lessen when I set it to minimum bit and hertz but i...
Hardware & Devices
Graphics card seems to have problems with many video devices?
I've tried two webcams, made by Logitech and HP, respectively. I have also tried using an HDMI cable. Crashes have occurred when any of these devices were connected to the computer. I currently have the HP webcam connected but if I end the Hpqsrmon.exe process, I have no problems with crashing....
Graphic Cards
Problems adding devices in Windows 7
Can't figure this one out... nothing appears on the "add a device" screen where Windows 7 is supposed to be looking for new devices. No matter how long I wait.... never. No printer, no camera and no PDA. The computer makes a noise confirming attachment of the devices and also when I unplug...
Hardware & Devices
Windows 7 video card overheating problems?
Hello, I have recently upgraded to Windows 7 RC1 on my main machine. When playing pc video games, specifically Left 4 Dead, the game will freeze at randoms parts. After doing alot of different fixes the main resolution was to set my video cards fan to 100% speed. Keep in mind the game ran...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App