Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External HDD corrupting? Cannot view in Explorer or Disk Management

03 May 2015   #1
xyman621

Windows 7 Ultimate x64
 
 
External HDD corrupting? Cannot view in Explorer or Disk Management

I have a WD MyBook 3 TB external HDD. I can see the drive letter in Windows Explorer but the name I had for it is no longer there and the window freezes when trying to access it, disallowing viewing of any files. I was going to take a look at in through Disk Management, but when opening DiskMgmt with the hard drive plugged in the window never opens and reads 'Connecting to Virtual Disk Service'. When the hard drive is unplugged I can use Disk Management just fine.

The drive is able to be viewed in Device Manager. I tried uninstalling the drivers but this did not work.

I am currently running a "chkdsk /r" on the drive. It has been running for about 9 hours now and is 0% complete on verifying files and folders. (see image) Before it started this step I noticed it was back to normal in Windows Explorer, but I did not try to open the drive to view any folders. It also showed up in Disk Management as that was open in the background when I started the command.
I found this very odd, because once this step started it was back to the issues before.
Do you think the chkdsk is working properly? I can hear the disks spinning and the light is flashing like it is being used. I would like to preserve the 2 TB of data in use, but if it's not an option I would just like to be able to use the hard drive again.
Would quitting out of this cause damage?

External HDD corrupting? Cannot view in Explorer or Disk Management-chkdsk.png

The issue started after using my netgear r6300v2 ReadyShare feature. I used this in the past with success, but stopped since it took forever to reindex and view folders/files when I accessed it through DLNA on my ps3. I was going through the files that were showing up and it suddenly stopped working. The drive was not even viewable through the routers settings after this happened, and all the issues listed above started showing.

I have tried it on another PC and received the same issues as well.

Any thoughts or advice? Should I just leave the chkdsk running? Should I kill it and try to duplicate the results where it appeared to be back to normal - just run a chkdsk instead of a chkdsk /r?
Any thoughts or advice would be greatly appreciated.




My System SpecsSystem Spec
.
03 May 2015   #2
Berton

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP
 
 

A problem I see in the picture is that it mentions "the type of file system is FAT32". The size of the drive is too large for FAT32 so would have to be formatted as NTFS but doing so will delete any files on it.
https://www.google.com/search?site=&....0.4p_d-Le6H9U
My System SpecsSystem Spec
03 May 2015   #3
xyman621

Windows 7 Ultimate x64
 
 

FAT32 can handle up to 16TB. The 32GB limit is set to promote the NTFS and because it is more efficient to use in larger partitions. I reformatted it to FAT32 a couple years ago and never had issues till now. Could it be hung in the chkdsk because it is not NTFS?

How To Format A Large Hard Drive With Either FAT Or FAT32
My System SpecsSystem Spec
.

04 May 2015   #4
MightyMiroWD

Windows 7
 
 

Hi there.

I agree with the others - reformat the drive in NTFS and see if this will solve the issue. If it continues to act the same way, run a test on the My Book with Data Lifeguard Diagnostics to see if anything wrong will be detected. You can download it from here:

Support Answers

Let us know how it went. :)
My System SpecsSystem Spec
04 May 2015   #5
xyman621

Windows 7 Ultimate x64
 
 

Well I cancelled out of the "chkdsk /r" command because it still wasn't moving after 36+ hours. I decided to run only "chkdsk" after that. For some reason the drive then showed up like it was back to normal and I am able to view the files finally. I will be taking your guy's advice and reformatting to NTFS after I try to back up some of the 2TB of data on the hdd.

Here are the results of running "chkdsk E:" Any thoughts about what it says here?

External HDD corrupting? Cannot view in Explorer or Disk Management-chkdsk3.png


My System SpecsSystem Spec
Reply

 External HDD corrupting? Cannot view in Explorer or Disk Management




Thread Tools




Similar help and support threads
Thread Forum
External Drive does not show up in disk management
Hello New Seagate external 8 TB drive. Did not format because it showed up in MY Computer. Drive crashed after trying to copy to it - it did show up in Disk Management,said "Disk 8 Unknown" "Not initialized." could not format. unplugged and replugged power and usb cable and restarted computer - no...
Hardware & Devices
brand new external drive not showing up (not even in disk management!)
I bought a brand new U12-43837 Ultra 500GB external hard drive but as soon as I hook it up to the computer, the computer recognizes the drive, installs the driver, makes the hardware insert sound, but the drive does not appear in My Computer, nor does it appear in Disk Management. A few threads on...
Hardware & Devices
External USB HDD not showing in My Computer or Disk Management
Hi all, I had a problem of Windows 7 x64 Pro not seeing my 8TB Seagate USB HDD no matter what I tried, it just would not show anywhere except in "Devices and printers" and there was nothing I could do with it there! After several weeks and hours spent on the net searching for an answer I struck...
Hardware & Devices
External HDD won't show up in Disk Management or Explorer
My WD Passport 320gb external drive is not recognised. When I plug it in the light comes on and i can hear the disk fine as normal. But it won't show up in either My Computer or Disk Management. I've tried Re-Scanning is Disk Management, as well as every single USB port on my Toshiba Equiuim...
Hardware & Devices
Can't find my external HDD in Disk Management
Ok, so I was formating my external HDD to a FAT32 and right after I deleted the volume in the disk management it disappeared in the Disk Management. I can't still see it in the device manager and am able to eject it. I also have restarted my computer a few times and gave a good amount of time in...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:54.
Twitter Facebook Google+