Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unspecified device - MS Mouse

08 Nov 2009   #1
cb900f2

Vista
 
 
Unspecified device - MS Mouse

Hey guys.. Gotta say.. Really like Win7... With that being said.. I have a little bug with my MS wireless mouse..

Under the Device and Printers my MS mouse was found initially as win7 found it as "Microsoft wireless optical mouse 1.0a".. There was a update that MS sent via update and was to update device drivers, and now under the same D&P view, my mouse model has changed to "Microsoft Wireless Optical Mouse 5000" , but in the section below for "unspecified" I am getting the icon for "Microsoft Wireless Optical Mouse 1.0a"..

If I unplug my mouse form my box, both icons for the mouse disappear, and if I replug it back in, both of these icons re appear..

Any reason why the OS is finding the new driver and putting the old driver in the "unspecified" section?? and how do I either get rid or correct this issue??

I attached a screen shot

Thanks guys!




Attached Thumbnails
Unspecified device - MS Mouse-win7_mouse-driver.png  
My System SpecsSystem Spec
.
10 Nov 2009   #2
cb900f2

Vista
 
 

bump for help...
My System SpecsSystem Spec
12 Nov 2009   #3
zBobG

XP SP3 32bit, Vista HP 64bit, Seven Pro 64bit
 
 

Go to Device Manager (not the Devices page in your pic), find the device, it should have a yellow sign with an exclanation mark, right-click it, click Uninstall.

It is safe to do this, if the device needs to be there it will reinstall. If the device does not need to be there it won't show up again.

I'm sure the reason both devices are listed is because they both have the same device ID. Just get rid of the one that has the exclamation mark.
My System SpecsSystem Spec
.

12 Nov 2009   #4
cb900f2

Vista
 
 

Hi Bob... Thaks for the feedback.... I should have noted that in the device manger I am getting no conflicts or errors with the mouse driver..



Quote   Quote: Originally Posted by zBobG View Post
Go to Device Manager (not the Devices page in your pic), find the device, it should have a yellow sign with an exclanation mark, right-click it, click Uninstall.

It is safe to do this, if the device needs to be there it will reinstall. If the device does not need to be there it won't show up again.

I'm sure the reason both devices are listed is because they both have the same device ID. Just get rid of the one that has the exclamation mark.
My System SpecsSystem Spec
13 Nov 2009   #5
zBobG

XP SP3 32bit, Vista HP 64bit, Seven Pro 64bit
 
 

The "HID keyboard device" is NOT the same as the "HID mouse device".

According to your picture everything's fine. Don't remove anything!

Are you still getting the "unspecified" thing?

I have no idea where that is from or what to do about it.

If it were my computer I might look for a duplicate device in the HKLM/System/CurrentControlSet/Enum key. A duplicate device entry could be removed. Don't go poking around in the registry if you are not very familiar with registry editing, and in any case set a restore point before changing anything in the registry.
My System SpecsSystem Spec
16 Nov 2009   #6
cb900f2

Vista
 
 

Fix the probolem.. Thanks guys!
My System SpecsSystem Spec
16 Nov 2009   #7
Tews

64-bit Windows 8.1 Pro
 
 

How about sharing your fix with the rest of the community?
My System SpecsSystem Spec
16 Nov 2009   #8
cb900f2

Vista
 
 

Good point..

All I did was right click on the top mouse device on the top section of the devices => open properties => tabbed to hardware; double clicked on the HID-compliant mouse driver, then all of sudden the unspecific device went away


Quote   Quote: Originally Posted by Tews View Post
How about sharing your fix with the rest of the community?
My System SpecsSystem Spec
16 Dec 2010   #9
emaleroland

Windows 7 Professional x64
 
 

After he double-clicked on the driver (and this goes for mouse or printer), you then need to select the properties button, driver tab and then uninstall button. This will remove the unspecified device from your system.
My System SpecsSystem Spec
07 Jan 2011   #10
124c41gun

Windows 7 Untimate
 
 
How to get rid of an unspecified device?

I had an old printer installed on an HP PC. It died. I bought a new printer. I installed the new printer according to the rules on HP's web site using an alternative driver. The installation seemed to go well. But as soon as I plug in the USB cable, an "Unspecified Device" with the name of the old printer shows up. And I can't print to anything. If I unplug the cable the unspecified device goes away but of course I can't print. I found the name of the old printer in Device Manager and uninstalled it. I plug the cable in and it's back, kind of like the monster in a horror movie. In Devices and Printers, when you click on a Device or Printer you get an option to Remove the Device, but not with unspecified devices. I've tried all the things I've found on the web, the old printer is still there.
My System SpecsSystem Spec
Reply

 Unspecified device - MS Mouse




Thread Tools




Similar help and support threads
Thread Forum
Win 7 - Only USB device that will work is a USB mouse
Hey Everyone, it's been a while since I've been stuck but I'm there. I've uploaded my system specs. I'll do the best I can to go through my issue. Only my 2 front USB ports will work now. I have a front panel/card that has USB 2.0 & 3.0 ports that is dead and all of my rear ports are dead....
Hardware & Devices
usb device causing glitchiness in keyboard and mouse
Hello i have bought a flirc usb device to use with my remote controls, i have successfully installed the correct drivers for this device but when i insert the device my mouse and key board randomly becomes inactive. i have contacted the developer and he says he has never heard of anything like...
Hardware & Devices
Remove Unspecified Device
Hi there, hope someone can help me, i've searched the web and could not solve this very simple problem. I installed a HP printer with the driver that i used for Win XP, it didn't work, i came to find out that for my printer (Deskjet 3820) to work on Win 7 i have to use the driver for a similar...
Hardware & Devices
Audio device and Mouse keep disconnecting, and reconnecting
Ever since i started using Windows 7, my mouse and my audio drivers seem to keep resetting. I have made sure all my drivers for all my Windows components are up to date. I was using the built-in RealTech audio that came with my Asus P8Z68V motherboard, and every few minutes I would see the...
Hardware & Devices
HP Laserjet 1012 recognized as an Unspecified device
When I try to set up a Laserjet 1012 on 32 bit Windows 7, the machine chooses IEEE 1284.4 generic printer drivers, and the installation fails. The printer shows up as an HP 1012 under Unspecified devices, and nothing new shows up under Printers and Faxes. I have HP VIsta drivers that HP...
Hardware & Devices
printer shows up as Unspecified device??
hi all, just installed win 7 on the new HD. epson printer installed fine. my okidata, using the latest downloaded 64 bit driver, shows up in the "unspecified" devices category instead of in printers. unusable as it will not show when i try to print. tried multiple install/uninstalls. how to get...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App