Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't make logical partitions with Minitool; disagrees with Win7/Linux

06 Jun 2015   #1

Windows Professional 64bit
Can't make logical partitions with Minitool; disagrees with Win7/Linux

This is an HP Zbook 15 with a 256G m2.SATA SSD drive running Win7 Professional 64bit.

I've been trying to get a dual boot setup on a new laptop and running into some various issues. Troubleshooting involved trying various partition schemes, as I wasn't sure if the issue was related to having /boot for Linux on a logical partition, trying to have an encrypted root on a separate partition, some issue with EasyBCD (which I'm trying to use to chainload my linux install from Win7), or who knows what.

In any case, I have a way forward now and am trying to create the following partition scheme:
- SYSTEM, 1GB (laptop came with this and sounds like I shouldn't move it)
- C:, ~80G (win7)
- Shared data partition for win7/Linux, to be encrypted with TrueCrypt (~100G)
- /boot partition for Linux (256M)
- root partition for Linux (~50G)

I actually started with this scheme, but for some reason I can't recreate it. When I try to create one or more logical partitions using Minitool Partition Wizard, a dialog appears stating that the operation applied successfully... but the space just reverts to "unallocated."

I need Minitool to set the type ID to 0x83 for linux, so I thought a workaround would be to use the win7 built-in partition editor to create the space and then just change the type ID from Minitool. No luck! Upon trying this, I see that Minitool and the win7 utility don't agree on what the partition scheme actually is!

How can I diagnose this issue? Here are some screenshots of the issue, using the following procedure as a starting point (feel free to suggest different steps/order):
- Delete all volumes/partitions after C:
- Create primary partition of ~100G, NTFS formatted
- Create logical partition of 256M, unformatted
- Create logical partition with remaining space, unformatted

win7 utility after deleting existing partitions:

win7 utility after creating scheme above:


Output of fdisk -l (from live linux CD):

Invalid flag 0x7d9b of EBR (for partition 5) will be corrected by w(rite).
Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x1e6513b3

Device     Boot      Start        End    Sectors   Size Id Type
/dev/sda1  *          2048    2101247    2099200     1G  7 HPFS/NTFS/exFAT
/dev/sda2          2101248  172433407  170332160  81.2G  7 HPFS/NTFS/exFAT
/dev/sda3        172433408  387473407  215040000 102.6G  7 HPFS/NTFS/exFAT
/dev/sda4        387473408  500115455  112642048  53.7G  f W95 Ext'd (LBA)
/dev/sda5       2961659748 5859253686 2897593939   1.4T 65 Novell Netware 386
So, obviously something's up. To further complicate, the computer is encrypted with McAfee Endpoint Encryption, so I'm extremely hesitant of just using fdisk to edit the partition table and try to fix it, as I don't know if that will botch anything with the encrypted bootloader or other files used at startup to decrypt.

Any suggestions? I've tried the following other things:
- primary partition: I can successfully create two primary partitions instead of 1 primary + 2 logical, but this won't work for my setup
- order: I've tried primary first, then two logical and vice versa. When putting the primary at the end, the space between C and the primary stays as "unallocated" from Minitool
- bigger /boot partition: I've tried 128M, 256M, 4G, and even 10G in case this was a size issue. Doesn't matter.
- ignoring Minitool: since Minitool allows adding steps, and then applying them all at once, I thought maybe I could just create them how I wanted (including adding hanging type ID to the steps), apply them all, and just accept that Minitool doesn't see them correctly. Unfortunately, when I do that, fdisk from Linux doesn't see them correctly either.
- resizing/shrinking win7: I deleted all non windows partitions, grew the volume to the full disk, and then shrunk it again.
- zeroing non-win7 area of drive: I shrank win7 to ~80G, created a single primary partition, formatted it from live Linux CD with ext4, and then dd'd /dev/zero until it was full, then deleted the file.

I'm out of my league with reasons partition tools wouldn't agree... can anyone offer suggetions? Many thanks!

My System SpecsSystem Spec
06 Jun 2015   #2

Windows 7 x64 Ultimate

If you're trying to dual boot Linux, why not just install it side-by-side with the Windows partition? I know it's not the solution you're necessarily looking for but it works just as well to reach your main goal to dual boot the two.... I did this on my desktop and laptop (with Ubuntu 14.04 I think) and have the GRUB boot switcher program to choose which OS to boot. (This gets installed if you make a bootable Linux installation USB and choose to install side-by-side windows.) It saps a little space from your windows partition to use for linux but I don't know how that works with expanding partition space and stuff. I just use the Unix environment for C programming and I am hardly using any of the 50gb I initially allocated for the OS (maybe using 1gb total for data?)

If dual booting is what you wish to accomplish I would try this.... if you're hellbent on partitioning your HD I would recommend using PartedMagic or Partition Wizard (DL and burn iso file to a disc and make it bootable, you can use a tool like img burn or something, can't remember how I did it) and try partitioning with that. If no other partition program works for you I would recommend you back up that hard drive, erase all partitions, format completely anew, and then create 2 partitions for both windows and linux OS. Follow an online guide for installing linux onto a clean partition, there are some extra steps you might need to do -- note I have never installed linux bare like this! Install Windows LAST on the second partition you set aside for that OS. I would also make a note of your product key for windows so when you install it again you can activate it properly.

Good luck!!
My System SpecsSystem Spec
06 Jun 2015   #3

Windows Professional 64bit

@youngrankUMD: thanks for the reply, and I think I understand what you're suggesting... namely to install a linux bootloader (e.g. grub, syslinux, etc.) and then chainload windows. I realize I'm dumping more information on you after the fact, but I linked to a fuller explanation of my situation in the original post. This is a work computer with full disk encryption, including the MBR.

So, I can't overwrite the existing bootloader, as it alone knows where to find the file necessary to unlock the C: partition for windows. Or at least that's my understanding. From looking at some McAfee Endpoint Encryption docs, I believe the above to be the case, anyway:

IMPORTANT: If you have EEPC installed, never reset or replace the MBR using FDISK /MBR or FixBoot /FixMBR f because it disables the preboot authentication that EEPC requires to operate. If this happens, you must perform an emergency boot to fix the issue.
What does work is to leave the windows bootloader intact and point it at a linux installation instead. I've done this successfully in the past, and am trying to do the same.

Nevertheless... the main issue I'm trying to solve is why the windows partition utility would disagree with Minitool and/or Linux. I'm planning to try and backup the existing MBR/partition table, edit the partition table with fdisk, and see if it botches the windows functionality. If so, I can dd the backup to the drive and walk away. If it does work, well awesome!

When you say "side-by-side," is there anything intrinsically different from what I'm trying to do? As in, I need a partition for windows, and one for linux... so I'm still stuck with needing a proper partition table, and something isn't right at the moment. I'd like to use linux-based tools as well, I just haven't figured out if it'll play nicely with the encryption, hence trying to accomplish everything from within windows.

It was working, but after trying numerous partition schemes to troubleshoot some other issues, now things aren't and I don't know why.

Thanks for any suggestion! (And, sorry again to reveal further information... I was just trying to keep the issue simple and focus on the current problem vs. the whole scenario).
My System SpecsSystem Spec


 Can't make logical partitions with Minitool; disagrees with Win7/Linux

Thread Tools

Similar help and support threads
Thread Forum
Help me make a WinPE for Minitool Partition Wizard help
Hi, This is my first post here and I am in dire need to make a WinPE for MiniTool Partition Wizard Pro version 7.7. My pc does not detect my external drive efficiently when using Linux bootable cd so I have been using WinPE discs of Acronis True Image 2011 which I have created with it's Plus...
Backup and Restore
Merge partition seems stuck using minitool partitions
Trying merge F: drive, 1TB into E Drive, 6TB. But the process seems stucked at "Merge Partition" stage 66%. Already 5 hours, still stuck at 66% What should I do ?
Logical Partitions to primary
Recently I make new partition using "AOMEI Partition Assistant Pro Edition 5.2" but my both new partitions goes to logical how can I make them back to primary because I wanna install windows xp on new partition but setup shows an error while installing " you have no hard drive to install the...
Installation & Setup
MiniTool Partition Wizard reports different partitions to others
Hello everyone Very much a newbie to this OS and to partitioning with MiniTool Partition Wizard. It seems lots of folk here use this tool so as I can't find an answer anywhere to this thing that's bugging me ... . I installed and used 'MT' to 'Expand' my C drive, taking a chunk from the D...
General Discussion
Changing primary partitions to logical
So, I want to have Windows 7 Home Premium 86x and 64x versions installed on my PC with dualboot. I have 86x version of Windows 7 installed already. So, for 64x version, I have to create a new partition. The problem is, I already have 4 primary partitions, so I can't create a new one (I read...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:12.
Twitter Facebook Google+