Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Asus P8Z77-V Pro - USB 3.0's not working

28 Jun 2015   #1

Windows 7 x64
Asus P8Z77-V Pro - USB 3.0's not working


My problem is as the title reads, recently formatted my PC, installed my motherboard drivers via the CD that came with the board and now my USB 3.0's do not work, no data or power coming from either of the 2. I've been reading other articles on the issue but none have had a fix for me yet. If anyone can help here's what I've done so far.
- Reboot/Hard Reboot
- Reinstall drivers via CD
- Reinstall board drivers via their own website
- Uninstalled broken USB's from device manager and reinstalled using the CD
- Installed USB 3.0 Drivers from their website
- Made sure the 3.0's are active in the bios

So far none of these have worked and i'm at a dead end. Any other help would be awesome!

My System SpecsSystem Spec
28 Jun 2015   #2

Windows 7 Ultimate x64 SP1

Are you using the front panel of the computer case and if so, are you sure you connected the cable to motherboard? Tried another internal USB port?

According to specifications:
ASMedia® USB 3.0 controller : *7
4 x USB 3.0 port(s) (2 at back panel, blue, 2 at mid-board)
Intel® Z77 chipset : *7
4 x USB 3.0 port(s) (2 at back panel, blue, 2 at mid-board)
Maybe you haven't enabled AsMedia ports and connected to them?
My System SpecsSystem Spec
28 Jun 2015   #3

Windows 10 64 bit

Check the BIOS. May have been inadvertently disabled. If the 3.0 is enabled, reset the BIOS.
My System SpecsSystem Spec

28 Jun 2015   #4

Windows 7 x64

@fireberd @Gokay
Hey guys, sorry should have checked back on this thread earlier. I was randomly prompted by an Intel program run request about 5 minutes after a boot up. I let it run and it installed some drivers from Asmedia and now the USB's work, no idea how or why it decided to randomly prompt me but hey, it works now. Sorry for the trouble guys.
My System SpecsSystem Spec
29 Jun 2015   #5

Windows 7 Ultimate x64 SP1

No trouble :) Glad you sorted it out.
My System SpecsSystem Spec

 Asus P8Z77-V Pro - USB 3.0's not working

Thread Tools

Similar help and support threads
Thread Forum
Asus P8Z77 V LK Intel USB ports weren't working due to bad drivers.
After a lot of research i finally got them to work by uninstalling from device manager Intel 7 series c216 chipset family 1e2d(but not the 1e26 out of fear of more chances to disable my mouse lol) and Intel usb 3.0 usb extensible host controller. Then installed the newer intel usb 3.0 drivers...
Wake On LAN not working from shutdown state (ASUS P8z77-v LX)
I'm leaving on Christmas for vacation but I need access to my computer over rdp. Everything is good except WOL, which won't seem to work from a complete shutdown state. From sleep it works, but if I shut it off (hibernate wont work either) then no avail. I have configured the windows side well...
Network & Sharing
PCI-E slots of ASUS P8Z77-M Motherboard
Hello to everyone! I need help regarding my motherboard's graphics card slots. It does have two PCI-e x16 slots: one is "black" and one is "blue". At first, I am using the blue one because, according to the manual, it has better performance than the black one. But, something had occurred that I...
Hardware & Devices
Unable to Install Win 7 on ASUS P8Z77-V LE Plus M/B
I have a PC with subject motherboard (and an i5 3550 CPU) that currently has Windows 8 installed (NOT UEFI). I need to also install Win 7 as I have an old Singer Embroidery machine program and a USB/Serial adapter that will only work on Win 7 (its supposed to also be Win 8 compatible but either the...
Installation & Setup
asus p8z77 v-pro ddr3 ram issue
hi my last mb asus p8z77 v-pro went pare shape so decided to buy same one so won't have problems with anything but: new mb don't see my ram 16gb corsair vengeance which was working on old one???? red led shows up continuous so did try cmos clear, did ram ok memory but atfer run up still goes red...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:04.
Twitter Facebook