Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Usb drive not working after Samsung SSD 850 cloned

20 Jul 2015   #11

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

Think of filters as driver "add-on" parts. A driver consists of one or more functional blocks. Think of these blocks like Lego blocks. A driver may consist of a single block that stands alone or it can easily be attach to other blocks at any time. We typically think of "THE" driver as a single thing - but it may consist of one or more functional blocks.

A device driver starts with one Lego block. This block is called the "function" driver. The function driver provides the base hardware interface needed between Windows and the h/w.

Applications can extend driver functionality to support its needs. It adds-on extended functionality by connecting a new "Lego"
> Upper filters are functions (blocks) that precede the function driver
> Lower filters are functions (blocks) that follow the function driver

It's worth noting: There are "class" filters and "device" filters. Ignore device filters, it's the class filters that sometimes, but certainly not always, can cause problems. More specifically, it's class filters from 3rd parties (not Microsoft). If it's a Microsoft filter, it's OK.

When an app creates a class filter, the filter is added (connected) to the driver for every device in the class.

In this case, Magician created a class filter for class=DISK. Windows applies this class filter to every disk drive on the machine (internal disks, USB flash drives and external disks, etc). Perhaps their filter saves info about machine state and its behavior varies based on state of the machine. The machine state is probably different at the moment it's cloned vs. when the cloned filter is later called on the machine. Just an example of how that could be a bug.

Important point being: A driver actually consists of one OR MORE functional blocks. If any one block fails, the driver fails. When you go looking in Device Manager, it can be deceiving. When you open DevMgr, you're seeing the function driver for the device. You have to dig further, to understand if any filters have been attached to the function driver

btw... That's why, if a class filter is at fault, you can install/uninstall a device till your blue in face without fixing the problem. That's because you're only installing/uninstalling the function driver. The problem class filter still exists and is re-attached to the function driver when it's reinstalled

As an example of class filter: Say an app is implementing encryption in the software. The function driver for a disk remains the same. The app could create an upper class filter for device=Disk
> For disk writes, the DISK class upper filter gets the I/O request to any disk drive BEFORE it goes to the function driver. The filter encrypts the data and then passes it to the function driver to be written to disk
> For disk reads, the function driver reads encrypted data from disk. It's passed to the upper class filter which decrypts it before passing the unencrypted data up to the Windows app

My System SpecsSystem Spec
20 Jul 2015   #12

Windows 7 Ultimate x64 SP1

Good info, thanks mate :)

I wonder what triggers the problem though, I have Samsung Magician installed too, no problem cloning and booting with the clone. However, I have not checked to insert any USB devices after booting with a clone. Hmm...
My System SpecsSystem Spec
20 Jul 2015   #13

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

Quote   Quote: Originally Posted by GokAy View Post
Good info, thanks mate :)

I wonder what triggers the problem though, I have Samsung Magician installed too, no problem cloning and booting with the clone. However, I have not checked to insert any USB devices after booting with a clone. Hmm...
I don't know what the bug is - or why it just affects USB - but have often seen cases where a class filter for DISKs only cause USB drives to fail. Internal disks continue to work just fine
My System SpecsSystem Spec

24 Sep 2015   #14

windows 7 64 bits / Windows 10 64 bits
usb error 10

It's definitively the solution.
I have lost hours in order to correct the usb error 10 when i discover your thread. It resolve my problem.
Just a remark, i don't have to uninstall magician.
In fact i run magician and see an error message on advanced feature/Rapid mode (don't remember the exact message) It says, your ssd are not the ssd configured with magician blablabla...
I 've just disable rapid mode, the pc reboot, and usb start to works ! . i return to magician , re-enabe rapid mode, the pc reboot (it is normal) and now USB works, rapid mode works too and indict the new SSD serial number. (the previous ssd was a 850 Evo 250Go and the new are same model but 500Go.)
My System SpecsSystem Spec
15 Nov 2015   #15

Windows 7 Ultimate x64

I don't know how many +1s I have to give to all of you guys! You were the first people that I turned to when I faced the exact same problem (upgrading from an 840 EVO 120 GB to an 850 evo 250 GB). I have to point out that huahine's "method" worked for me brilliantly, ez mode! Many thanks to everybody!
My System SpecsSystem Spec
05 Feb 2016   #16

Windows 7 Home Premium 64bit

Hi, everyone,

After cloning the Windows 7 partitions (done completely outside the windows environment) from my Samsung 840 250 Gb to the new Samsung 850 500 Gb) I found myself in the same situation: Everything worked, except for any and all USB drive, sticks access...even the SD cardreader stayed empty...

After reading this thread I knew why trying to solve this by myself has been clearly a major waste of time (and reducing the life span of my new drive: I had +2.5Tb written on the new disk before doing anything useful with it...:))

I really do thank GokAy and ComputerGeek for their thoughts and insight on device filters; since the tought of Samsung's Magician as being the culprit never crossed my mind I'd now still been busy wasting my time and space...
For me the solution was uninstalling Magician on the clone; after that all USB and SD access returned fine.
Reinstalling the latest version of Magician had no disturbing side effects.

Thank you all for this thread..!

Best regards,
My System SpecsSystem Spec
27 Jul 2016   #17

Win7 professional 64
Can this possibly be???

Quote   Quote: Originally Posted by GokAy View Post
AJL14, when Magician installs, it also installs a filter driver (read about them here
So the filter is there (enabled in the registry) as long as you clone that source SSD. It is not the Magician software that's causing the issue but the filter driver it installs.

However, there is one other thing reported in that thread I linked. That is Rapid Mode may be causing the issue too. So disable it for the clone if you have it enabled and try again, if not uninstall Magician. You don't need it running all the time anyway.
I have spent over 50 hours trying every combination and permutation of cloning, backup restore, reload chipset and drivers, on and on with 3 different backup programs, including linux boot cd's, disk duplicator... nothing has worked. Will try this tomorrow. THANK YOU THANK YOU THANK YOU

UPDATE: tried your fix and it worked. Just for reference, when I reinstalled Magician I updated to 4.9.7

One thing that happened that led me down a rabbit hole was that any disk that received an image from the Samsung SSD that was in my machine also caused the USB devices to fail, so it didn't seem like a Samsung-related problem, but more like a problem in the cloning or backup process.

Samsung should be SHOT for causing this problem to occur
My System SpecsSystem Spec
28 Jul 2016   #18
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Just something that happened to me using a Samsung ssd.

After using Samsung's Magician and or a Linux installation a format was not good enough. It always left little bits of junk on the ssd which interfered with cloning.

I completed a wipe of the ssd which cleaned up the bits of junk on the ssd and the cloning process to the Samsung ssd worked properly using Macrium Reflect.

Your millage may vary.

My System SpecsSystem Spec
01 Aug 2016   #19

Win7 64 bit Home Premium and Pro (1st and 2nd PCs)

+1 on the magician uninstall. Another tormented soul made happy. Thank you for this thread.
My System SpecsSystem Spec
01 Aug 2016   #20
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

We all like happy souls and happy customers.
My System SpecsSystem Spec

 Usb drive not working after Samsung SSD 850 cloned

Thread Tools

Similar help and support threads
Thread Forum
Problem after having cloned drive. (showing incorrect space on drive)
First off PC specs: AMD Phenom II x4 processor - 3.4 Ghz 8GB DDR3 RAM Nvidia N460 GTX GFX card 240GB SanDisk SSD Windows 7 64 bit So here is the problem. I had a Western Digital 300 GB SATA drive that was starting to quit on me. So using an Ubuntu live CD I cloned the 300 gig drive onto...
General Discussion
Win 7 cloned drive wont boot
Any suggestions on how to make my cloned drive boot? I installed Win 7 to a SataIII drive/port with the intention of doing a bootable clone to a SataII drive/port. However on completion of the first install I realised...
Backup and Restore
Cloned existing drive to new HDD...can you have 2 Win 7 drives in box
Tried my first attempt using Acronis clone feature to upgrade my Win 7 Pro 64bit system from a Hitachi Sata 2 750 GB drive to a Western Digital Sata 3 500 GB drive. Cloning seemingly has gone flawlessly from within Windows 7 Acronis app/tools. Now I don't remember how I setup the new drive...
Installation & Setup
How do I change a cloned SATA drive to use as a backup drive
I messed up by making a cloned SATA drive instead of just doing an image back up. Now, because it's recognized as a real system drive, I can't get to it to make it a backup drive with an image vice a clone.
Backup and Restore
Cloned Drive with Windows 7
I installed W7 on my D: drive and it was only 80GB, and had everything running to my satisfaction. Started adding a few programs from my Vista install and thought the drive was to small, so cloned the drive unto a backup drive and installed a 1TB drive. Cloned the image back unto the new drive, but...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:07.
Twitter Facebook