Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB not working after Windows Update

20 Jul 2015   #1

windows 7 64bit
USB not working after Windows Update

Computer was fine on Friday but this morning after an update has been applied I have no USB hence no keyboard or mouse. I'm able to access the computer from anoth PC via Teamviewer so can make changes etc no problem. So far I've spent the entire day trying different things to sort this out but to no avail. I've tried re-installing the USB drivers but I either get a message saying I already have the latest drivers installed or the driver appears to install but in the Device Manager has a yellow flag and uder Device Status says
"Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"
I've attempted changing the BIOS settings (keyboard and mouse work fine there) but doesn't make any difference and I've also attempted to get into the Advance Boot options so I can try disabling Digital Device Signing. However on this MOBO, F8 takes it into which device to boot from and when I select the device and try F8 again it just continues into normal Windows mode. I've also tried a System Restore and uninstalling the latest updates but still the same problem. Any ideas because I'm at my wits end

My System SpecsSystem Spec
20 Jul 2015   #2

Windows 7 Ultimate x64 SP1

Try loading defaults in BIOS.

Was the System Restore point from before the problem? Like Friday or earlier.

Get Malwarebytes Anti-Malware free, enable rootkit scanning (settings - detections) and scan with it.
My System SpecsSystem Spec
21 Jul 2015   #3

windows 7 64bit

The system restore was the earliest I could go which was yesterday morning so presumably after the updates. Done the Malaware scan and a few things came up but nothing too scary. I've got up and running again by using ReadyDriver Plus which loads the Advance Boot Options / Disable driver signature enforcement option.

Tut: Using ReadyDriver Plus on Windows 7 (x86/x64) - Forums

Citadel Industries ? View topic - ReadyDriver Plus Setup Guide [With Pictures!]
My System SpecsSystem Spec


 USB not working after Windows Update

Thread Tools

Similar help and support threads
Thread Forum
Rdp not working after windows update
I recently performed all the windows updates and now rdp will not open. The error says Could not load the Remote Desktop Service ActiveX control. Make sure mstscax.dll is in the path. I confirmed the extension is in there. I uninstalled an update that was possibly to blame. I replaced the...
Network & Sharing
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
Windows Update is not working/Update Readiness Tool won't install
Win 7 64 Windows Update not working (post migration), nor is Windows Update Readiness tool installing. I have renamed catroot and stopped services, nothing working. I just migrated HD to a hybrid solid state (Seagate Momentus). I had this problem both with Acronis 2009 and Acronis 2013, and...
Windows Updates & Activation
Windows Update not working.
Hi, i've been unable to do a windows update, it simply doesn't start and gives me an error message. When I tried SFC/SCANNOW in the command prompt, the scan completed and I got: Windows Resource Protection found corrupt files, but was unable to fix some of them. So that's about where I got to.
Windows Updates & Activation
Windows Update not working
Fresh install of Windows 7 and i have tried the readiness update which comes back with no errors in the log. I have removed firewall and antivirus and still cannot get the Microsoft Updates (it is just the security related ones) to install. I have also run the sfc /scannow from the elevated cmd...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:33.
Twitter Facebook Google+