Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External Hard Drive appearing as Local Disk, not opening

14 Sep 2015   #1
colinjas

Windows 7 Home Basic x64
 
 
External Hard Drive appearing as Local Disk, not opening

When I plug in my WD "My Passport" 1TB hard drive, I can hear that a device has been connected, but when I open explorer the name's been changed to Local Disk (E and I can't perform ANY operation on it like open it, check properties or scan with an antivirus. I can't even eject it. Also the laptop slows down considerably and internet becomes too slow to open any page.
I tried running "chkdsk" and the data recovery software "PhotoRec" on it but it just keeps scanning for hardware and even after leaving it for 6 hours, it got nowhere. I tried opening "Disk Management" but even that keeps loading forever. A few times after the problem started, it told me to format the drive to be able to use it, but now even that message doesn't come and I'm not even able to format the drive(though I prefer getting all my data back, but it's better than spoiling the HDD).
The drive is physically fine as I kept it very carefully and I can hear the smooth rotation of the disk, plus there are no 'clicking' sounds coming out of it.


My System SpecsSystem Spec
.
14 Sep 2015   #2
paul1149

Linux Lite 3.2 x64; Windows 7, 8.1
 
 

A few things you can try.
  1. Try accessing it is Safe Mode
  2. Try from a WinRE or Win PE disk
  3. Try from a Linux boot disk. If Linux reads it you can at this point rescue your data.
  4. Open the Passport and hook the drive up directly on a SATA channel and try it in Windows again. It could be the Passport controller causing the issues.
  5. Running a chkdsk /r is the way to go, but only after rescuing data.
  6. In any one of the above environments you can run a drive utility such as GSmartControl to a) check SMART attributes, and b) perform the Long test.
My System SpecsSystem Spec
15 Sep 2015   #3
CKWD

Windows 7 Home Premium x64
 
 

Hello colinjas!

I'm sorry for the issue! :/

I would suggest you changing the cable with another one, it's a standard USB 3.0 Micro-B one. You could also try the device on another system.

Also, see if the dedicated WD software, the WD Data Lifeguard, can detect the drive. If it can, do a Quick test and post the SMART values here, please.

WD DLG:
Support Answers

Also, do as paul1149, suggested, try booting into a Linux/Ubuntu Live CD, see if then you can detect the drive, and try his other options, as well.

Post back!

CK_WD
My System SpecsSystem Spec
.

15 Sep 2015   #4
colinjas

Windows 7 Home Basic x64
 
 

Thanks for the replies! I'll do as the two of you have suggested and get back with the results as soon as possible.
My System SpecsSystem Spec
15 Sep 2015   #5
GokAy

Windows 7 Ultimate x64 SP1
 
 

I will add uninstall its drivers and let it re-install. May be best if done after a successful Linux test.
My System SpecsSystem Spec
16 Sep 2015   #6
jumanji

Windows 7 Home Premium 32 bit
 
 

Try with Linux as already suggested.

Please read this post Is there any way of saving a completely unrecognisable hard drive?.

Prepare your Lucid Puppy Pendrive using Rufus. https://rufus.akeo.ie/ (If you have any data on the pendrive back it up elsewhere since all data in it will be lost when Rufus formats the pendrive and writes Lucid Puppy in it.)

Read this and try to familiarise yourself on how to use Lucid Puppy. Lucid Puppy way to recover files from a non-bootable computer In your case it will be the non-responding/problematic external drive.

With your WD external drive plugged in and the Lucid Puppy pen drive plugged in, boot your PC. Use the onetime boot menu to boot Lucid Puppy from the pendrive.
My System SpecsSystem Spec
16 Sep 2015   #7
MillBaduya

Windows 7 Home Basic 64 Bit
 
 

You can go for the following solutions:
Use it on Linux
Use it using Windows Safe Mode
Changing Cable
Reinstalling its Driver

pcb assemblies
My System SpecsSystem Spec
Reply

 External Hard Drive appearing as Local Disk, not opening




Thread Tools




Similar help and support threads
Thread Forum
iOmega External Hard Drive Not Appearing Anywhere
A month ago, my father asked to take back the Mac he lent me, so he gave me his iOmega external hard drive to copy all of my information onto. iOmega External Hard Drive Model: EPHD-ME I did so, and waited for a month before I realized I was better off moving the information onto my Windows...
Hardware & Devices
lock folder xp: problem when opening my locked external hard disk
Hello, I used lock folder xp to lock my external hard disk. when opening my external hard disk, I enter the correct password but it doesn't open and windows displays the following message: this device is currently in use, Close any programs or windows that might be using the device, and then...
General Discussion
External hard disk detecting but not opening
Hello I have WD My passport 1TB.After knowing that it had lot of bad factors I used HDD regenerator and at 95 percent it stopped working and I restarted my Pc and now my HDD is detecting but not showing up.So I went to disk management and tried this and it shows like this ...
Hardware & Devices
External Hard Disk Not Opening
buffalo 1 tb external hard disk not showing in my computer. its showing in device manager. disk manager is not opening. what to do?
Hardware & Devices
Samsung s2 external hard drive not loading showing local disk F drive
I have a Samsung s2 1tb external hard drive. Today when I hooked it up to my laptop it would not load. It will shows local F drive when it usually will say samsung Drive. A pop up box will then appear stating "you need to format drive" I know if I reformat it I will lose all my data which...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App