Can't access USB Drives on Acer laptop-Windows 7


  1. Posts : 2
    Windows 7 Home Premium
       #1

    Can't access USB Drives on Acer laptop-Windows 7


    My sister has an Acer laptop that she uses ONLY for connecting to a Dymo LabelWriter 450 for work.
    She bought a $3.96 POS USB fan and plugged it in. Didn't like it, and unplugged it. Now we can't use her label printer, the fan (I'm guessing) appears as an unknown device and the following comments:
    Port_#0001 Hub_#0004
    Windows has stopped this device because it has reported problems.
    Code 43
    I've tried resetting the registry. It was already set on 3.
    I've tried deleting/uninstalling the device. It keeps coming back.
    I've tested the printer and USB cord on my HP and it works fine.
    I've tried updating Windows 7 drivers.
    I've tried updating the Labelwriter 450 software and reinstalling.
    Nothing works. Doesn't matter which of her 3 USB ports I plug the printer in to-nothing happens. Print jobs go to the queue and stay there until deleted.
    I've tried plugging in USB flash drives, and they're not found.
    I think, somehow, this POS USB fan has messed up the controller or "something".
    Does anybody have any words of wisdom that will get rid of the "unknown device" for good, and bring my USB ports back on line?
    Thanks so much for your help.
    DH
      My Computer


  2. Posts : 7,054
    Windows 7 Home Premium 32 bit
       #2

    Remove all USB devices and do a System Restore to a point before the POS USB Fan was plugged and check whether it helps.
      My Computer


  3. Posts : 2
    Windows 7 Home Premium
    Thread Starter
       #3

    Hi, Jumanji-
    Sorry, I should have mentioned-this Acer doesn't have a restore point. All it's ever done is run the Dymo Labelwriter. My sister isn't allowed to hook up hardware to her company PC, so she uses this strictly to generate client mailing labels. It's never been backed up, never had SW updates, never even connected to the internet until this happened...This Dymo printer, besides that wonderful little USB fan, is all that's been hooked up to this as far as USB devices go. No matter what I do, this "unknown device" still shows in the list of Devices. I can't delete it, I can't uninstall it, etc. I tried disabling the USB suspend feature, thinking that this POS fan had somehow commandeered all of the ports when it was plugged in, but that made no difference.
    I'm wondering if the young men at my local Staples could figure this out....
    Thanks, though.
    DH
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:28.
Find Us