Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New SSD. Unable to use with AHCI mode.

06 Oct 2015   #1

Windows 10 Professional
New SSD. Unable to use with AHCI mode.

Sup beautiful people,

My aim is to install Windows 7 64x Home Premium on a new SSD in AHCI mode.

I recently bought an OCZ Arc 100 Sata III SSD to transfer Windows 7 Home Premium OEM to, on a Samsung RV510 laptop.

All possible methods of backing up and restoring, cloning and repairing boot sectors completely failed without any BIOS changes from a perfectly booting Samsung HDD partitioned as MBR booting in AHCI mode with Legacy OS support turned on in BIOS. I would end up with "Operating system not found" and it being impossible to recover the environment and rebuild the BCD with the error "Requested device unavailable" and "No OS files found" with automatic repairing.
If I were to try and install Windows 7 Home Premium with the aforementioned BIOS settings after completely wiping the disk clean it would tell me that:
"Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu."

Installing Windows 7 Home Premium with IDE set and Legacy OS Boot set goes through without any hindrances and OEM OS was activated. I have tried to reset the AHCI mode through the registry with the OS loaded on the SSD and then rebooted and changes BIOS settings back to AHCI mode and I once again face the error "Operating system not found."

In AHCI mode the SSD is not recognised as a bootable device at all however BIOS is picking it up. It makes no sense to me that an SSD with an exact copy of the OS of an HDD will not boot, however the HDD does.

I have done endless amounts of Google research but I think this time it won't be able to teach me and my brain is just absolutely fried right now, so I am hoping some one here might be able to help me. I believe I have recalled correctly all my trials and errors, feel free to ask any questions for clarification.

Samsung RV510 Laptop (2011)
Windows 7 Home Premium 64x OEM
Samsung HM500JI HDD
OCZ Arc 100 SSD
Pheonix SecureCore BIOS
BIOS version: 02UC
MICOM version: 02UC

Advanced BIOS Settings:
CPU Power Saving Mode
Intel SpeedStep
Graphics Memory

Legacy USB Support
Legacy OS Support
AHCI Mode Control
>Native AHCI Mode

Fan Silent Mode
Battery Life Cycle Extension
USB S3 Wake-up

(No security options for EFI mode)

My System SpecsSystem Spec
08 Oct 2015   #2

Windows 10 Professional

Any one got any ideas at all? Any theories? Any suggestions?

I just tried a BIOS update which had no affect. This is killing me because it makes no sense what so ever!
My System SpecsSystem Spec
10 Oct 2015   #3

Win-7-Pro64bit 7-H-Prem-64bit

Hi and welcome to SevenForums,
Sorry for the late response please review this if you haven't already
Troubleshooting Windows 7 Failure to Boot

Doesn't make much sense to me even on legacy bios ahci is the default bios setting so you shouldn't have to change anything :/
My System SpecsSystem Spec

11 Oct 2015   #4

Windows 10 Professional

I'm afraid I have already looked through that.
My System SpecsSystem Spec
11 Oct 2015   #5

Win-7-Pro64bit 7-H-Prem-64bit

Can you post some images of the bios settings Secure boot and csm ?
Also disable Fast boot and test as well.
My System SpecsSystem Spec
11 Oct 2015   #6

Windows 10 Professional




As you can see this is an extremely basic BIOS on a 2011(?) laptop. Not an awful lot to configure. No fast boot option, no secure boot.
My System SpecsSystem Spec
11 Oct 2015   #7

Win-7-Pro64bit 7-H-Prem-64bit

Interesting no fast boot option shown,
The ssd might not be marked as active ?
Have you used diskpart
Partition - Mark as Active
My System SpecsSystem Spec
11 Oct 2015   #8

Windows 10 Professional

Yep I have done that. Not what is causing the issue though as I installed Windows 7 onto it in IDE mode, then used registry changes (after checking it boots fine) to change the OS to AHCI, then changed the BIOS to AHCI and then got the error "No operating system found"
My System SpecsSystem Spec
11 Oct 2015   #9

Win-7-Pro64bit 7-H-Prem-64bit

Not sure how to fix the ide thing looks like might be the ultimate problem
AHCI : Enable in Windows 7 / Vista
My System SpecsSystem Spec
11 Oct 2015   #10

Windows 10 Professional

Yeah that is the thread I read through when changing to AHCI in the OS. I don't know how to fix this either and it hurts my brain trying to logically put all this information together to something that makes sense.
My System SpecsSystem Spec

 New SSD. Unable to use with AHCI mode.

Thread Tools

Similar help and support threads
Thread Forum
No AHCI mode in BIOS?
My current computer is a inspiron 530s running Windows 7 (of course) and in it there isn't an option in the BIOS for AHCI mode. I have the newest version of the BIOS and was wondering if there might be something else I might could update or change to make the option available. Thank you for your...
Hardware & Devices
IDE mode to AHCI mode - can I change it on an OS drive?
Hello, I have bought a new SSD which I plan on using as a program drive, though not as OS drive (will reinstall Windows in the next few months). Currently I am running Windows 7 Pro 64bit. My OS is installed on a Western Digital 2TB drive. It is set to run in IDE Mode currently. My...
Hardware & Devices
SSD problems in AHCI mode
Last week I was playing a game when suddenly I got a BSOD. I narrowed the error down to a memory problem and ran Memtest86+. I got errors (about 30 in 15 hours). The stock timings were pretty aggressive so I loosened them and it ran without problems. Then me, being the idiot I am, decided that I...
Hardware & Devices
Can I switch my boot disk from ahci mode to raid mode?
I Installed windows on a ssd drive running in ahci mode. I then switched the sata setting in the bios from ahci to raid in order to add 2 other hdds as a raid 0. Now the pc won't boot anymore getting no boot device error. I know about the registry fix to get an IDE sata drive to boot in ahci mode,...
Hardware & Devices
AHCI Mode Setup
Hi, I have recently bought this motherboard Gigabyte GA-890FXA-UD5 and I am trying to setup AHCI Mode on it I have gone into the BIOS and tried to set this up but when the system loads its saying that no devices were found. Please can you advise if the attached picture is the correct...
Hardware & Devices
AHCI mode
Does Win7 still require AHCI be configured before installation? I think in XP if you switched an SATA drive to AHCI from IDE, you would need to format and start over.
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App