Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Computer with Hang if USB Devices are Plugged in

11 Nov 2015   #1

Windows 7 Ultimate 64-bit SP1
Computer will Hang if USB Devices are Plugged in


I've been running into an in issue where if I have any USB devices (two 2tb external hard drives and a cablecard tv tuner) plugged in, the computer will hang on a black screen before the login screen in Windows 7 and I will have to restart. This is what I've tried so far:

- Setting fastboot in the bios with USB support disabled
- Disabling legacy USB in the bios
- Changing the order of devices so that the USB devices load last
- Switching USB ports for the devices

If I unplug everything, the computer will start normally and I'll make it to the login screen. This was last for about a week or so and then the same issue returns. Is there something I haven't tried that might resolve this issue?


My System SpecsSystem Spec
12 Nov 2015   #2

Windows 7 Ultimate 64-bit SP1

Update to my issue:

I started my machine without the two ext. hard drives plugged in. After logging in, I plugged them in maybe a bit too quickly and my machine acted like it was about to restart (desktop icons disappeared, task bar, etc) and then I received this BSOD:

* *
* Bugcheck Analysis *
* *

Use !analyze -v to get detailed debugging information.

BugCheck F4, {3, fffffa8010a219e0, fffffa8010a21cc0, fffff80003790940}

ETW minidump data unavailable
Probably caused by : csrss.exe

Followup: MachineOwner

2: kd> !analyze -v
* *
* Bugcheck Analysis *
* *

A process or thread crucial to system operation has unexpectedly exited or been
Several processes and threads are necessary for the operation of the
system; when they are terminated (for any reason), the system can no
longer function.
Arg1: 0000000000000003, Process
Arg2: fffffa8010a219e0, Terminating object
Arg3: fffffa8010a21cc0, Process image file name
Arg4: fffff80003790940, Explanatory message (ascii)

Debugging Details:

ETW minidump data unavailable

SYSTEM_SKU: To be filled by O.E.M.

SYSTEM_VERSION: To be filled by O.E.M.

BIOS_DATE: 08/03/2013




BUGCHECK_P2: fffffa8010a219e0

BUGCHECK_P3: fffffa8010a21cc0

BUGCHECK_P4: fffff80003790940


PROCESS_OBJECT: fffffa8010a219e0

IMAGE_NAME: csrss.exe



FAULTING_MODULE: 0000000000000000

PROCESS_NAME: csrss.exe

EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.



CPU_MHZ: d40

CPU_VENDOR: GenuineIntel







ANALYSIS_VERSION: 10.0.10240.9 amd64fre

fffff880`096cce38 fffff800`03820342 : 00000000`000000f4 00000000`00000003 fffffa80`10a219e0 fffffa80`10a21cc0 : nt!KeBugCheckEx
fffff880`096cce40 fffff800`037d65ab : ffffffff`ffffffff fffffa80`114da640 fffffa80`10a219e0 fffffa80`10a219e0 : nt!PspCatchCriticalBreak+0x92
fffff880`096cce80 fffff800`037440cc : ffffffff`ffffffff 00000000`00000001 fffffa80`10a219e0 00000000`00000008 : nt! ?? ::NNGAKEGL::`string'+0x2a546
fffff880`096cced0 fffff800`0348bcd3 : fffffa80`10a219e0 fffff800`c0000006 fffffa80`114da640 00000000`04700c80 : nt!NtTerminateProcess+0xf4
fffff880`096ccf50 fffff800`03488290 : fffff800`0350d519 fffff880`096cda38 fffff880`096cd790 fffff880`096cdae0 : nt!KiSystemServiceCopyEnd+0x13
fffff880`096cd0e8 fffff800`0350d519 : fffff880`096cda38 fffff880`096cd790 fffff880`096cdae0 00000000`04701990 : nt!KiServiceLinkage
fffff880`096cd0f0 fffff800`0348c0c2 : fffff880`096cda38 00000000`000713b8 fffff880`096cdae0 00000000`04701468 : nt! ?? ::FNODOBFM::`string'+0x48554
fffff880`096cd900 fffff800`0348ac3a : 00000000`00000000 00000000`77318af4 00000000`00000001 00000000`000713b8 : nt!KiExceptionDispatch+0xc2
fffff880`096cdae0 00000000`774c8fa2 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x23a
00000000`047013b0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x774c8fa2





BUCKET_ID: X64_0xF4_IOERR_IMAGE_csrss.exe



FAILURE_ID_HASH_STRING: km:x64_0xf4_ioerr_image_csrss.exe

FAILURE_ID_HASH: {183378f4-a174-8cab-8ad7-e5d860a58439}
I'm going to run an SFC and disk check of the OS drive and the two ext. hard drives to see if I turn up anything.

Does anyone have any suggestions based on this BSOD?
My System SpecsSystem Spec
16 Nov 2015   #3

32bit embedded

reinstall or update your drivers
My System SpecsSystem Spec

17 Nov 2015   #4

Windows 7 Ultimate 64-bit SP1

Attached is a minidump from the BSOD I mentioned above. Are there any specific drivers which might be causing problems?

Some things I've tried since last post:

- Ran sfc scannow, said there were corrupt files that couldn't be fixed. Tried booting into safe mode and got the same results. Also tried running that scan from system repair based on the tutorial on this site and it still wouldn't run.
- Installed newest Windows updates.
- Updated my SSD firmware.
- Ran a disk check on one of the external hard drives, no problems were found.

Still having the same issue where the computer will hang before login if I have the external hard drives plugged in.

Attached Files
File Type: zip (27.9 KB, 0 views)
My System SpecsSystem Spec

 Computer with Hang if USB Devices are Plugged in

Thread Tools

Similar help and support threads
Thread Forum
BSOD while three USB devices Plugged in, error 0x0000000A
Hello, We have a computer that keep randomly blue screening a at different times of the day. We have replaced the motherboard, RAM, power supply and CPU and we still receive bluescreens. We have had the USB devices (scale and two thermal printers) unplugged while this occurs. Multiple types...
BSOD Help and Support
Any way of detecting which devices have been plugged in removed?
PC keeps making the device unplugged sound followed by the device plugged in sound randomly with no real pattern, is there any way of identifying which device it is? Unplugged all of the usb etc so assume its something internal but no idea what.
Hardware & Devices
usb devices plugged in one port only lights up..
hello.. i need help please.. i have a hp pavilion g6 usb port problem.. i have windows 7 home premium.. everything was working well weeks ago.. then suddenly.. one usb port suddenly stopped working.. everytime i insert a device into that port.. example.. a flash drive.. it only lights up.....
Hardware & Devices
Windows 7 32 won't boot with USB devices plugged in
My Windows 7 HTPC (see my profile, it's an Ion with an Atom 330) has been running fine for about a week now and tonight I went in to watch a movie and it was stuck at the "Starting Windows" screen, without the logo showing. After toying with it a bit and trying to boot in to repair mode (which also...
General Discussion
usb pci card... devices plugged into it not recognized
I just installed a new PCI USB 2.0 card into my machine. I have a Line 6 Toneport UX8 that connects to the PC by USB as the interface for microphones and instruments. Because of the high volume of data coming down the pipe from this external interface it is pretty much a 'mandatory recommendation'...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:27.
Twitter Facebook Google+