Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WD HDD unable to access.. win 7

15 Nov 2015   #1

win 8, win 7 dual boot 64 bit
WD HDD unable to access.. win 7


I have a 2 TB hdd of WD.

Whenever I try connecting to system all this happens -

1. my computer hangs
2. disk management never loads
3. System does not shutdown, it keeps waiting on the screen- shutting down.
4. I have 4 partitions on HDD, mostly 2 of them I cannot access, the rest I can access.

Troubleshoot steps I did -

1 tried running wd utilities, the hdd doesn't gets detected.
2. Cant format it as I have important data.
3. Tried accessing hdd from command prompt only working partitions can be accessed.

Please help.

My System SpecsSystem Spec
18 Nov 2015   #2

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Hello pioneer747 mate if it is just data you need for the time being try this
Make a bootable Ubuntu disk Get Ubuntu | Download | Ubuntu
Set the BIOS to boot from the optical when the machine boots it will show you a screen with TRY or INSTALL > select TRY not INSTALL
When it is finished - it takes very little time you will get a screen like in the pic .
Open the drive you want > User and dig down until you get to the data / settings you may be able to copy / paste the material you want to an external source or other installed drive doing this.
I am not sure if it will but I have recovered tons of data etc using this method both on "dead" or just plain drives that you cannot get data from using Windows.

You could also run these as well before you try the Ubuntu
SFC /SCANNOW Command - System File Checker
Disk Check < if necessary include the /f and /r in the command line as per Option2

Attached Thumbnails
WD HDD unable to access.. win 7-ubuntu-screen-x2.png  
My System SpecsSystem Spec
19 Nov 2015   #3

Windows 7 Home Premium x64

Hello thepioneer747!

I'm sorry for your issue with the WD drive! :/

I suppose this is an external drive, which model is it, a My Passport, My Book etc.? How old is the drive and is there valuable data you need from the drive? What happened prior to the issue occurring?

I understand when you connect the drive, you can only access two out of four partitions, but at the same time the system and Disk Management hang and lag?

I would suggest changing the USB cable you are using. Do also try ICIT2LOL's suggestion with the bootable flash drive. You could also try and see if the dedicated WD software can see the drive. Download the WD Data Lifeguard Software and check the SMART status of the drive and do a Quick test.

Post back with results!

My System SpecsSystem Spec

20 Nov 2015   #4

win 8, win 7 dual boot 64 bit

Hi everybody..

I tried using the same HDD on a MAC, surprisingly it worked there. So I have copied my data. Mac cannot write NFTS files, so had to format another hdd to fat32.

CKWD - What you mentioned, thats exactly what is happening. I would now take complete backup through MAC then I will reformat it.
My System SpecsSystem Spec
20 Nov 2015   #5

Windows 7 Home Premium x64

Try reformatting through Windows and through Mac, if necessary try diskpart in Windows, too:

1. Open the Start Menu, type diskpart, press Enter
2. Type list disk, press Enter
3. Type select disk X (where X is the number the certain drive), press Enter
4. Type clean, press Enter
5. Type create partition primary, press Enter
6. Type format quick fs=ntfs, press Enter
7. Type assign letter=X, press Enter
8. Type exit, press Enter

If they don't work, try writing full zeros first then formatting, you could use the WD DLG for this.

Good luck! :)

My System SpecsSystem Spec

 WD HDD unable to access.. win 7

Thread Tools

Similar help and support threads
Thread Forum
Unable to access one site without using VPN
About a year ago, out of the blue, I started getting Server Not Found errors for a regular, clean site that I use constantly. Other site users I asked are/were able to access it no problem. Long story short, I took out a VPN subscription and was then again able to access the site again, but ONLY...
Browsers & Mail
Unable to access System Recovery in Boot Menu, and unable to boot disk
Win 7x64 Acer-5251 Everything seems to be working fine, but as the title suggests, when i tap F8 the Advanced boot options DO appear, but when i engage "Repair Windows" it just goes into a normal boot. Ive tried booting from my installation CD that i've purchased from Acer, but does nothing....
Installation & Setup
Unable to access my Maxtor!!!
I can see my 40 gig Maxtor usb drive sitting on my desktop, but alas I cannot access the contents, in fact I cannot even right click the drive to get to properties, if I double click the icon in my computer the whole desktop screen of icons disappears for a few seconds then all is normal. I have...
Hardware & Devices
Unable to access cbs.log
How do I access the cbs.log?
BSOD Help and Support
Unable to access old HD
Hi Friends Here is the situation. I was given a WinXP computer with a bad HD that will not boot and unable to get to a good restore point. I installed it on my good Win7 system and can see all the documents, pictures etc that I'm trying to backup on a CD. It seem that with my...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:38.
Twitter Facebook Google+