Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Sometimes, only the f,g,h,j,k keys do not type

16 Dec 2015   #1

Windows 7 Home Premium x64
Sometimes, only the f,g,h,j,k keys do not type

Starting about a month ago, I had this recurring problem where only a few keys would not enter a letter when typing. It's only (I think) the F, G, H, J, K keys. Sometimes it goes away, sometimes it stays until I reboot.

At first I thought it was related to some fishy sites I browsed in Portable Firefox using SandboxIE. When I terminated all programs in SandboxIE, I would get control of those keys after a few minutes.

Today when I booted up my PC, I had this occur right from the beginning. I ran scans in MS Security Essentials (don't laugh, please) and MalwareBytes. Nothing bad came up, so after a reboot, all seemed fine.

Odd Thing #1: Two hours later, after I had been browsing 'normal sites' in Chrome only (No SandboxIE, just normal Google, TomsHardware, Youtube, Amazon) I found it happened again.

I decided to play a movie on a second monitor while trying things out.

Odd Thing #2: Microsoft's On-Screen Keyboard does NOT register those keys (letter K for example) as a typed letter in an explorer window, browser, or start menu search.
Odd Thing #3: VLC recognized me clicking madly at the K button as setting the audio delay ahead on the movie!
Odd Thing #4: When I closed VLC, the problem stopped.

The problem did not come back when I played the movie in MPC-HC.

I don't think it's due to maxing my older system. This happened before I started playing Fallout 4 at 1080p medium settings. VLC plus some Chrome tabs only used 15% CPU / 3.8gb of 16gb. MPC-HC only used 9% CPU.

No hardware changes were made in the last several months aside from a gaming mouse in August. I am using a 5 year old MS X6 gaming keyboard and I tried an even older Acer OEM keyboard (both USB) and neither keyboard would type F, G, H, J, K keys.

I have a quad-core I5-750, 16gb DDR3, and an SSD for Windows, programs and games.

Help? Thanks in advance!

My System SpecsSystem Spec
16 Dec 2015   #2


Sounds like a strange one!
Are you all up to date with your Windows Updates as it sounds like a keyboard controller driver issue. However have you also tried using another USB port to be safe.
My System SpecsSystem Spec
16 Dec 2015   #3

Windows 10 Pro x64 x3, Ubuntu

Have you got access to another hardware keyboard - I used to see this in businesses in the good old days when all keyboards were switched type.

The keyboards are wired in a matrix arrangement and this sort of issue was due to mechanical failure of the supply to a bank of keys. as you say that you have a gaming keyboard this would normally use a similar system and you could have a damaged connection in the keyboard. I have physically repaired this type of error in the past when I had a failure on site where no replacements were available - but these days if this is the issue you have a replacement would b the best solution
My System SpecsSystem Spec

16 Dec 2015   #4

Windows 7 Home Premium x64

All but a few optional updates are up to date. Microsoft got out of the Sidewinder gaming keyboard market a while back but they do update drivers every so often, last one was in August.

I've tried front panel USB, rear panel USB, an add-on USB3 card port, powered USB hubs connected to the rear panel (which is what I had them on for 4 years), all no difference until I close a program (VLC, Chrome) that fixes it.

I've tried a basic wired $30 Logitech USB multimedia keyboard, and a few pack-in USB keyboards (Acer, Gateway) and all exhibit the same symptoms. All keyboards were at least 4 years old.

Baffles me too folks.
My System SpecsSystem Spec

 Sometimes, only the f,g,h,j,k keys do not type

Thread Tools

Similar help and support threads
Thread Forum
AULA Expert Gaming Keyboard keys don't type
I have recently built a new computer, and it has been working fine. The only major problem I have run into is my AULA BE FIRE Expert Gaming Keyboard has stopped working. The back lights are working, but none of the keys type. I have tested other keyboards on my computer and they all work fine....
Hardware & Devices
Keys that have FN functions on them not working as normal keys
I have a Commodore Laptop (Argentina) and all the keys that have a FN function attached to them do not work as their normal function any more - this happened after lending the laptop to my kids.... I think it may be FN lock, but can-t find any way to unlock it. Any ideas please. Many...
General Discussion
Is default email account type deteremined by type of device?
I set up an Outlook account on a new-to-me laptop. I had been unable to download email for several months, since I didn't have a computer. I had been saving the emails I wanted to keep and had planned on downloading them into my new computer. After setting up the account, it appeared the system...
Microsoft Office
how to deal with photo files Type 1 and Type 2
I found a few pix in my files that I want to edit with Photoshop. I can't open them in PS because they are Type 1 or Type 2. When I try to open them, PS says they are .jpg.1 or. jpg.2. How do I get rid of the .1 and .2 so they become normal JPG photo files? I can look at them with Windows...
Music, Pictures & Video
How Can I Disable The Multimedia Keys Covering The F1-F12 keys?
On my dell inspiron 15r the F1-F12 keys are covered by multimedia keys like volume, screen brightness, battery, internet, and other. I need to disable these because in some video games I play, I need to use these keys because they are set hotkeys that cannot be changed. Even better if anyone knows...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:36.
Twitter Facebook Google+