Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Corrupted disk structure, tried repair, only found one partition.

08 Feb 2016   #11

Windows 7 Home Premium 32 bit


3. PW does not find any second partition even with a Full Scan.That could be because you didn't change 42 to 07 for the second partition.( But do not change it on your own. Let me examine Sector 0 and then tell you) That necessitates examining Sector 0 for the second partition string and also sector 976768064 for the presence of Volume Boot Record. Again with a Hex Editor. So here we go.
Action Required: Since you have Windows 10 64bit version download BOOTICEx64 v1.332 from 【BOOTICE v1.3.3.2: 功能强大的启动维护工具】-*逸轩 ( Don't worry if it is all Chinese. THe program runs in English :)) .It will be a .rar file. Extract it to a folder named Booticex64 anywhere on your system drive. It will be a single BOOTICEx64.exe which you will run.At this point read through this post to familiarise yourself with using bootice Lost partitions!

Now make sure you have selected the right drive, click on Sector Edit and post a screenshot of sector 0.Then go to Sector 976768064 ( you can simply click on the sector field ,enter the sector No. and then click on OK) and post a screenshot. Close bootice.

4. "the first thing I did was go into the disk management utility built into windows, where I quickly noticed that the drive is flagged as an Invalid Disk" Did you also notice it was flagged as a Dynamic Disk??? Did you at anytime convert it as a dynamic disk?

5. Since you also have another 500GB drive, I would like to see the Partition Table in it. So connect the other 500GB drive, run bootice, Click on the partitions button and post a screenshot like the one below.I may use it as a reference template if need arises. Once you have posted the screenshot, you may disconnect it again so that there is no confusion later as we proceed.

Corrupted disk structure, tried repair, only found one partition.-08-02-2016-16-01-26.jpg

Note: All the sections in the above two posts are selfcontained and independent. You may do it one by one at your leisure and at your own pace and post. There is absolutely no hurry. Do things in a calm and composed manner - not when you had a fight with someone else :) or stressed in any other way. .

My System SpecsSystem Spec
08 Feb 2016   #12

Windows 10 64 bit.

1. Yes the WDM screenshot is current.

2. Here is the new screenshot requested. All files seem to be there as best I can remember.

Corrupted disk structure, tried repair, only found one partition.-new3.png

My System SpecsSystem Spec
08 Feb 2016   #13

Windows 10 64 bit.


Sector 0

Corrupted disk structure, tried repair, only found one partition.-sector-0.png

Sector 976768064

Corrupted disk structure, tried repair, only found one partition.-second-sector.png

4. I honestly can't exactly remember about the dynamic part.

My System SpecsSystem Spec

08 Feb 2016   #14

Windows 7 Home Premium 32 bit

I have seen upto this point. I shall now wait for your response to section 5. Take your time since I am retiring now. After you complete it, I shall post on further course of action. Good day.
My System SpecsSystem Spec
08 Feb 2016   #15

Windows 10 64 bit.

5. I just now remembered/realized that the other drive is no longer a Seagate drive of the same size as this one. I took it out of use and disposed of it a couple of years ago after experiencing a BSY error that required connecting it to a software terminal to bring it out of that state. The other drive in there now that is not connected is a newer Western Digital. Please forgive the incorrect information.
My System SpecsSystem Spec
08 Feb 2016   #16

Windows 7 Home Premium 32 bit

OK, The data on your first partition is still there. There should be no problem in recovering it. You need 200GB of free space on your Western Digital drive to copy those. Check and confirm. Then we shall do it with some freeware (Partition Find and Mount ( easy to use) and if it fails TestDisk ( little difficult to use, but a power machine)).

Your second partition: The partition string(table) for the second partition is missing in sector 0 (How come????). It is as if no second partition exists. Volume boot record in some form is present at sector 976768064, the first sector of the second partition. However PW is unable to identify it even with a Full Scan to be able to write the partition table in sector 0.So we have to give up on Partition Recovery and move to data recovery as aforesaid in para 1..

Now what is the data in the second partition? You do not know. That means you have no need for that data and it has been so for a longtime :).

Still if you want to find if there is something in there, try GetDatabackSimple v2.00 5.6MB Free Trial version.. Download, install and run it. When it detects your system drive and the 500GB Seagate drive, click on the 500GB drive which should then show the detected partitions.Hover the mouse pointer over each partition and click on the partition which shows "Open NTFS at Sector 976768064 ......" See whether you can see the files and you need those.

( You can do this even for the first partition and see the files. But you can't copy those with the Trial version. You need to buy a license for $80).

Corrupted disk structure, tried repair, only found one partition.-09-02-2016-08-30-00.jpg

My System SpecsSystem Spec
16 Feb 2016   #17

Windows 10 64 bit.

Hello, thank you very much for your help thus far. Sorry I'm just getting back to you. Been out of town away from the affected drive and not been able to continue this process until today.

I downloaded GetDataBack Simple, installed it and ran it but got the following error twice before I could get to the screen you posted. In addition to coming up for sector 6293504 it also showed up for sector 6293568

Corrupted disk structure, tried repair, only found one partition.-gbs.png

I clicked ignore on both of those instances and this is the screen that came up after that.

Corrupted disk structure, tried repair, only found one partition.-sectors.png

When I hover over the first partition it shows it's open at sector 63, the second one at 2,048, and the third at 488,396,608

When I tried to click on the second one I got this error on sectors 6293504 and 6293505.

Corrupted disk structure, tried repair, only found one partition.-capture3.png

After clicking ignore on each instance this is what I show now on each partition.

Corrupted disk structure, tried repair, only found one partition.-par1.png

Corrupted disk structure, tried repair, only found one partition.-par2.png

Corrupted disk structure, tried repair, only found one partition.-par3.png

I've downloaded Partition Find and Mount and Test Disk and have them installed and ready to use when and if we need them.

I'm currently running MiniTool Partition Wizard again to see if the files that showed up there ealier still come up as I figured they would have also showed up on GetBackData.

Again, thank you for your help and patience.

My System SpecsSystem Spec
16 Feb 2016   #18

Windows 7 Home Premium 32 bit

Yes,check again with PW and confirm whether you can still see the files in the first partition. Getdataback did not give any useful information and if things were still good, it should have shown your files in the first partition atleast. Now I have a doubt that the HDD may be regressing day by day.

If you confirm that you can still see the files in PW, we shall then straightaway get on to TestDisk and try to recover whatever can be recovered.
My System SpecsSystem Spec
16 Feb 2016   #19

Windows 10 64 bit.

PW came back with the same results as before and the files do show up there.
I'll await your instructions for continuing with TestDisk.
My System SpecsSystem Spec
17 Feb 2016   #20

Windows 7 Home Premium 32 bit

I was composing a reply - a long post detailing the TestDisk steps. When I was almost at the finishing stage, CKWD sent a PM and at that instant my writeup disappeared inexplicably.So I had to pick up steam to redo it .

OK, I hope you have downloaded the Windows version of TestDisk and extracted it.
I also hope you have enough space on your WD internal drive to copy the files listed by TestDisk. Connect it and create a folder named Recovery where you will copy the files. You can also use an external drive and create that folder if you have space on it. Before running TestDisk the destination drive should remain connected for TestDisk to recognise. ( You cannot connect those after starting TestDisk)

With the destination drive connected/plugged in, run testdisk_win.exe

First Screen: With up/Down arrow keys, highlight/select No Log Press Enter

Second screen: You should see all your connected disks and drives. Post a screenshot. Highlight the Disk ( not Drive) you want to recover Disk ( sda /dev /* ) You should be able to identify the drives with the capacity.
[Proceed] Enter

Third Screen:Highlight [Intel] if not highlighted already Enter

Fourth Screen: [Analyse] Enter

Fifth Screen: Current Partition Structure will be shown. Post a screenshot. [Quick Search] should be highlighted Enter

Sixth Screen: Let the analysis complete. You can see the progress. When complete it may show a number of partitions. Post a screenshot.

At this point click on X at top right corner to quit TestDisk.( You may also press q repeatedly till it takes you out)

Let me see the above three screenshots and decide on the next step. You can run TestDisk again.

Note: If you have any doubts on dealing with any screen post a screenshot and quit TestDisk.

Do not go to any step, choose any command on your own. Especially do not give a [Write]
command unless instructed.

( I was at this stage when CKWD sent a PM and the whole writeup vanished instantly. When I write the steps I always run TestDisk, see the screen and write because it is very difficult to remember the DOS steps.I had to rerun TestDisk again and rewrite the steps.)

Before you run TestDisk, take your time to read the following threads/posts to familiarise with TestDisk. You may then feel comfortable when you run it.

Running TestDisk: Regain a lost drive using Test Disk - An Illustrated Guide

Copying files listed by TestDisk: My external hard drive suddenly became unllocated:
My System SpecsSystem Spec

 Corrupted disk structure, tried repair, only found one partition.

Thread Tools

Similar help and support threads
Thread Forum
Pendrive Inaccessible - Disk structure is corrupted or unreadable!
I download everything from the internet into my 32 GB HP Pendrive and also use it for Windows Ready Boost. But yesterday suddenly it gave the error message - G:\ is not accessible. The disk structure is corrupted and unreadable. I ran CHKDSK /r and the following is the output. The...
Hardware & Devices
sfc and startup repair found corrupted files but can't fix
Win 7 starts ok but sfc reports corrupted files Cbs Log attached. Any advice will be appreciated
Performance & Maintenance
Need Partition help? Startup repair says no OS files found on disk.
After running startup repair, the details state the root cause to be "No OS files found on disk. Repair action: Partition table repair. Result: Failed. Error code = 0x3f8" I have Partition Wizard and have a funny feeling that might help, but I'm not 100% sure how to use that software for this...
General Discussion
Hard disk Error - The disk structure is corrupted and unreadable.
I have IOmega 1 TB hard drive. 2 days ago, my comp restarted suddenly after which my external drive is corrupted. I get the error 'H: is not accessble' The disk structure is corrupted and unreadable. It shows up in the disk management as RAW file system, I have almost 700 GB of important...
Hardware & Devices
Laptop DVD-RW Issue: "The disk structure is corrupted and unreadable"
I am working on someones laptop with the complaint that the DVD drive stopped working. It was working last night. Running W7 32 bit. I tried to play some CDs and DVDs in Windows. Tried to boot a Linux disk, a Partition Wizard Disk, an Acronis Boot disk, a Windows 7 Disk. No play, no boot. In...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:09.
Twitter Facebook Google+