Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't get my printer to work. It is in working order.

16 Feb 2016   #1

Windows 7 Home Premium 64bit
Can't get my printer to work. It is in working order.

After a clean re-install of Windows Home Premium by my computer shop who built my comp. 11 months ago), everything else works OK except printing. The printer worked perfectly a week ago (6 months old Canon MG 6650). I have always simply opened a doc. in Notepad or MS Word (or Photshop etc.), typed something and done File > Print and its is printed. Now, I get tangled in a loop with OneNote which I don't want to use. Here is what happens:

In Notepad
1. I start up the comp., open a Notepad text file, do File > Print. In the Print D. box I am offered "Send to OneNote", "Fax" and "Micrsoft XPS Document Writer" (also "Add Printer"). All are described as "Ready". If I choose "Send to Onenote 2013". I press Print at the bottom and OneNote opens but there is no way to print. (I don't want Onenote.)

Instead, I D. click Add Printer. A D. box appears with two options: "Add local printer". On D. clicking on this this I get "Use this option only of you don't have a USB printer. (Windows automatically installs USB printers when you plug them in.)" The other option involves a network printer - (I am not on a network).

Back to the Print D. box I press "Find Printer" and all I get is the name of my comp. and if I select it I get "No items match your search." If instead of choosing Add Printer I choose Fax or Microsoft XPS Document Writer, all three buttons are dark (active).

In Word 2013
3. At an early stage, when starting to print in Word, I got a message like "Sorry, you need to print to OneNote first." So I tried that: Word > File > Print. The previous three print options are offered, all labelled "Ready" so I choose "Send to OneNote", press the Print button. OneNote opens with the text displayed but again no option to print. I don't want OneNote.

4. In Word 2013 with a simple text file (open) I do File > Print. Under the Printer button, a dropdown offers "Send to OneNote", "Fax" or "Microsoft XPS Document Writer", all three labelled "Ready". Also in that dropdown list I click on Add Printer. I get "The Active Directory Domain Services is not currently available" and a D. box "Find Printers" but all options buttons or fields a non-reactive.

The printer is plugged in to a USB socket as usual and switched on. It works on my Imac. Early on in this present saga I was offered to install a printer driver but it said that Windows will always find a USB printer driver (presumably automatically). So that was no help. When I set this printer up 6 months ago it found the driver and got to work.

So how can I get the thing to work please? Hope someone can nail it.

A thought: As my iMac is retired but working, I set up this printer on it while the Windows machine was having W7 clean re-installed. Worked fine. Then, after my Windows 7 machine returned, I found this above problem. Could it be that the printer still has the Mac printer driver and Windows is confused? However, it previously had the W. driver on it and the iMac managed to install the Mac driver over it. If that is the explanation, how to scour the iMac driver from the printer?

(Whew! It doesn't half bite into a working day investigatin this and drafting all this accurately and clearly.)

My System SpecsSystem Spec
16 Feb 2016   #2

win 7 64 bit

Hi I would uninstal everything pertain to the printer in programs and features. And uninstal driver in device manager and then reinstall the printer.
My System SpecsSystem Spec
22 Feb 2016   #3

Windows 7 Home Premium 64bit

Quote   Quote: Originally Posted by oscer1 View Post
Hi I would uninstal everything pertain to the printer in programs and features. And uninstall driver in device manager and then reinstall the printer.
I spent hours going through the Canon and Microsoft on-line advice on how to re-install the driver: 5 different methods. Eventually I rang Canon and, after a second call I was given instructions on how to download the driver manually from their site. It worked. It took several stages (automatically) and it became obvious that all the earlier attempts got nowhere near downloading and installing. Happy now.
My System SpecsSystem Spec

22 Feb 2016   #4

win 7 64 bit

Glad you got it sorted
My System SpecsSystem Spec

 Can't get my printer to work. It is in working order.

Thread Tools

Similar help and support threads
Thread Forum
Will Wolfenstein The New Order work on an Intel Graphics 3000 HD?
Rage can work on an Intel Graphics 3000 HD, so why not Wolfenstein the New Order? What do you people think? Will I be able to run the game or not? Both use the same engine. It could work.
Cant Add printer as printer spooler not working
I recently bought a new desktop with Windows 7 as the OS. Have a HP Laserjet 1018 and installed it. Worked fine for a couple of days and all of sudden I get this message when adding the printer (windows can't open add printer. The local print spooler service is not running please restart the...
Hardware & Devices
Work Around for Printer not working
Hi - I'm new to this forum, having just recently purchased a laptop with Windows 7 on it. I'm still finding my way and am currently trying to make my older HP PSC 2210 All-in-one printer work. When I plugged in the USB cable, it didn't recognize the printer or load any drivers (as far as I could...
Live Photo Gallery - order prints doesn't work
When I try to order prints online from Live Photo Gallery (Print menu, Order Prints) it says " No printing companies found in your area". This happens on two Windows 7 systems. It works correctly on a Vista machine. Any ideas how to fix it?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:43.
Twitter Facebook Google+