Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: HDD 2Tb Unallocated, how to retrieved all data

22 Mar 2016   #11

Windows 7 Home Premium 32 bit

I am also hoping that there is a possibility to restore your drive. Yesterday I did a small experiment. On my 750GB external drive which I keep exclusively for my experiments, I created an MBR drive with a single partition in Windows Disk Management, copied some 30GB of data onto it and then did all that you did.:)

In your case we don't know exactly what happened to the sector 0. A drive asks to be initialised only when sector 0 containing the MBR code and the partition table gets corrupted. Initialising the drive only writes the MBR code to sector 0- not even the partition table. Only when one creates a new volume the partition table is written into sector 0 in its assigned space. Simultaneously it also writes zeros to sector 2048 where the first volume/partition always starts and making that sector ready to write the NTFS onto it when one formats.

That initialising a drive will destroy all data is a myth. Initialising stops with sector 0 and does not touch any other sector if one stops with just initialising. Nothing new here. See my post here Disk Mgmt ask to initialize a drive that isn't there. . Shows where the MBR code lies and where the Partition table rests, all in sector 0.

Now to carryon with the experiment, I destroyed the MBR code and the partition table in sector 0 by writing all zeros to sector 0 (using bootice). My drive became inaccessible. When I invoked Windows Disk Management it wanted me to initialise. I initialised it as an MBR. MBR code written into sector 0. I proceeded to create a new volume, assign a drive letter to it but "do not format". Exactly what the OP did. Creating a new volume wrote the partition table to Sector 0. Simultaneously it wrote all zeroes to sector 2048 where my original NTFS existed.Now Partition Wizard also will not find the partition since it sees only zeroes at sector 2048 and no NTFS. I now use TestDisk to find whether the backup of the NTFS exists and is in good shape. It did find the backup ok and wrote it into sector 2048. My drive came back alive with all data that I had originally written intact. And it was a surprise double delight. TestDisk not only wrote the NTFS boot record into sector 2048 but also wrote the corresponding Partition table into Sector 0. I was thinking that I may have to run Partition recovery Wizard to find and write the partition table after TestDisk wrote the NTFS on 2048.

There was a little unknown phenomenon when I did this experiment. When I did the create new volume, assign a drive letter but do not format operation and then checked with bootice, it showed a FAT16 partition starting at sector 2048 even though sector 2048 was all zeros. TestDisk also found it as a FAT16 partition. I asked it to look at it as an NTFS and look for the NTFS backup. It did find the backup OK and wrote the NTFS backup to sector 2048 bringing my drive back alive.

With the renewed conviction that doing all this does in no way affect the data, I am now going to ask the OP to do the same thing again. (In the previous run TestDisk did not find a partition and therefore the NTFS back up.)

And so, Tony H, do the following.

1. Write zeros to sector 0

2. When Windows Disk Management asks you to initialise it do it as an MBR disk.

3. Create a new volume, assign a drive letter but do not format. Safely remove the drive and plug it in again. (If it refuses to be safely removed citing that some program is still holding it, close all programs , shut down your PC, unplug your drive and plug it in after the reboot.)

4. After this, run bootice, click on the Partitions button and check whether it shows a FAT16 partition at 2048.

5. If it shows, then run TestDisk and repeat what you have done as per my post #3

Does it show you a FAT16 Partition found, instead of the " No partition available" message you got last time?

If it does find, post the screenshot. I shall give further instructions to find the NTFS Backup.

If not, we may turn to other avenues to get the data. Yes, we don't lose hope till we finish with all that we can.

Now I shall only give instructions on how to write zeros to sector 0 and write it to the drive.

Using bootice select your external drive >Sector Edit. You will be at sector 0 ( Make doubly sure you don't do this on your system drive. :) )

Run the mouse pointer diagonally across to select all fields > Right Click > Fill Selection > Fill with 0x00 > OK

HDD 2Tb Unallocated, how to retrieved all data-22-03-2016-23-11-05.jpg

HDD 2Tb Unallocated, how to retrieved all data-22-03-2016-23-16-09.jpg

You will see all fields 00. Click on Save Changes on the top menu bar. Done. You have written 00 to sector 0 of the drive.

Quit bootice, safely remove your drive and then plug it in again.

Go to Step 2 above, Windows Disk Management. You will be asked to initialise the drive.

Proceed as instructed already.

I am keeping my fingers crossed. :)

My System SpecsSystem Spec
23 Mar 2016   #12

Windows 7 ultimate x64

Hi Jumanji,
That great, really appreciate the experiment you did.

just followed the step you mention, here is the result :
1. Run the Bootice
- Changed value 00 to sector 0, Done.
- I dont find the Fat16 partition at LBA 2048 (screen shot)
HDD 2Tb Unallocated, how to retrieved all data-bootice_4_after.jpg
2. Run the TestDisk
- Followed the #3 post, but i don't choosed boot because i read you only need to know is there Fat16 partition available.
- The Fat16 partition available (screen shot)
HDD 2Tb Unallocated, how to retrieved all data-testdisk_3_after.jpg
i really read your post carefully, hope i dont miss that you ask for.
just able to do it now. :)

My System SpecsSystem Spec
23 Mar 2016   #13

Windows 7 Home Premium 32 bit

That looks good. And yes, I wanted you to stop at this for further instructions.

Screenshots will follow explaining what exactly you should do now. Please wait.
My System SpecsSystem Spec

23 Mar 2016   #14

Windows 7 Home Premium 32 bit

Do the following:

When you get the screen showing the Fat16 Partition, move Highlight to [Type] Press Enter key

HDD 2Tb Unallocated, how to retrieved all data-2-move-type.jpg

This will be the next screen. [Proceed] Enter

HDD 2Tb Unallocated, how to retrieved all data-3yougetthis21-03-2016-21-24-32.jpg

On this next screen type 07 after the question mark as shown and press Enter

HDD 2Tb Unallocated, how to retrieved all data-4type07.jpg

You will get this next screen showing that the partitionType has been changed to HPFS - NTFS.
[BOOT] Enter

HDD 2Tb Unallocated, how to retrieved all data-5yougetthis.jpg

Do you get this screen now? If the Backup boot sector status is OK, then and only then [Backup BS] Enter

HDD 2Tb Unallocated, how to retrieved all data-6backupok.jpg

When you get this screen type y on your keyboard to say yes. Wait for a few seconds.

HDD 2Tb Unallocated, how to retrieved all data-721-03-2016-21-37-07.jpg

Do you get this screen saying that both Boot sector and Backup boot sector are OK now?

HDD 2Tb Unallocated, how to retrieved all data-821-03-2016-21-40-20.jpg

Now quit,quit quit quit till you quit TestDisk or just click on the X close button on top right corner.

Safely remove your external drive and then plug it in.

Can you access your drive and see all your data?

As always a pessimist :), I keep my fingers crossed.

Do this slowly. Take your time to look into each screenshot before you press Enter or any other command. It may take a few seconds for TestDisk to execute each command. So after each command wait for a few seconds for the next screen to appear.

If any screen is different from what is shown above, post that screen and quit TestDisk. Do not play with TestDisk. :)

My System SpecsSystem Spec
23 Mar 2016   #15

Windows 7 ultimate x64

Hi Jumanji,
no good, the screen is different.
both status boot sector and backup boot sector are bad.
HDD 2Tb Unallocated, how to retrieved all data-testdisk_4_after.jpg

i always like your warning, it kept me alert anytime :)

My System SpecsSystem Spec
23 Mar 2016   #16

Windows 7 Home Premium 32 bit

That is absolute bad luck. The backup boot sector is also bad.

The screenshots I posted were from my experiment, where it could find the backup OK exactly after doing what you had done in the first part. Since I don't know how EaseUS Data Recovery and the Power Data Recovery work, I can't say for sure that those could have botched up your drive but only suspect.

Now you are left with only one option. Trying to recover data using PhotoRec. PhotoRec will try to rebuild your files without depending upon the file system. Using that you can get only all the files without the original file names and folder structure. You can read about PhotoRec here PhotoRec - Digital Picture and File Recovery Of particular interest will be PhotoRec step by step in that page. You will find photorec_win.exe in the same TestDisk Folder. A rudimentary guide on using PhotoRec is here written by one jumanji :). Guide to using PhotoRec recovery software. . Straightaway go to the topic under Recovery ( Do not format your drive) Note: You should have another formatted external drive with adequate space plugged in to copy the files recovered by PhotoRec.

You can also try the Free Trial version of GetDataback Simple, scan your external drive and check whether it shows all your files complete with the original folder structure and filenames.If the MFT is not corrupted it should be able to do that. You can preview the files also and if you are happy you have buy a licence to copy.

Another commercial software recommended by the author of TestDisk when PhotoRec fails, is Zero Assumption Recovery.

PhotoRec, Getdataback as well as Zero Assumption Recovery do not write anything to the drive under recovery and are absolutely safe.

Keep us posted when you try these things.

Note: On your last screenshot, Move Highlight to [Rebuild BS] and press Enter. Check whether it can successfully restore the boot Sector, before proceeding with PhotoRec/ Getdataback/ZAR. I missed it.
My System SpecsSystem Spec
23 Mar 2016   #17

Windows 7 ultimate x64

Hi Jumanji,
i will try the software recovery that you mention after my new HDD arrived (yesterday purchase from online shop).
will update the post also when i have tried all the option available.
Thanks a lot for all your help and support, i have gained much knowledge from this thread. :)
My System SpecsSystem Spec
23 Mar 2016   #18

Windows 7 Home Premium 32 bit

While you wait for your online order to be delivered, you can try Rebuild BS in TestDisk. I missed it and added it at the end of my last post. So you could have missed it.. It will try to rebuild the NTFS Boot Sector at sector 2048. If it is successful, OK. If not go to PhotoRec/ Getdataback/ZAR

When you try Rebuild BS post the screenshot of what happened. I haven't tried it anytime before and so I need to learn too .

And yes, you do learn how to use certain tools.Especially bootice is a nice tool. You can click on the Partition Table button, that gives you details of all partitions and important sectors. You can save those individual sectors.

When you have problems with your HDD, you can examine what happened and restore the important sectors from the back up. In your case for example, when it asked you to initialise, you could have examined Sector 0 and restored it from the backup you had made. You could have also restored Sector 2048 from the backup. In this particular case Sector 0 and Sector 2048 are the most important sectors. We could manage to get Sector 0 right, but were unable to recover Sector 2048. If only you had backed up sector 2048 with bootice earlier, we could have easily restored it.

In most cases, restoring the important sectors by itself will clear the problems. Even if not, it makes further data recovery easier since we have all important sectors right.
My System SpecsSystem Spec
24 Mar 2016   #19

Windows 7 ultimate x64

Hi Jumanji,
ok i will try rebuild BS first.

i see, but how to backup sector 0 and 2048 ?

some strange thing happen, today i plug the drive and in the computer management written not initialized.
ehmmm i will redo yesterday step and then rebuild BS.
My System SpecsSystem Spec
24 Mar 2016   #20

Windows 7 ultimate x64

Rebuilding BS on progress

Attached Images
HDD 2Tb Unallocated, how to retrieved all data-testdisk_5_after.jpg 
My System SpecsSystem Spec

 HDD 2Tb Unallocated, how to retrieved all data

Thread Tools

Similar help and support threads
Thread Forum
How can I recover data from HDD now showing as Unallocated?
Hi, I'm trying to recover the data (including some treasured family photos) from a Western Digital 320GB HDD that died in my sister's desktop HP PC using my Windows 7 work Dell laptop. I can only see the disk using Disk Management, where it shows as unallocated. ...
General Discussion
Lost Partition - Now Unallocated - Data Recovery
I purchased a new Motherboard to upgrade my computer and new SSD drive. I installed Windows 7 again on my new SSD. I had a 3TB Seagate Drive that had 3 partitions. One partition had Windows 7 and system files. The other two had data. Now, one of my data partitions shows as Unallocated. The old...
General Discussion
unallocated drive lost the data
i was using a third party patition manager and suddenly i saw that my big hdd was lost in my computer and when i opened the disk management then it was unallocated then i right clicked it and assing a drive letter then i was appeared but i really killed me when i saw whole drive was vacant . then i...
Backup and Restore
Windows 7 Data Drive (D:) Suddently Unallocated
I recently shrunk the data partition(D:) to let me increase the system partition(C:) size. I used gParted on the D: partition, but it would not resize the C: partition. However, Parition Wizard successfully resized the C: partition to use the space freed up by shrinking the D: partition. They are...
General Discussion
(Urgent) The Data On HDD Can't Retrieved
i have Seagate FreeAgent Godflex 500GB..i wanted recover the data but its popup the message prompt me to reformat the drive before use..on the boot,its popup the message said that NTDLR is missing.. I dont have any ideas about this i upload a photos for the problem ...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:18.
Twitter Facebook Google+