Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Drobo 5D HDD unacessable and RAW

06 May 2016   #1

Drobo 5D HDD unacessable and RAW

Hello all!

I've read through many posts, especially everything Jumanji has written on the subject and haven't found a solution and am a bit overwhelmed about the many solutions.

As you can see from the pictures, i have an array of 16TB. Drobo uses beyondRAID. I ran CHKDSK and received the error "Corrupt master file table CHKDSK aborted." I also ran Stellar Phoenix to see if i the possibility of recovering my files. They seem like they are all there, but i didn't recover anything because they were in complete disoray.

Should i use partition wizard, testdisk, bootice, or easeUS?

Please help, i have irreplaceable files on this that i need to recover!

Thank you!

Attached Thumbnails
Drobo 5D HDD unacessable and RAW-screenshot-2016-05-05-23.55.59.png   Drobo 5D HDD unacessable and RAW-screenshot-2016-05-05-23.58.47.png   Drobo 5D HDD unacessable and RAW-screenshot-2016-05-05-23.59.20.png   Drobo 5D HDD unacessable and RAW-screenshot-2016-05-05-23.59.55.png  
My System SpecsSystem Spec
06 May 2016   #2

Windows 7 Home Premium 32 bit

Welcome to Seven Forums.

When did it become RAW?

Did you make any changes to the partition structure of the S drive? There is something suspicious about it for I see a 128 MB Unallocated space at the end of S drive.

Please look at the Partition Wizard screenshot. You see many GPT drives in it. Take N:. When any drive is initialised as a GPT drive and formatted , Windows Disk Management as well as most other formatting software, will create a 128 MB MSR partition at the beginning of the drive. GPT specification does not allow any vacant space in between the partitions or at the end. How come there is a vacant space at the end?

Anyway, while you answer this query, you may go ahead and install the free version of Getdataback simple

Scan your S drive and check whether it shows all your files with the original file sructure intact. You can also select the files and check their integrity. If you can see post the screenshot.
My System SpecsSystem Spec
06 May 2016   #3


Thanks so much for your response.

This happened randomly one day. I’m not sure if it was due to being plugged in during an automatic windows update, or a power surge. Quite frankly, i have no idea how it happened.

the 128mb partition also concerns me. Unlike other 128mb partitions i’ve had in the past that were permanently there and difficult to remove. This one is accessible via computer management. Should i remove or reformat the 128mb partition?

I ran the data recovery software and attached the screenshot. Barely anything showed up. Do i need to do a deeper scan?

I also ran another scan using ZAR. It recovered more items with intact file structures, but still missing quite a bit. I also attached a screen shot of that.

When i ranStellar Phoenix a lot more came up, but it was disorganized.

Attached Thumbnails
Drobo 5D HDD unacessable and RAW-screenshot-2016-05-06-04.24.17.png   Drobo 5D HDD unacessable and RAW-screenshot-2016-05-06-04.26.08.png  
My System SpecsSystem Spec

06 May 2016   #4

Windows 7 Home Premium 32 bit

When MFT is corrupt, you have to necessarily turn to Commercial software. The author of TestDisk, Christophe Grenier, recommends Getdataback and ZAR.

You can try other levels also in Getdataback and see whether it shows more files. In Getdataback you can also select the files and preview it.

One disturbing aspect I see is that checkdisk seems to have played further havoc on the drive. Whatever, nothing can be reversed at this stage and you have to finally decide between the two - GDB and ZAR -and be happy with whatever you get. But make sure to preview the files shown by GetDataback and check the integrity wherever it can be previewed.

There is no point in trying to alter the partition structure now.You may lose even whatever you can get now. These experiments can be done later after the available files recovery.

Some users had reported good results with Active @ File Recovery Active@ File Recovery searches for lost & deleted files, recovers damaged volumes, disks & RAIDs You may try that too. All these programs are scan and read only and so whatever data is there will not be altered.

I do not know anything about Drobo 5D but sometimes the docks like these can also create problems. You may consider to discuss it with their Tech. Support and see whether they can throw some light on it.

I have nothing more to contribute on your data recovery problem other than the above advisory .
My System SpecsSystem Spec
06 May 2016   #5

Windows 7 Home Premium 32 bit

After a close look at the ZAR screenshot ( which escaped my attention since I was concentrating more on Getdataback) I also agree that ZAR seems to have done a better job. There also there is a fragments folder which I believe is the handiwork of Check disk.

As told earlier you may try deeper levels of getdataback and then decide which is better . Quite obviously I can't make that decision for you. You are the best judge having the physical possession of the drive.

Just for your further reading:

Since you have a number of GPT drives these posts may be of help to you to deal with any partition related problems in future. As you will see in these posts, the first few sectors carry the GPT structure data. The last few sectors have the backup of the GPT structure data.

Lost partitions!

Benefits of GPT vs MBR Primary and MBR Logical Partitions ?

Benefits of GPT vs MBR Primary and MBR Logical Partitions ?
My System SpecsSystem Spec
06 May 2016   #6


Thank you. At the moment, i'm running a level 4 scan using getdataback. Depending on what data is recovered and the condition it is in, I'll do a deep scan with ZAR. Hopefully, between the 2 i'll be able to recover a substantial amount of my data and back it up.

Unfortunately, due to the size of the disk array, this is going to take a very long time!

I'll check in and update my findings after each recovery attempt. And hopefully, after we can explore altering the partition structure.

Thanks again for your help, and I'll definitely read those articles you sent me.
My System SpecsSystem Spec
26 May 2016   #7

Windows 7 Professional x64

Hello shabuwarrior,

Were you able to recover your data from the Drobo 5D?

I cannot thank you enough for your post as it helped me recover data from my Drobo 5D which showed up as RAW after a careless mistake from my end. In the event this post may help others like me I will state what happened to me and how I managed to recover the data and also what has to be avoided when using a Drobo 5D.

I have 5 x Drobo 5D units connected to a PC for data storage. On this PC I was doing a clean install of Windows 10 and was overwriting the C: drive which is a separate HDD (not the drobos). I accidentally forgot to disconnect all the drobos while installing.

The Drobos showed up when I had to select the partition to install Windows 10. I was in a hurry and I didn't think this would cause any issues and continued with the installation.

I selected the C: drive which had the windows partition earlier and formatted it to clean install.
Windows 10 copied the install files and rebooted.

I was away while the reboot occurred and initial windows startup was happening. (5mins maximum) When I came back I noticed a disk check going on drive G:, I could not cancel it. I noticed it was reading or writing to one of the Drobo 5D units as its disk read / write light was on. I panicked and fearing data corruption, shut down the PC with the power button. I disconnected all the Drobos and re-installed Windows 10 with only the C: connected.

Upon completing the Windows 10 install, I installed Drobo dashboard and only 4 x Drobo 5D units were shown. 1 x Drobo 5D was showing a RAW partition.

But this was not the Drobo 5D unit which had the read / write light illuminated when I shut the PC down with the power button. I was able to read and verify data fine on all except for 1 x Drobo 5D unit which had the least amount of data with only 3 drives added and in dual disk redundancy mode. All others had 5 drive bays populated with dual disk redundancy mode. My assumption is that the affected Drobo 5D had completed a disk scan and by the time I came back I was witnessing another Drobo 5D being scanned.

Drobo Dashboard status as it showed the Drobo 5D

995.65GB of data shown above.

There was about 1TB of data on the drive that I needed badly. I tried testdisk but was not sure on how to go forward as I had not come across the type of screens that I saw with this situation. Then I came across this post. I tried getdataback simple, it managed to find all the directory and file structure but the recovered files were corrupt!! I was fearing the worst thinking that Windows had corrupted the partition and there was no way to recover. I tried Recuva for a brief moment and saw some files that it managed to recover. These were not corrupted but I didn't have the file / directory structure. So this gave me the idea that the data could be recovered.

I then tried the software ZAR you have mentioned. It did the data recovery scan with it and after about 1 hour I was shown the directory structure and files, same as the result I got from getdataback, but the great thing was all files that were recovered now with ZAR were free from corruption!!!

1001.9GB recoverable above. Appears that all the data was detacted by ZAR and is recoverable.

I have not experienced the Drobo 5D having a RAW partition before. My experience was caused by Windows 10 trying to scan the drive for errors and fixing what it thought was faulty. This was however when the Drobos were connected without loading their drivers upon Windows 10 install. On a previous occassion I had this PC do an automatic update on its own from Windows 7 Pro to Windows 10 Pro a few days back and nothing happened to the connected Drobo 5D units. I would assume this was due to Windows 7 having the drobo dashboard installed with proper driver support for the Drobo 5D prior to the upgrade and Windows didn't try to checkdsk the Drobo.

I have read elsewhere that you should disconnect the Drobo should there be an error on it to prevent the drobo accidentally assuming data areas as free space and erasing them. There was a piece of software that I found below by watching a video on youtube which can mount the Drobo volumes by connecting each drive to the system directly without the Drobo enclosure.

Link to the software ReclaiMe File Recovery Software
My System SpecsSystem Spec
17 Jul 2017   #8

Windows 10

Hey, just made an account to add this.

I had exactly the same problem. The Drobo was formatted by mac with HFS+ and I was running Paragon. I just uninstalled and reinstalled Paragon and it fixed it right up.
My System SpecsSystem Spec
17 Jul 2017   #9

Windows 7 Home Premium 32 bit

Hi boxofrabbits,

Welcome to Seven Forums thank you for coming in with your experience.

However, I can't say for sure that the problem is the same as that of shabuwarrior - the first poster and Prabodha - the second poster.

shabuwarrior didn't know how and why the Drobo drive turned RAW. His Drobo was all the time connected to his PC. Prabodha was installing Windows 10 without disconnecting the Drobo.

In your case however you had only mentioned that your Drobo was formatted by Mac with HFS+ and uninstalling and reinstalling Paragon solved the issue. What was the issue and how it came about is not mentioned. Perhaps you should have elaborated on it. I presume that the old version of Paragon could not read the HFS+ in Drobo's BeyondRaid while the new version of Paragon did it.There was no data recovery involved in it.

Whatever, one has to follow the cardinal rule that during Windows installation, one should disconnect all the storage devices other than the drive on which Windows is being installed ( especially the docks). Also it will be prudent to disconnect the external drives/docks when not in use. ( Plug in only when required)

If one falters on it and a drive in the dock - especially the DROBO - becomes RAW, do not run Checkdisk which may spoil the data. Abort it without any further delay if it starts running on its own to prevent the data getting scrambled beyond recovery. Straight-away try data recovery with

1. Getdataback Simple (USD 80), 2. Zero Assumption Recovery (USD 70) 3. active @ File Recovery (USD 30)

One may do a better job than the other in recovery and the trial versions facilitate previewing the files that can be recovered. So try all three, preview the files for their integrity and then decide to buy one that does best. All three are Scan and Read only and do not alter the data in anyway.

Note: According to the first two posters ZAR seems to have done the best between GetDataback and ZAR. They did not try active @ file recovery which costs less.

Prabodha made another important point that it would be better to pull out such drives, directly connect them in a desktop and try data recovery since the background processes of the DROBO can spoil the data in it further - according to the promotional youtube video. He found that ReclaiMe software specifically deals with Drobo recovery with all the Drobo drives connected directly in a desktop. Personally though, he seems to have used ZAR with the drives sitting in the DROBO as shabuwarrior did.

Note: I have only documented what I have learnt or seem to have learnt :) reading all three posters (apart from jumanji) in this thread.
My System SpecsSystem Spec

 Drobo 5D HDD unacessable and RAW

Thread Tools

Similar help and support threads
Thread Forum
Suddenly unable to access files in folders on Drobo 5N under Win7
Win 7, 64 bit, all the latest and greatest updates. I have a curious problem. For years I have had a NAS running just fine: Drobo 5N. Last night, in fact, I accessed data without a problem. This AM I tried to access files on my Drobo 5N on a machine running Win 7 this AM and while I am able...
Network & Sharing
BSOD with connected NAS Drobo 5N
Hello My computer runned fine before I connected the drobo 5N NAS. I had copied files to my NAS and was switching them from one map to another and deleting when the first BSOD came up. See attachement. I already downclocked my vga card with Msi afterburner, since one bsod gave me a dxkrnl...
BSOD Help and Support
Thums.db file after copy/paste to Drobo?
I copied/pasted pictures to my Drobo 5N. Now I have a "Thumbs" file in every picture folder that is on the Drobo. I don't have the Thumbs.db file in any picture folder on my desktop where I copied the pictures from.
Music, Pictures & Video
How to create 'poor man's' RAID solution (like DROBO)?
Hello, There is a company called Drobo (, which has an enclosure for internal hard drives, so that they can be inserted and removed (hot swapped), while maintaining a dual redundant backup at all times across the RAID array. I would like to create a RAID array utilizing some...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:30.
Twitter Facebook Google+