Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Com1 in Ports vs. Com1 in Modems

22 May 2016   #11

windows 7 32 bit

I just uninstalled the modem (without physically removing it) and reinstalled it using device manager. I was trying to install it as com2, but Wizard only allowed Com1 or "all ports". Since I chose "all ports" last time, and it assigned the modem to com1, I chose com1 this time, just for kicks (to the head). I did get Com1, as expected. And, also as expected, I am getting the same error when querying the modem, some generic stuff about be sure modem is turned on, and irq interrupt is set properly. Anyone know how I can change the modem to Com2? Thankssssss. (Wizard will show me com1 but won't offer any other ports to change it to).

My System SpecsSystem Spec
23 May 2016   #12

Windows 10 64 bit

Have you disabled the com port in the BIOS? If not that is one thing that must be done.
My System SpecsSystem Spec
24 May 2016   #13

windows 7 32 bit

I have not disabled anything in BIOS. Don't know how to get into BIOS. Are you referring to the physical com port on the motherboard? I assume I would use this motherboard com port if I were to, in the future, want to use the ethernet connection. So I would be able to re enable it, right? Also, what's the difference between disabling com1 in Ports in Device Manager and disabling Com1 in bios? Thanks.
My System SpecsSystem Spec

24 May 2016   #14

Windows 7 Professional x64, Arch Linux

Com ports are serial ports, not ethernet ports. If there's one on the IO panel, it'll be shaped like a VGA port but with 9 pins instead of 15 holes. If not that, then there will be an internal header.

It's not clear to me whether the modem actually needs to use COM1 or usurp its resources. What resources (DevMgr -> r-click device -> Properties -> Resources tab) are in use by COM1 and the modem?
My System SpecsSystem Spec
25 May 2016   #15

windows 7 32 bit

Alphaniner, Thanks.

There isn't any vga port on the back of the computer with any pins. There is one with 15 holes avail. The other 15 hole vga port is in use for monitor. I'm using a phone line plugged into the internal modem, in a PCI expansion slot.

Device Manager for Ports tells me in Resources tab: "Communications Port (COM1)" next to an icon of a large connector (not a phone line). On same Resources tab it shows the I/O range of 03F8- 03FF and IRQ of "(04)". Conflict device list box has "no conflicts". "Use automatic settings" is checked. In General tab, also still in Ports, it says the location of Com1 is "PCI standard ISA bridge". Device Status is "working properly".

When I go to Modems in Device Manager I can't get the word "Resources" to appear anywhere. It does say the port is COM1, and location is "Unknown", and device status is "working properly".
My System SpecsSystem Spec
25 May 2016   #16

Windows 7 Professional x64, Arch Linux

I have a slightly better understanding of what's going on now. External modems need to connect to an actual serial (COM) port on the motherboard. Internal modems "provide a serial port" for all intents and purposes.

I came across information suggesting that generic drivers may not be enough to make internal modems work... but I also found this which may help in your troubleshooting.
My System SpecsSystem Spec

 Com1 in Ports vs. Com1 in Modems

Thread Tools

Similar help and support threads
Thread Forum
COM1 unavailable (HP true RS-232 )
I am disappointed . I bought the HP ProBook laptops thats still to date are delivered with windows 7 professional & a real physical COM port. I need it for serial-interface communication instead of fooling around with usb-adapters. But to my surprise,the com port seems to fail on me! And...
Hardware & Devices
How can I get rid of the yellow exclamation mark against Com1
I've tried cleaning the registry, uninstalling and reinstalling the port then rebooting but it's still there. Looking around the net there appears to be software that claims to be able to fix it but none of it is from MS. So I'm scared to use it. Also tried the MS Mrfixit but it couldnt. Does...
Using COM1 over local network
Hi ! I have a POS application.I'm using one thermal printer connected to COM1,I create a bat file wit this command : copy mydata.txt COM1: I run this bat and printer is working fine. I've installed my application on a second computer in the network and I need to print from there to the...
Network & Sharing
COM1 port once available for Visor Prism is now not ...
Hi! My Handspring Prism was working fine with my Win 7 until recently. Now, every time I try to sync it, I get a "The selected port, COM1, is not available at this time. Hotsync manager will open the port when it becomes available." My Device Manager won't tell me what is using COM1 and says...
Hardware & Devices
Hi is there any app to use a usb device on a COM1 port? i know i can make a cable but i need a software? if theres any out there, im searching and nothing. Thanks
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:24.
Twitter Facebook Google+