Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: When i insert printer usb, i get warning One of the USB malfunctioned.

10 Jun 2016   #1

windows 7 ultimate 32 bit
When i insert printer usb, i get warning One of the USB malfunctioned.

The printer was printing well. It is old model hp inkjet d1360 model old one.
I removed the usb and when inserted again, i get the malfunction of usb alert. I double click the unknow device to see that it has got error 43.
I tried msoft fixit on hardware detection and it gives me the same problem as the device is having problems. I know that it is printer , by physically verifying when i get this alert.
Now, if i update the driver for printer, it says that it is update.I do not see any yellow exclamation in the Devices and Printer. But on device manager, i have one unknown device usb/unknown in its properties , in details tab.
No hardware id is there, but instance path id is shown as USB\VID_0000&PID_0000\5&C0910C2&0&2
I do not know how to get the drivers for this id.
i tried full install of hp printer driver, but could not install it , as it shows fatal error during installation and no further progress could be made.
I replaced the printer usb cable with a new one , having 9feet, and tried to print. The same error usb malfunctioned error.
I totally uninstalled the hp software, as it is huge and downloaded all sorts of unwanted programs. the size of download is 203 mb for my printer.
Can i take it that the connection between the usb and the printer usb socket in the printer is defective or not functioning. I could power up the printer and could see the moving of carriage and also the flash of light in on switch. Please ,

My System SpecsSystem Spec
11 Jun 2016   #2

windows 7 ultimate 32 bit

Hi, No reply so far from experts.
I also done self pint test, by moving and closing 4 times the lid of the printer, when pressing the power switch on.
The printer prints the test page successfully.
Which is causing the problem?
Is it possible that the connection point between the usb cable and the socket, is having problem. How to correct it Please
My System SpecsSystem Spec

 When i insert printer usb, i get warning One of the USB malfunctioned.

Thread Tools

Similar help and support threads
Thread Forum
install program driver warning ,can i reset the warning?
Hi i guess general discussion is the right place because it's not closely related to drivers well i have installed Softperfect Ram Disk last version i used revo uninstaller pro , to track this program well during the installation i got a warning about the installation of the Softperfect...
malfunctioned offline help, no bcrm string
Hi guys! I have been having this help malfunction for quite a while, but the general solution does not help. i.e. deleting the BCRM_Bluetooth_help String from the registry, well because there IS NO string there!! Hence, I need help. Sfc scans freeze at 9% on my PC, while a repair install is too...
General Discussion
Wireless Adapter malfunctioned after PC cleaning.
I am using ASUS N10J with windows 7 Ultimate. Today i disassembled it for cleaning as dust in fan was causing excessive heat. :rolleyes: . After assembling it worked fine but now wifi range is limited to my room only and moving to any other room causes disconnect. In other rooms PC sometimes...
Hardware & Devices
Silverlight 5 malfunctioned?
Why is the CPU usage so high even hardware acceleration is enabled in Silverlight 5 (64-bit)? (VGA: ATi Radeon HD5750)
USB has malfunctioned!!!
I get this error when I try to connect my nokia c3 using an USB cable: "USB device Not Recognized One of the Usb devices attached to this computer has malfunctioned and windows doesn't recognize it" it works fine for other devices....only for this one gives me this error. I tried to...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:14.
Twitter Facebook Google+