Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem installing new PSU

19 Jul 2016   #1
Nosmas

Microsoft Windows 10 Pro 64-bit Multiprocessor
 
 
Problem installing new PSU

My PC suddenly started to power off intermittently. After much googling I decided the problem was probably with my 10 year old Trust PSU so I bought a new Corsair VS550. Having installed the new unit, to my dismay when I switched on absolutely nothing happened - the system was dead as a dodo. All suggestions for solution gratelfully received. Have been unable to find UK (or any) phone number for Corsair. Anyone know one?

Windows 7 home premium SP1, Foxonn motherboard M61PMV, Corsair VS550 PSU


My System SpecsSystem Spec
.
19 Jul 2016   #2
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

The first thing to check is whether all leads are plugged in & fully seated. Also make sure all leads are plugged into the correct sockets. It often needs quite a hard push to get some of the plugs to seat properly.

The last Corsair PSU that I bought had instructions on the box showing what all leads are for & where they should go.

My Corsair PSU has a power switch on it, so be sure that is switched on.
My System SpecsSystem Spec
19 Jul 2016   #3
HAVOC

Windows 7 Professional 64bit
 
 

Are you sure that the outlet isn't at fault?
My System SpecsSystem Spec
.

Reply

 Problem installing new PSU




Thread Tools




Similar help and support threads
Thread Forum
Problem installing Win 7 Pro 64 on SSD
I have a problem with installing Windows 7 pro on an SSD. I had a 60 gig that I forgot the name of and when I went to reinstall 7 I came up with a problem. Bought new 250 gig Corsair but did not get rid of the problem. My motherboard is duel bios and I have tried using both systems. Windows...
Installation & Setup
Problem Installing, missing file or HD problem?
Hi I hope someone can help me on here - I've tried for about 2 hours to get a copy of windows 7 working on my old pc and really can't see what the problem is when it comes to doing a clean installation. It's not "old' only a year old or so with very good specs but I use another machine now so...
Installation & Setup
Problem Installing Cs4
Hey guys ok im not so good with this just installed it :) I Downloaded Cs4 - Photoshop for Windows (Trial) of the windows website i have tried to install serveral times running as admin doing in vista/xp and everytime i get error 2 language pack error and after installed it says Done , With...
Software
Did you have any problem with installing Win 7?
Did you have any problem with installing Win 7?
Installation & Setup
Problem Installing
Hey Guys, really hope you can help me out here. Basically, i have just downloaded the 32bit version of 7, i have burnt the .iso to a disc usin ImgBurn. I restarted the computer and set boot device to Cd/DVD.However, the disc does not boot at all, i thought it would boot and ask me which...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:13.
Twitter Facebook Google+