Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: RAID array won't boot after downloading Windows updates

01 Aug 2016   #1

Windows 7 Professional x64
RAID array won't boot after downloading Windows updates

This is so aggravating. I always put off rebooting because my computer is busy with downloading or I'm playing a game or have a conversation or whatever. So I get home from work and then I try to reboot. I click on the shut down button and Windows goes away and then I see the normal update progress percentage. I walk away, thinking it's fine. But, now my computer won't boot.

Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key
The hardware is fine, I know it is. I have four hard disks in a RAID 10 configuration with an Intel controller built into my motherboard. My BIOS can recognize the disks and I can get into the RAID controller menu. What's strange is that, when trying to use a Windows Recovery Drive, none of the options can do anything (and my keyboard doesn't work on it for whatever reason), but if I click on 'System Image Recovery' and then 'Install a driver', the file explorer UI pops up and I can see all of my files there and I can even open txt files. I can even look at a lasagna recipe I saved 10 years ago in Notepad.

Through this, I tried to install the driver for my RAID controller, but it probably didn't do anything unless the array didn't work in this interface and required the driver. I wish the System Restore option worked, but it says, "To use System Restore, you must specify which Windows installation to restore. Restart this computer, select an operating system, and then select System Restore." Stupid thing doesn't even have its own restore feature and assumes I can get into safe mode at all.

So, I'm thinking this is a classic case of an update SNAFU, but I have no idea how to get around it. I tried using my Windows7 install DVD to fix it, but that eventually runs into a BSOD during the "Setup is starting Windows" period, which is very troubling.
Technical information:
*** STOP: 0X0000007B (0XF78D2524, 0XC0000034, 0X00000000, 0X00000000)
So, does anyone know what I can do to get Windows bootable again? I'm not going to be able to install a fresh copy because of the BSOD, so that's out.

My System SpecsSystem Spec
01 Aug 2016   #2
Microsoft MVP

Windows 10 Pro x64 ; Xubuntu x64

Use the File Explorer UI and browse to C:\Windows\Minidump. If there are any .dmp files present, copy then to an external USB drive.

Use 7zip to zip them, then upload them here as an attachment.
My System SpecsSystem Spec
01 Aug 2016   #3

Windows 7 Professional x64

I'm surprised this was even possible, but good ol copy and paste.

Attached Files
File Type: zip (1.15 MB, 2 views)
My System SpecsSystem Spec

02 Aug 2016   #4

Microsoft Community Contributor Award Recipient

Originally Win 7 Hm Prem x64 Ver 6.1.7600 Build 7601-SP1 | Upgraded to Windows 10 December 14, 2019

The majority of your 15dumps were 0x9f and you had a couple for 0xd1 both indicate device drivers, the 0x9f is DRIVER_POWER_STATE_FAILURE (9f) A driver is causing an inconsistent power state, and the d1 pointed to Mijxfilt.sys which is the MotioninJoy simulate Xbox 360 controller (virtual Xinput device) driver, but just going by your last error code you could try this:
You receive error: Stop error code 0x0000007B (INACCESSIBLE_BOOT_DEVICE) after you install Windows Updates

As noted in the second part of the 07B link there could be a boot sector virus involved I hope not, I did scan your .dmps with mbam and virustotal as I always do when working with unfamiliar files and nothing was detected.

Something else I thought of; Did you notice any flash/external drives in any USB slots because the 0x9f pointed to a PnP problem, and if you do have a controller plugged in pull that also before you try the 07B link.
My System SpecsSystem Spec
02 Aug 2016   #5

Windows 7 Professional x64

I'll try the offline Windows Defender thing later on, but that looks like the only thing I can do in the link, since everything seems to think that Windows is not installed at all and everything else there suggests options that would appear if Windows was detected.

That damned MotionInJoy driver has given me a couple BSODs, but that's apparently normal, as they're incredibly unstable if you keep installing and uninstalling the drivers. Not so much an issue for me anymore. It was only plugged in to recharge the battery, as I normally use it with bluetooth.

Other stuff that is plugged in 24/7:
Brother laser printer/scanner (USB 1.0)
Remote control receiver
External hard drive

There's also a portable media hub that attaches to USB headers for SD cards and stuff. It's detected as a device whether or not there's a card inserted. I don't think this causes any issues, as it was there when I installed Windows 7 in the first place.

I'll try to use my Windows 7 install disc again with everything unplugged, in case there isn't a virus, which is likely.
My System SpecsSystem Spec
06 Aug 2016   #6

Windows 7 Professional x64

Finally had time to attack the problem.

The link in the article to the Windows Defender Offline downloads doesn't actually have any downloads on it and I had to look around for 10 minutes before I could find it. Unfortunately, I couldn't do any scans because of this error:
This app can't be started.

Error: Unable to detect a Windows system drive. This could be
due to missing drivers, an encrypted drive, or a corrupted
Windows installation.

Error Code: 0x8004cc01
Even if I needed to somehow install the driver for my RAID controller, it didn't work for the Windows Recovery Drive, which also couldn't do anything because it couldn't see the Windows installation.

Then I tried unplugging my external USB drive, my printer, my remote receiver and even the weird DVI monitor thing I never use that plugs into my graphics card. I got the 7B BSOD again.

Previous looks at that BSOD error pointed me to changing the SATA setting in the BIOS from RAID/AHCI to IDE. My BIOS couldn't boot from my optical drive from this setting for whatever reason, but changing it to IDE and then force booting through the BIOS, I was able to start the Windows install program without a BSOD. And then it occurred to me that I've been very, very, very stupid.

I was using my Windows XP disc. Of course a 2005 operating system will have a hardware error with 2012 hardware. I did some cleaning up and found my Windows7 disc, but it somehow works even worse than Windows Recovery Drive. It can't even see my RAID drive. More telling is that it can't detect a 5th hard drive that isn't part of the array that I just use for storage. So any hard drives connected to my SATA ports aren't being detected. Installing the drivers again doesn't do anything.

I'm unsure of what to try next. I'm thinking I can try to copy my windows directories to a USB drive and see if I can boot from that and figure out what's causing the weird SATA myopia. Morale is low.
My System SpecsSystem Spec
06 Aug 2016   #7

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Tiger,
as an add-on, W7 hates being a secondary OS, so if your boot order puts it out anywhere else than 1st, especially if your dual booting. It does do perculiar things.

Try ESET on-line, if as Anak thinks it might be a virus, dissable MSE.

My System SpecsSystem Spec
06 Aug 2016   #8

Windows 7 Professional x64

I ... I don't know what happened.

So, I thought I'd swap out the "storage" hard drive for a clean one to move my Windows files onto. On a lark, I tried to run the startup restoration process again. Instead of spitting out the same failed error, it rebooted. "What just happened?" I said. Thinking it worked, I pulled the Windows Restore Drive out before the boot process hit it. Same 'insert' prompt as usual. So, I put the Windows Restore Drive back in and rebooted again. But instead of booting back into that ... my computer booted into Windows 7. I said WTF three times in a row out loud.

The drive I put in was blank. I had formatted it sometime in the past. I put the drive I took out back in and there was nothing wrong with it. All the files were present and accessible. I got a message showing that my updates were installed successfully.

Unfortunately, rebooting the computer again had proven the problem wasn't fixed. I still get the 'insert' prompt when I try to boot normally, but now, I can't even get into the Windows Restore Drive menu. It appears to boot Win7 normally, but it won't go all the way, crashing in a BSOD that autoreboots too quickly for me to see what the error code is. The good news is that I can get into safe mode now, but I don't know what that accomplishes, since restore points seem to be turned off and disabled in safe mode and I think I need the full environment to use that or to virus scan or anything. I didn't see any new files in the minidump folder.

The Windows Restore Drive seems to be locked into the repair startup action and I don't think I can get the menu back without erasing the key and reinstalling. It's something I'll do if I think I need to get back into that menu, but I think I'm done for the day and would like some feedback before I try anything else. The Windows7 disc still doesn't recognize the RAID, so repairing through that is not yet an option for me.

torchwood, my BIOS has boot option #1 set to Windows Boot Manager. There are two options that say Windows Boot Manager, but they seem to be the same, as I've tried both. There is an option under boot override that lists the RAID, but that doesn't do anything different. I would try ESET, but I'm pretty sure I need a full Windows environment to be able to do that. MSE is pretty useless as well.
My System SpecsSystem Spec
09 Aug 2016   #9

Windows 7 Professional x64

Nobody has an idea, eh?

I didn't do anything since Saturday, but something is different. I still get the insert prompt if I don't have the Windows Restore Drive or the Windows7 install disc, but the Windows Restore Drive booted to this error message that stays up for about two minutes, then reboots in an infinite loop:

Your PC/Device needs to be repaired

The Boot Configuration Data for your PC is missing or contains errors.

Error Code 0xc000000f

You'll need to use recovery tools. If you don't have any installation media (like a disc or USB device) contact your PC administrator or
PC/Device manufacturer
I erased the USB key and put a fresh Windows Recovery Drive on it. I failed to mention before that if I select the "Reset this PC" option, this message appears:
The drive where Windows is installed is locked. Unlock the drive and try again.
No idea what this means and I can still access my files with no problems.

Next, I downloaded the Malwarebytes free scanner and ran it in safe mode. It didn't find anything but a thing called OpenCandy, which is just a thing for one of my programs that runs ad banners. Deleted it anyway. No other threats detected. I'm tempted to try other scanners, but I'm fairly certain I won't find anything else.

Just to be thorough, I opened the Western Digital Data LifeGuard Diagnostics and ran both the quick test and the extended test, which took over two hours. No problems.

I also poked around my startup file and found the option to enable boot logging. I restarted and then this showed up:
Windows failed to start. A recent hardware or software change might be the
cause. To fix the problem:

1. Insert your Windows installation disc and restart your computer.
2. Choose your language settings, and then click "Next."
3. Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer
manufacturer for assistance.

File: \Windows\system32\winload.exe

Status: 0xc0000225

Info: The application or operating system couldn't be loaded because a
required file is missing or contains errors.
Of course, I still need the Windows Recovery Drive for my RAID to be visible to Windows, so I don't know how I would boot from the disc and the USB key at the same time. I would use the command prompt to launch the disc, but my keyboard doesn't work in that environment.

It's late, so I'll see what else I can do after work tomorrow. As always, I would appreciate any suggestions.
My System SpecsSystem Spec
09 Aug 2016   #10

Microsoft Community Contributor Award Recipient

Originally Win 7 Hm Prem x64 Ver 6.1.7600 Build 7601-SP1 | Upgraded to Windows 10 December 14, 2019

Life got in the way Tiger, I haven't forgot about you, but I'm gonna have to read up on your last two posts to get caught up, maybe another couple of days, meanwhile I'm gonna alert our group to see if anyone can pitch in so you might see some different avatars in a bit.
My System SpecsSystem Spec

 RAID array won't boot after downloading Windows updates

Thread Tools

Similar help and support threads
Thread Forum
Trying to install Windows 7 on 2x Samsung 850 Evo's in Raid or Array.
I've been dealing with this for hours. I've looked all across the internet and I have yet to fix my issue. SPECS/ISSUES MSI GT80 Titan Laptop Windows 7 I just bought/installed two Samsung SSD 850 Evo M.2s I already have a 1TB HHD with all my stuff and OS on it (windows 7)-Not Samsung ...
Installation & Setup
Borked my PC when trying to split up a RAID 1 array (not windows disk)
I have two 1TB disk drives as storage space. Originally, I set these up as a RAID 1 array, but am now using this PC for DVR purposes and not so much for actual work, so the disk space is more valuable than the redundancy. So I wanted to undo the RAID, but the RAID is not my boot disk, so I figure...
BSOD Help and Support
RAID 1 Gigabyte SATA Cannot find the array during Windows 7 install
Hello, I have just bought two brand new WD 500 GB RE4 HDD's and connected them coorectly for RAID 1. I have changed the BIOS and Pressed Ctrl+F to create the RAID and this has been successful. When installing Windows you obviously get to the aprt where you need to load the floppy drivers to...
Hardware & Devices
RAID - deleted RAID array, Windows 7 ok but I have questions
Hi all, My RAID 1 (I think? I have two equal drives that are mirrored) array was causing me a lot of pain. It kept freezing up my system and having me to had to rebuild the RAID too often. After a number of tests and browsing info online, I've decided that the RAID was the culprit of the freezing...
Hardware & Devices
Disk Boot Failure with RAID 0 Array
Hi I have two 500Gb SATA drives in a RAID 0 config set as my system drive 'C', and a 1TB SATA as a storage drive 'E' Never had this problem until last night when I removed the storage drive. Tried the usual fixes with no luck, put the drive back in and the system boots normally. The...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:31.
Twitter Facebook