Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Sata HDD works in external dock but not internally?

30 Aug 2016   #11

Windows 7 HP 64

If you don't have a UEFI BIOS and / or if your OS isn't UEFI compatible, a UEFI / GPT disk will not be recognized. As BIOS makes the interface between the disk and the OS it's important to set Storage Boot and PCI device to UEFI only.
For example, Win 7 32 bits isn't compatible with UEFI / GPT, only Win 7 64 bits.
To have disks bigger than 2T, and work around this limitation, (not sure) manufacturers install a software that translate the GPT disk.
To install a GPT disk directly to the MB, you have to set UEFI on BIOS and have a UEFI OS compatible (Win 7 64bits). As Jumanji posted, the reason why you can't erase partitions can be because the owner is on a network, but I think that the problem is more related to UEFI BIOS settings and installed OS.

My System SpecsSystem Spec
30 Aug 2016   #12

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

A Legacy Bios / MBR PC can use GPT Data disks > 2TB.
I can post a screen print if you want.
My System SpecsSystem Spec
30 Aug 2016   #13

Windows 7 HP 64

I'm not saying it's impossible. On a legacy system, there are some workaround to be implemented to work properly.
On a UEFI is plug and play.
Support for Disk Drives Beyond 2.2 TeraBytes (TB) and 4K Advanced Format Sectors
My System SpecsSystem Spec

30 Aug 2016   #14

Windows 7 Ultimate x64

Hey Guys,

Thanks for your feedback, as Jumanji mentioned I was sleeping on the other side of the world haha.
I have attached screen shots of the 4TB drive whilst in the external dock and it shows only the first 2TB of the drive which you were correct on saying this is a limitation for this dock. However when I connect it internally I can see the whole 4TB in disk manager and MiniTool (see the third attachment).

I checked the mentioned settings in the bios and they were:
- CSM (Compatible System Mode) = enable
- Storage Boot and PCI device = Legacy (not UEFI)
- Fast boot to disable.

Also I tried to re-format the 4TB drive so it is now MBR not GPT (well only a 2TB portion of it) but I still have no change. I was thinking this may have been an easier solution for the time being rather than re-installing everything, shouldn't this have had the same effect?

As for the story of this PC and it's HDD, It's a brand new PC purchased and put together by another guy I work with, he got this far and asked me to help with this issue as I know more about this sort of thing than him but am far from an expert (obviously!). As for the HDDs the big 4TB is actually NEW and the 2TB was picked from another PC (not in a RAID), both drives work perfect in two other computers we have put them in this issue only exists on this machine. The dock we just happened to have lying around and we were using to try and problem solve. The OS is Windows 7 Ultimate x64

Attached Thumbnails
Sata HDD works in external dock but not internally?-4tbdm.jpg   Sata HDD works in external dock but not internally?-4tbmini.jpg   Sata HDD works in external dock but not internally?-alldrives.jpg  
My System SpecsSystem Spec
31 Aug 2016   #15

Windows 7 Home Premium 32 bit

It turns out you are not the owner/ user with administrator privileges. Your friend Mr.X is. You are perhaps operating with a non-administrator guest account.

If your friend Mr.X trusts you, can you not log in as the original user and troubleshoot for him? That will greatly simplify matters. And during this troubleshooting process disconnect from the internet so that there is no network influence and also disconnect all other external drives including the media drives physically plugging those out ( safely remove) and also disabling your fibre channel adapter/program.

You have needlessly formatted the 4 GB drive as an MBR drive in the 4GB incompatible dock. Once you log in as the administrative user Mr.X, check whether you can read and write to 2TB as well as the 4TB (now 2TB MBR drive) drives and post your findings.In effect you will be starting afresh doing away with any unnecessary attendums that can be confusing.

As you said that you are not an expert, me too not an expert in dealing with these problems, but I think the above recommended process will put the whole thing in a proper perspective for other experts to chip in and guide you with any problems you face and report.

( Don't worry about the 4TB MBR drive. It can be reformatted as a GPT drive bringing the whole space accessible)

I am also not sure whether it is absolutely necessary that you should only use UEFI and reinstall Windows 7 64bit on a GPT SSD. Other experts to look in and advise you.
My System SpecsSystem Spec
31 Aug 2016   #16

Windows 7 Ultimate x64

This machine has a single admin account, the same account I am logged into and using.
I have tried booting into windows with no fibre channel drives connected and also disabling it's managment software (with the internet still connected) but no change. I was told by Mr.X that this problem existed before the fibre channels were connected and configured, but I didn't see this for my own eyes I have to trust him on that.

I don't mind formatting these drives over and over again as there is nothing on them, Ive done it several times whilst in the external dock. Also on the drive (whilst in the dock) Ive also gone into properties/Security and successfully claimed ownership of the drives under the admin user I'm logged into but alas as soon as I re-boot and re-connect back the drive back into the motherboard all is lost again? and I have no access and no control... ?
My System SpecsSystem Spec
31 Aug 2016   #17

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

Have you tried initializing the drive as GPT while it is connected to the motherboard (not in the dock) ?
You might also want to do a Diskpart Clean while it is connected to the motherboard (before initializing).
My System SpecsSystem Spec
31 Aug 2016   #18

Windows 7 HP 64

You are having all this problems because Win 7 wasn't installed as it should. Your MB deserve a clean install with UEFI, and this problem will be gone.
My System SpecsSystem Spec
31 Aug 2016   #19

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

For me a 3TB GPT drive works with Windows installed as Legacy Bios / MBR.
I just plug it in and it works, no special drivers, workarounds, etc.

Here is a quote from the MS KB article linked in post #13

Overall requirements for a non-bootable data volume

For a system to be able to address the maximum capacity of a device that has a storage capacity of more than 2 TB, the following prerequisites apply:
  • The disk must be initialized by using GPT.
  • The Windows version must be one of the following (32-bit or 64-bit, unless otherwise noted, but including all SKU editions):
    • Windows Server 2008 R2 (only 64 bit version available)
    • Windows Server 2008
    • Windows 7
    • Windows Vista
  • The latest storage drivers from your storage controller manufacturer must be installed. For example, if your system uses an Intel storage controller that is set to “RAID” mode, make sure that you have the latest applicable drivers from the Intel support site.
  • Overall, you should contact your system vendor to determine whether the system supports device sizes of more than 2 TB.
My System SpecsSystem Spec
31 Aug 2016   #20

Windows 7 Home Premium 32 bit

Quote   Quote: Originally Posted by Megahertz07 View Post
You are having all this problems because Win 7 wasn't installed as it should.......
I disagree with this if you mean that it has to be installed only as UEFI+GPT. ( Unless it has some authoritative base/reference. I am unable to find one)

Just had a look at this one New motherboard has UEFI bios but my hdd is in MBR scheme...Want to format C drive and fresh install windows 7..HELP - USB - Windows 7

"uefi/ legacy is an option, not a requirement. your pc,'s bios has an option to use efi or not, find that option and turn efi off, then make rufus make a regular mbr win7 disk, and reinstall windows. if you dont know what uefi is then dont use it. its not for you "

"ah you have an asus mobo. boot into you bios, click advanced mode if not already in advanced mode, goto the boot tab, find compatibility ssupport module(CSM) and basically just make sure nothing is set to uefi. i believe its called OProm or something. once youve set those you can use your computer like the pre-efi days. gpt is unnessicary"

DavidE has also stated that he has a legacy + MBR install and he has no problem.
My System SpecsSystem Spec

 Sata HDD works in external dock but not internally?

Thread Tools

Similar help and support threads
Thread Forum
Hard Drive works internally, but not externally.
Hello everyone, I've got a Seagate Momentus hard drive taken from a laptop that I intend to use as an external storage device. When plugged directly into my laptop's hard drive slot, it works fine. When I try to use it externally with an enclosure, it is not recognised (on the same...
Hardware & Devices
Hard Drive works externally but not internally
i found this thread which is opposite to my problem and its been a year since the last post. So i make a new thread. As you can see in the title. My Hd drives works externally but not...
Hardware & Devices
Does DOCK's (such as Rocket Dock,Object Dock etc) makes computer slow?
My Windows 7 Operating system is taking a lot of time during Start up.I was looking for an alternative to the regular icons ,scattered all over my desktop.So,i decided to try Docks such as Rocket Dock,Object Dock,Nexus,Rk Launcher or similar dock....It certainly looks beautiful but now i am...
General Discussion
Dock that works for Win 7 64 bit?
Hi I'm running Object Dock, but there's a problem with window focus not working properly in Windows when the program is running (goes away when I close Object Dock). Does anyone have a suggestion for some free dock software that will run properly under Win 7 64 bit? Thanks a heap. Geoff
Can I fit my external drive internally?
Can any one advise me on this? I have a 1GB Samsung Story External USB 2.0 hard drive. The drive performs well, but isn’t really as fast as my internal hard drives. What I was wondering was, Now that I have a spare hard drive bay inside my case, could I remove the Samsung from it’s external...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:53.
Twitter Facebook