Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Sata HDD works in external dock but not internally?

29 Aug 2016   #1

Windows 7 Ultimate x64
Sata HDD works in external dock but not internally?

I have a recently newly built PC and I'm having some trouble with some Sata HDDs and getting them to work, I'll try provide as many details of the problem that I'm experiencing and also things I've already tried to hopefully save some time.
The OS SSD is working fine but I also have two Sata HDDs plugged in that windows sees but cannot use in any way, all I get is "location is not available" and "access denied" errors? If i remove the drives and plug them into an external USB dock they function perfectly but as soon as I put them back into the PC I cannot access them again?
Whilst connected internally I cannot format/partition in disk management nor can I change ownership in security settings. The only thing I have been able to achieve is to use the "CLEAN" function in diskpart in dos. Whilst in the external dock I can do everything including partition/format/set ownership and access as normal.
I've tried different ports on the mobo (SSATA & SATA) and Ive tried changing the bios setting to IDE & AHCI but no change. I downloaded MiniTool Partition Wizard but also no joy with it.
The two drives a WD 2TB & 4TB with no jumpers on them.
Has anyone got any ideas for me to try? I'm just about out of ideas


ps: in the attached pic it looks like I'm using a user without admin rights when I go to change ownership on these drives but I am! That's part of the problem, I only get this error on these drives not any others.

Attached Thumbnails
Sata HDD works in external dock but not internally?-hdds.jpg   Sata HDD works in external dock but not internally?-accessdenied.jpg  
My System SpecsSystem Spec
29 Aug 2016   #2

Windows 7 HP 64

What kind of external USB dock you have?
Did you bought them as a external HDD like WD Passport?
Don't ask me why, but WD Passport HDD uses electronic encryption so the only work on the external USB dock.
My System SpecsSystem Spec
29 Aug 2016   #3

Windows 7 Ultimate x64

The dock is a Shintaro SH23SDOCKE
Both HDDs are internal drives, WD Black (WD2002FAEX) 2TB & WD Red (4001FFSX) 4TB
My System SpecsSystem Spec

29 Aug 2016   #4

Windows 7 Home Premium 32 bit


Not that I am going give any solution - I am dumb on this sort of problems -, but some additional information may perhaps be in order for others to work on it.

1. Motherboard details Asus Z10PE-D16 ?

2. Windows Disk Management Screenshot with both 2TB and 4TB drives in the dock

3. MiniTool Partition Wizard Screenshot with the drives in the dock.

4. Whether your current system uses Intel Rapid Storage Technology drivers

5. Whether the drives are new or picked up from another PC

6. Whether you want to keep any data on it or willing to do a clean wipe and format those?

7. What are those huge TB media 1,2 & 3 drives and how are those connected to the system?

Adhere to the guidelines here: Disk Management - Post a Screen Capture Image

Upload to Seven Forums : Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
30 Aug 2016   #5

Windows 7 Ultimate x64

Hi Jumanji,

My motherboard is a Asus Z10PE-D16
I have attached screen shots of the 2TB drive in the dock (I can only fit one drive in it) from Disk management and MiniTool.
I don't believe my system uses Intel Rapid Storage Technology drivers, I've looked under Storage controlers in device manager and I have ATTO Celerity FC-82EN Fibre Channel Adapter & also Intel C600+/C220+ series SATA AHCI Controller. Is that where I would find that information?
The drives are not new they have been picked from another PC and I have formatted them several times trying to get them going on this system so they are blank and can be wiped again.
Those huge media drives are connected to the above Fibre Channel Adapter and connect at startup through a program called metaSAN (this is a work PC). Ive tried disconnecting this connection and disabling this program from running at startup but there is still no change in gaining access to these WD HDDs, even if I boot into safe mode.

Attached Thumbnails
Sata HDD works in external dock but not internally?-comman.jpg   Sata HDD works in external dock but not internally?-minipart.jpg  
My System SpecsSystem Spec
30 Aug 2016   #6

Windows 7 Home Premium 32 bit

Thanks for the updates.. You can now put the 4TB drive and post the screenshots.

Check for any latest chipset/AHCI Controller drivers for your motherboard on the ASUS website and be ready to update if recommended by other knowledgeable people. I am blank on Intel which is always confusing.

Please wait for other experts to look into your problem.I shall take a backseat now .
My System SpecsSystem Spec
30 Aug 2016   #7

Windows 7 HP 64

Your C drive is MBR and your D drive is GPT.
What win brand you are running? Is it a 64 bits OS?
Tell in details the story of the Shintaro SH23SDOCKE and the WD drives. Did you bought them separately? Did you install any kind of software?
On Shintaro data sheet it says it is compatible with HDD up to 2TB. How you use higher capacities?
External HDD Enclosure
My System SpecsSystem Spec
30 Aug 2016   #8

Windows 7 Home Premium 32 bit

Good work @Megahertz07. I wanted to check the details of the Op's Shintaro's dock but then it slipped out of my mind. If the OP puts the 4TB drive in the dock and provides the WDM screenshot as asked in my post #6, it would have been evident. Anyway he must be in deep sleep now and may not comeback for another 6 hours atleast.

I was deliberating on the issue on and off and I feel that his drives were network shared by the previous owner. He may have to remove the network sharing of the drives before he can take current ownership and access the drives. He may reactivate network sharing after taking ownership.At the moment these are only thoughts based on what I have read about it. My interpretation may or may not be correct. Error message: "Unable to set new owner on Local Disk ( D: ) Access denied."
My System SpecsSystem Spec
30 Aug 2016   #9

Windows 7 HP 64

You have a MB that I didn't even imagine it exist. It's like a kind of a super server with tweaks of a gamer MB.
But, as complex MB, there are many BIOS configurations.
What call my attention is that your C drive is Legacy / MBR. Why Win wasn't installed as UEFI / GPT?
On page 94/194 of the manual ( you have the CSM options.
- Boot Option filter is by default Legacy only. It should be UEFI only.
- Network / Storage / Video is by default Legacy. It should be UEFI.
This two settings explains why Win was installed as legacy / MBR.
I'm not sure, but I think UEFI / GPT disks are not compatible with Win installed as Legacy OS.
You can't only change the BIOS settings as it wont boot on UEFI as your C drive is legacy / MBR
I would start from scratch: Backup all your data, configure your BIOS properly.
You must set on BIOS:
- CSM (Compatible System Mode) = enable
- Storage Boot and PCI device to UEFI only
- Fast boot to disable.

Detach ALL other drives, leaving only the C drive.
Boot with the Win 7 64 installation disk on UEFI mode, go to install, custom, advanced, delete all partitions, create a new one (Win will create 3 partitions) and proceed.
My System SpecsSystem Spec
30 Aug 2016   #10

Windows 7 Home Premium 32 bit

How is this relevant to OP's problem? I am at a loss.

Do you mean that because OP had chosen to install his Windows 7 64 bit on Legacy mode with an MBR SSD drive he is unable to access his 2TB and 4TB GPT drives internally?


leaving aside the OP's problem, are you suggesting that it would be better if he uses UEFI and GPT SSD?

Will it resolve OP's problem?
My System SpecsSystem Spec

 Sata HDD works in external dock but not internally?

Thread Tools

Similar help and support threads
Thread Forum
Hard Drive works internally, but not externally.
Hello everyone, I've got a Seagate Momentus hard drive taken from a laptop that I intend to use as an external storage device. When plugged directly into my laptop's hard drive slot, it works fine. When I try to use it externally with an enclosure, it is not recognised (on the same...
Hardware & Devices
Hard Drive works externally but not internally
i found this thread which is opposite to my problem and its been a year since the last post. So i make a new thread. As you can see in the title. My Hd drives works externally but not...
Hardware & Devices
Does DOCK's (such as Rocket Dock,Object Dock etc) makes computer slow?
My Windows 7 Operating system is taking a lot of time during Start up.I was looking for an alternative to the regular icons ,scattered all over my desktop.So,i decided to try Docks such as Rocket Dock,Object Dock,Nexus,Rk Launcher or similar dock....It certainly looks beautiful but now i am...
General Discussion
Dock that works for Win 7 64 bit?
Hi I'm running Object Dock, but there's a problem with window focus not working properly in Windows when the program is running (goes away when I close Object Dock). Does anyone have a suggestion for some free dock software that will run properly under Win 7 64 bit? Thanks a heap. Geoff
Can I fit my external drive internally?
Can any one advise me on this? I have a 1GB Samsung Story External USB 2.0 hard drive. The drive performs well, but isnt really as fast as my internal hard drives. What I was wondering was, Now that I have a spare hard drive bay inside my case, could I remove the Samsung from its external...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:23.
Twitter Facebook