Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB write speed is suddenly extemely low!

20 Dec 2016   #1
Hunnicat

Windows 7 Home Premium 64-bit
 
 
USB write speed is suddenly extemely low!

Please help me!

A lot of stuff has happened in the last two days, which I don't understand.

The latest thing to happen, is that I can't write large files to USB-sticks. I usually transfer at about 1 GB per minute. Now, about the first couple of hundred MB (judging by the progress-bar) go at normal speed (ca. 15 MB/s), and then it stops. Windows starts saying the 3 GB file will transfer in "about 3 minutes", then suddenly says "about 1 hour", then a couple of minutes later "about 3 hours." I am sure if I waited longer, it would say "about one day".

Here is all the crazy stuff that has happened:

Wait, I was just about to read all the stuff I had written and saved in a text file on my desktop, but now it is totally empty! It was 28 KB, and it still is, but it is all 0-chars now!!!

What is going on with my computer?! This is intolerable! Now I am losing data! I don't even have write-caching enabled on the C: drive, and still this happened!

Let me see if I can remember it.

I first noticed something strange, when my external HDD which was drive e: was suddenly drive n:! This has never happened before.

I began to google it, and there seemed to be a lot of mentions of USB-drives. So I remembered that just a short time earlier, I had inserted an old 256 MB USB-stick plus my Android phone at the same time. Was that the problem?

Then I tried inserting the USB-stick again, and my external HDD was now drive O:, whereas the USB-stick was drive N:!

I went into Disk Management, and the external HDD was all the way down as "disk 9". I don't remember what it was before, but I THINK it was just below the internal drive as drive 1, or 2, or something.

Also, Windows seemed to boot up more slowly, and I thought could it be because the external HDD was all the way down as disk no. 9? Now windows seems to turn off the HDD and then spin it up again every time it boots up. I don't remember if it did this before, so I don't know if this is also a symptom of something being wrong.

Finally, I decided to name my external HDD drive Z:, to prevent it being changed into another letter, and breaking my shortcut-links.

But I think that's when I discovered that transferring large files to other USB-drives is impossible. It's funny, my external HDD seems to have no problems copying files to the internal C: drive, but when I try to copy a file from the external drive to a USB-stick, it acts as described above. Also, my external HDD makes an odd ticking-sound when reading, as if it is an old-style HDD, which made noises when reading and writing, whereas when copying to the internal, it is smooth and silent.

I just tried copying a large file from the internal HDD to the USB-stick, and the same thing happens. It goes quickly in the beginning, and then, about 20% into the file, it goes dead. Actually, it's completely dead. The USB-stick isn't even blinking anymore. And Windows is stills saying "about 2 minutes 45 seconds" here 6 minutes later. It's completely dead.

I have tried searching for explanations for the disk-number switch thing, but so many things are happening, that I don't know what to try to search for.


My System SpecsSystem Spec
.
20 Dec 2016   #2
Hunnicat

Windows 7 Home Premium 64-bit
 
 

Some more info:

I went to check whether the write-caching was on my internal HDD, and now it WAS checked! I am 99% sure it was unchecked when I looked at it some hours ago.

Also, a couple of times today and yesterday, when I booted up, windows couldn't find my external HDD.
Sometimes, when I clicked on the drive, it looked as if the drive was empty. I nearly had a heart-attack, thinking about all my files being gone! I then had to physically remove the power cord from the HDD, for Windows to recognize it again, and show the contents were still alright.

This also happened once last week, but I had forgotten about it.

This also happened once yesterday with one of the USB-sticks. I could click on the drive, but it opened showing nothing in the foilder.

So I am beginning to think that some of the issues I am describing is not a new problem, and may not be related. But the extremely low USB-transfer speed IS a new problem for me.



Okay, I just tried another USB-stick than my usual one, and it seemed to work, though the speed seemed unusually low, 6 MB/s. The readspeed is fine though, I think, at 30 MB/s.



Now I tried the usual USB-stick again now it wrote the entire file at 12 MB/s. No, as 10 MB is remaining to be written, the process froze up for 30 seconds. Well, now it seems to done- e all there.


I understand NOTHING.



Everything in Windows 7 has seemed stable and fine until now. And now all this stuff?
My System SpecsSystem Spec
20 Dec 2016   #3
Wandering one

Win7 sp1 Pro 64bit / XP sp2 Pro (games only)
 
 

Not that this will be of any use to correct the problem, just so you know that you are not alone, I had the same thing happen after November updates.
Art.
My System SpecsSystem Spec
.

20 Dec 2016   #4
Megahertz07

Windows 7 HP 64
 
 

Schedule a disk check: chkdsk c: /f
Run sfc /scannow

Open disk manager and delete all partitions on the USB flash disk. Create new and format as default (normally as Fat32).
Open Task manager and look for suspicious program or service.
My System SpecsSystem Spec
Reply

 USB write speed is suddenly extemely low!




Thread Tools




Similar help and support threads
Thread Forum
RAID's write speed on large files suddenly tanking randomly
tl;dr: When recording with fraps, dxtory or just generating a large file, my write speed fluctuates wildly, ranging from 140-70, but also dropping to as low as 2mbps, causing lag and maxing out disk activity %. I've been recording gaming sessions off and on for a couple months now, but a few...
Performance & Maintenance
Lower CD-R write speed ?
Hello I was curious to know. I heard there could be firmware preinstalled that forbids low write speeds. I'm trying to achieve 4x I burn with DiscJuggler. It reports 30x-40x speeds, despite setting 4x everywhere in it. I'm using Sony blanks.. or could they be the conflict ? My friend said...
Software
SSD write speed less than 20mbps
Recently, after re-installing windows, my SSDs write speeds has plummeted, the read speeds were fine however my write speeds just went through the floor, even my HDDs write speed is faster. My computer is a Dell XPS 15z. Any idea how to fix this?
Hardware & Devices
16 GB SanDisk Cruzer suddenly becomes write protected!
Got a 16 GB SanDisk Cruizer flash drive and it did well - until I swapped my hard drive for an SSD. Since the SSD conversion, the ReadyBoost file on it does not work - Windows won't use it because I have an SSD - that' fine. The real problem is the SanDisk became write protected - can't format,...
Hardware & Devices
Slow USB write speed
hi guys. i've recently got a Kingston DataTraveller 101 (4 gb) which says that its read and write speed is 10 mb/sec. I'm running windows 7 and when i tried copying a 3 gb file in the pen drive i was getting a speed of just 5 mb/s. is there any problem or is that normal. regards kranika
Hardware & Devices
What Write Speed do I use to burn W7?
I found this write up that I'm going by: How-to: Burn your Windows 7 .ISO to DVD disc | Hardware 2.0 | ZDNet.com But on theirs its listed as but mine doesn't have Auto..what burn speed should I be using to burn an ISO of Windows 7 to a blank DVD?
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App