Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network Adapter Missing after Virus

22 Jan 2017   #1
eric55

New Jersey
 
 
Network Adapter Missing after Virus

Firstly i have been using this site for years to fix my problems i only signed up now cause its the first time i cant find my problem here so i hope some can help
I had some viruses on my computer its all clean now there was some registry damage the virus did which i fixed with the awesome registry download fixes on this site. Now the only thing is the network card is missing in network adapters and in device manager. I plugged in a usb wireless adapter and that also i got nothing device manager didnt show anything not even acknowledging that i plugged something in. Is there a reg fix for this thanks much


My System SpecsSystem Spec
.
22 Jan 2017   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello and welcome Eric mate first up we need some more system specs as it is very hard to advise when we do not know what is in the machine so please follow this another option is to fill in the specs to your profile.
System Info - See Your System Specs

Now I am curious as to what New Jersey OS is??
My System SpecsSystem Spec
22 Jan 2017   #3
eric55

New Jersey
 
 

i didnt fill in my profile because i have 6 machines this one is
dell vostro 460 i5 8gb ram windows 7
My System SpecsSystem Spec
.

22 Jan 2017   #4
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok mate now I have also six machines and have included as many I can get in but anyhow it would be good to know the specs of the machine that has an issue.

Having said that I see the Vostro that you have linked. But as always the Dell site is as convoluted as ever so I cannot find any drivers that may need to be updated. Have you tried it at your end?
My System SpecsSystem Spec
22 Jan 2017   #5
eric55

New Jersey
 
 

Its not a driver issue because i installed another card and its still just blank not showing any card its like the virus messed up the network part of the registry or system files. i tried sfc/scannow didnt work but i never had luck doing that so no surprise.
My System SpecsSystem Spec
23 Jan 2017   #6
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok well if the registry has been corrupted by malware then I am not really cluey enough to guide you through what you can do with the registry because the pathways in the LOCAL_MACHINE entries is quite extensive and again I cannot advise you on what to change or redo in those entries.

I might ask for some help on this one.

Just one thing have you run this
Disk Check < if necessary include the /f and /r in the command line as per Option2 (if you are going to use the /r switch there is no need for the /f switch)

Best done in safe mode I shall wait on your reply and if there is no fix or improvement then I shall ask for that help..
My System SpecsSystem Spec
23 Jan 2017   #7
Megahertz07

Windows 7 HP 64
 
 

If the virus made changes on register and you're having trouble with hardware drivers, start from scratch.

My suggestion:
- Backup all your data.
- Do a Factory restore.
- Reinstall all programs.

For the updates: MS releases SP2 for Windows 7
My System SpecsSystem Spec
23 Jan 2017   #8
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

I agree with Megahertz because as I mentioned before unless one is really confident with finding issues in the reg and changing those reg entries it would be a daunting task. This is by far and away a quicker and more final solution.
My System SpecsSystem Spec
Reply

 Network Adapter Missing after Virus




Thread Tools




Similar help and support threads
Thread Forum
network adapter missing
I recently bought a new CPU (core i7-3770k) which required an update to the BIOS. That caused some problems (documented in some of my other recent posts) and I decided to do a clean install of my OS (W7Ultimate). Since then the system has been mildly problematic. I have not yet installed the new...
Network & Sharing
Network Adapter Missing
Hello all, I can't detect internet on my laptop. When I go to the bottom right internet icon, there is a red x through the icon. After some browsing through the internet, I've found that what helps some people is going to computer-> manage -> network adapter and deleting the adapter. For me the...
Network & Sharing
Network adapter missing.
Hi, I need urgent help please. So I installed windows 8, I originally had windows 7 home premium. I dint have a win 7 disk so I had to download a torrent and install win 7 again, it all went well until I tried connecting to my wifi. It's says "Windows could not find a driver for your network...
Drivers
Missing Network Adapter? Please help!
Hi, I just reinstalled Windows 7 Ultimate x64 and for some reason, I am missing one of my network adapters. I have had this system up and running before and I use the second adapter to stream media to my PS3 - so it is essential to me! I've done a Windows update and checked to make sure both...
Network & Sharing
Network adapter is missing
Hello guys! I got a little issue with my new ADSL USB modem. It's a D-Link 210. My specs: Windows 7 Professional x86, nVidia nForce networking adapter (Ethernet) (onboard) and the installed driver from the modem: D-Link DSL-210 USB ADSL LAN Adapter (installed with the CD that came with the ADSL...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App