Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB device problem with windows

28 Jan 2017   #1
Nihal mazhar

Windows 7 home basics x64
 
 
USB device problem with windows

I have been facing this issue for a couple of days.Whenever I try to connect my USB keyboard to my laptop ,it doesnt work properly.Let me tell the exact events.Couple of days ago when I plugged in my USB keyboard onto my laptop for coding work,the keyboard lights blinked on for a second and went off and the keys wont register any presses.After that I removed it from the USB port and and plugged it again.The lights blinked for a second and went out.Now my usb cooling pad has also stopped working properly like it used to.I will have to plug it in a way that the usb interface is not fully inserted to the port ie a little bit ejected out.Otherwise the voltage is low and fan starts rotating at a low speed.After that my usb bluetoooth reciever for logitech mouse stopped working properly after I pulled it out for testing all the ports.My laptop has 3 USB ports.
After that I tried rebooting the computer to see if the problem has gone.The bluetooth reciever started working properly but not the keyboard.

After that I tried switching on the computer with the keyboard plugged in.Then it started blinking and stopped when the loading windows screen started appearing and then came back when logon screen appeared.After I logged into windows it stopped again.I can see the USB keyboard in the devices and printers with a yellow alert .Troubleshooting couldnt identify the problem.So I went to device manager and tried updating the driver but it says the driver installed is the latest one.
All other USB devices like hard disk is working properly and I have disabled the USB selective suspend in power options.

Now I am typing this article using my built in keyboard , it started working (but its not related to using the built in keyboard.I have used it earlier but the USB one doesnt work).So to test if its okay I pulled it out again and inserted but didnt work.Now I found out that it needs sometime to work properly like 10 minutes or so.But it wasnt required earlier before the issue started to occur.

Now I dont know whether its a problem with windows 7 or the keyboard or the laptops USB ports itself.Someone said that if it was the problem with usb ports ,switching off the laptop and holding the power button for 30 seconds to discharge the capacitor will work but i havent tried that till now.Any suggestions are welcome


My System SpecsSystem Spec
.
28 Jan 2017   #2
Megahertz07

Windows 7 HP 64
 
 

I would say that your USB cooling system is draining so much power that the USB's go to a under voltage state.
Try your keyboard without the USB cooling system.
My System SpecsSystem Spec
29 Jan 2017   #3
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
I would say that your USB cooling system is draining so much power that the USB's go to a under voltage state.
Try your keyboard without the USB cooling system.
Either that or the USB power functions in the laptop have been damaged permanently.
My System SpecsSystem Spec
.

30 Jan 2017   #4
Nihal mazhar

Windows 7 home basics x64
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
I would say that your USB cooling system is draining so much power that the USB's go to a under voltage state.
Try your keyboard without the USB cooling system.
I don't think its because of the usb cooling system because I have been using it for a couple of years and it never caused a problem .Also I have tried using the laptop without it .Even then the keyboard stopped working a couple of times.
My System SpecsSystem Spec
30 Jan 2017   #5
Nihal mazhar

Windows 7 home basics x64
 
 

Quote   Quote: Originally Posted by Mellon Head View Post
Either that or the USB power functions in the laptop have been damaged permanently.
If the USB functions were permanently damaged,It shouldn't work at all ,Right?but its working .The external hard drives are functioning without any issue and the usb cooling is running at full speed.The keyboard also works at times and some other times it stops working
My System SpecsSystem Spec
Reply

 USB device problem with windows




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 'reboot and select proper boot device' problem
I believe this problem is different to previous threads on this subject. I have a 500GB HD with a trial version of Windows 8.1 installed as GPT which I want to use as clean build of Windows 7 Pro. I used a UEFI Windows 7 USB Drive to install the OS on the GPT partition which was successfully...
Installation & Setup
Sony Vaio Windows 7 Alps Pointing Device Problem
Hello there, I am new to this forum. I use a Sony Vaio VGN-SZ491N laptop that I just recently installed Windows 7 Ultimate 64bit on. However, since updating, my touch pad no longer scrolls. I went to the Sony manufacture site to download the Alps Pointing Device Driver, but it is only for Vista...
Drivers
Windows has encountered a problem communicating with a device conne...
Hello, I have recently built a custom PC. When I wanted to install Windows 7 I got a message saying "Windows has encountered a problem communicating with a device connected to my computer". Somehow I managed to fix this problem, and now I don't remember what I did. Now I am trying to reinstall...
Installation & Setup
Driver/Device Manager Problem after re-installing Windows 7
Hi, Today I reinstalled Windows 7 on my Novatech nSpire Pro 2430 because it was sluggish and I wanted to have a clean slate. I, however, now can not connect to the internet. Device manager isn't showing my Network Card, or even my graphics card for that matter (GEFORCE GT540M). I've tried...
Drivers
Realtek Hd Device problem on my Windows 7.
Hi, I have downloaded Realtek Hd Device on my Windows 7. And while installing the massage appears 'NO DRIVER WAS SUPPORTED IN THIS DRIVER PACKAGE' .. I have hp Pavilion 5000. Plz help guys..............
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App