Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can’t Print – says “Error Printing” in queue

09 Mar 2017   #1
DaveBrock

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Can’t Print – says “Error Printing” in queue

Hi,
I have 2 laptops and a desktop in the office, all 3 of them running Windows 7. Printer has been running fine on all computers for years.

Last week the printer stopped working on 1 laptop. When I print a document from MS Word, the queue says “Printing” but nothing happens. After approx. 1 minute the queue says “Error Printing”

The printer is connected to a WiFi router. The desktop is connected by cable to the router, and the 2 Laptops connected via WiFi. Printer still works fine on 1 of the laptops.

I went to Services, and stopped the Print Spooler, and then restarted. Still would not print.

I cancelled all documents in the queue, and tired again. Still would not print.

I can ping the printer from the laptop which won’t print.

I have stopped the printer and restarted it, and stopped and restarted the router, and also shutdown and restarted the laptop... still won't print from that 1 laptop.

Any suggestions?

Thanks in advance,
Dave


My System SpecsSystem Spec
.
11 Mar 2017   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok Dave mate it would be good for you to follow this please
Now before we can help we do need to know what is in your machine so please do this System Info - See Your System Specs
or either enter the specs of your system in your forum profile the specs will appear when we click on that little box bottom left of the post screen it is for me the preferable option as it is easy. As you may appreciate it is very hard when you don’t know what one is working with for example a diesel or petrol engine.
*(pretyped to save time)

Now my first thought is that you should run these
SFC /SCANNOW Command - System File Checker
Disk Check < if necessary include the /f switch and if this does not make any improvement then just run this switch instead /r in the command line as per Option2
Run these in safe mode and the sfc often best run for two to three runs – you can leave out the /r switch in ckdsk if you feel it not necessary

if no fix then these

SUPERAntiSpyware | Remove Malware | Remove Spyware - AntiMalware, AntiSpyware, AntiAdware!
Malwarebytes | Malwarebytes Premium
AdwCleaner Download
ADW download from bleeping computer delete any rubbish found with the malware scans
(NB If you are running Kaspersky as the main AV then it might need disabling it when trying ADW because it does not like it at times)

Next I would update the driver for the printer in the machine that is not working and as I don't know what you have I cannot link you to anything.

You could also look in the Device Manager and look for any devices that have yellow triangles alongside them.


Attached Thumbnails
-dave.png  
My System SpecsSystem Spec
11 Mar 2017   #3
DaveBrock

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Hi ICIT2LOL,
I ran the System Info and updated my specs... so you can see that I am running petrol instead of diesel.

I read about the SCF / SCANNOW you recommend and it said

"Be aware that if you have modified your system files as in theming explorer/system files, running sfc /scannow will revert the system files such as explorer.exe back to it's default state. Make the appropriate backups of your system files that you have modified for theming if you wish to save them before running sfc /scannow. "

It's a good few years since I have changed the Explorer settings (and probably many more settings) to get Windows 7 the way I like it, and I can't remember all the work and all the settings I have changed a few years ago.

I am running up to date Bitdefender Total Security on all 3 of my machines.

I also checked the device manager as you suggested, and all looks normal... with no triangles.

From Devices and Printers, when I click on the printer, and then Printer Properties, and click Print Test Page, it goes to the queue and status is "Printing". Nothing happens at the printer. Approx 1 minute later, the status changes to "Error - Printing".

Is there a log file that I can check, to see why the status went from Printing to Error-Printing ?

Any ideas what could have changed so that 1 of my laptops does not print, but the other two machines are fine?

Thanks,
Dave
My System SpecsSystem Spec
.

11 Mar 2017   #4
DaveBrock

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I enabled Print Logging;

'Start->Administration Tools->EventViewer->Applicationsand ServiceLogs-> Microsoft->Windows->Print Service->Operational - Right click and select Enable log''

And saw this error in the Event Log

Event Properties – Event 372, PrintService

The document Test Page, owned by Dave, failed to print on printer Kyocera FS-C5400DN. Try to print the document again, or restart the print spooler.
Data type: NT EMF 1.008. Size of the spool file in bytes: 196608. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\DAVE-LAPTOP. Win32 error code returned by the print processor: 2250. This network connection does not exist.

Does this give any information, on what may be causing the error?
My System SpecsSystem Spec
11 Mar 2017   #5
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

As its reporting --- network does not exist,
recreate the link,
note check the printer log as well, might give you a clue as to when the connection was dropped, what was happening on the lappy at that time.

Roy
My System SpecsSystem Spec
11 Mar 2017   #6
DaveBrock

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Hi Roy,
I am not sure what you meant by 'create the link again', so I went to Printers and Devices, and deleted the printer 'Kyocera FS-C5400DN'.

I then clicked 'add printer', selected 'Router printer', and entered the IP address and type of printer, and that seemed to add the printer ok.

I then printed a test page, but nothing happened.

In the Event View, under Printer Operation log there are no errors.

Last few Informational Messages were as follows;

Printer Kyocera FS-C5400DN will be deleted. No user action is required.
Printer Kyocera FS-C5400DN shared as Kyocera FS-C5400DN was unshared by the print spooler.
Settings for printer Kyocera FS-C5400DN Laptop were changed. No user action is required.
Printer Kyocera FS-C5400DN Laptop was created. No user action is required.
Printer Kyocera FS-C5400DN Laptop was shared by the print spooler as Kyocera FS-C5400DN Laptop.
Settings for printer Kyocera FS-C5400DN Laptop were changed. No user action is required.
Spooling job 3.
Printing job 3.

In Event Viewer under Printer Admin, messages as follows;

The default printer was changed to Send To OneNote 2013,winspool,nul:. See the event user data for context information.
The default printer was changed to Kyocera FS-C5400DN Laptop. See the event user data for context information.

Any ideas?

Dave
My System SpecsSystem Spec
11 Mar 2017   #7
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Quick query Dave - I am wondering why in your specs this is quoted as the motherboard??

"Notebook W350STQ/W370ST"
My System SpecsSystem Spec
12 Mar 2017   #8
DaveBrock

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

From command prompt, when I type in
wmic baseboard get product, manufacturer, model it displays
Manufacturer Model Product
Notebook W350STQ/W370ST

This laptop I have had since 2013 and runs excellently.

Just 1 week ago, suddenly it would not print.

I had installed Windows Updates 1 day previously as far as i can recall.

Please see my previous entry reply to Roy, when I deleted the printer, and then added printer again to see if this gives any clues to the problem.

When I try to print, and look in the Event Viewer this is the message;

The document Test Page, owned by Dave, failed to print on printer Kyocera FS-C5400DN Laptop. Try to print the document again, or restart the print spooler.
Data type: NT EMF 1.008. Size of the spool file in bytes: 101556. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\DAVE-LAPTOP. Win32 error code returned by the print processor: 2250. This network connection does not exist.
My System SpecsSystem Spec
12 Mar 2017   #9
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Dave,

Looks like for some reason OneNotes is getting in the way,
OneNote 2013,winspool,>>> nul:.<<< that means NO printing
OneNote(XPS) showing in devices??

do you have this option available when Right clicking on the Kyocera printer

select Set as default printer,(tick it)
or if not
Click the "Manage default printers" button in the menu bar.

Select the "Always use the same printer as my default printer" option in the dialog box that opens up and click the "Apply" and "OK" buttons.


If you have other devices in devices\printers you could try removing them, if the above option is not offered.

Roy

.


My System SpecsSystem Spec
12 Mar 2017   #10
DaveBrock

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Thanks again Roy...
I already had 'Set as Default printer' in the Printers and Devices section.

I can't see any option " Click the "Manage default printers" button in the menu bar. "

I also tried to Print from Wordpad, and same behaviour.... status first says "printing" and then approx 1 minute later status changes to "Error - printing".

In Devices and Printers I also have
Adobe PDF
Fax
Kyocera FS-C5400DN Laptop (set as default)
Microsoft XPS Document writer
Send to OneNote 2013


I just noticed another strange behaviour...

When I print a document (from Word), the status is 'printing' although nothing prints, and then changes to 'error - printing'.

So I then 'cancel all documents'... and the strange thing is that in Printers and Devices, a slightly greyed out image of the old printer "Kyocera FS-C5400DN" then just appears as one of the printers.

When I added a new printer yesterday I named it "Kyocera FS-C5400DN laptop" so I could tell the difference.

I wonder what could be causing this 'old printer' name to be appearing?
My System SpecsSystem Spec
Reply

 Can’t Print – says “Error Printing” in queue




Thread Tools




Similar help and support threads
Thread Forum
Hp 6968 won't print yet print queue shows empty
I ran into a very odd issue today that as-is I only have working using a workaround. I have a 32-bit windows 7 machine. The HP 6968 printer is hooked into my wireless router via ethernet cable. I downloaded the drivers and ran the setup on another ethernet connected Vista 32-bit machine and a...
Hardware & Devices
Can't print: just says "Error - Printing" in queue
This is a new laptop, Windows 7 Home Premium 64 bit, and I have installed drivers for both my HP Laserjet CP1215 and Canon MP150 (and re-installed quite a few times now too...). Whenever I try and print a document, from WordPad, Adobe Reader, Word, whatever, it just appears in the print queue...
Hardware & Devices
When printing, print jobs are showing in the print queue as paused.
I have an end user that is printing to a networked Xerox printer. When he prints, his print jobs automatically show in the print queue as "paused". This only happens on the Xerox. I had him try doing this with a networked HP in his area and it doesn't happen on that printer. I have removed and...
General Discussion
Printing error, cannot print anything
Hi, I bought a new laptop with Win7 Home Premium 64bit a couple of months ago and havent been able to print anything at all. The printers that i have are HP Officejet K7100, HP Deskjet 960c. Both printers are recognized and the status on the control panel is all good, until i actually print...
General Discussion
Win 7 Print Queue won't empty
I have two PCs on which I have installed Win 7 Home Premium. They are both Dell PCs and I have a Dell MFP1600n networked printer plugged into my router. Everything prints fine, but when it's done printing the job won't flush out of the queue. Since it's in the queue, when I reboot both systems,...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App