Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Printer is local but computer looks on network

17 Apr 2017   #1
BarryNZ

Windows 7 Home Premium x64
 
 
Printer is local but computer looks on network

Hi, I have a Canon i865 inkjet printer that has been installed on my Asus laptop and running well for a long time, although I don't often use it. When I tried to print something today, the printer could not be found. It is the same for all applications, although the messages may vary slightly. For example:

Microsoft Word
File -> Print -> Printer: No Printers Installed
Add Printer -> Find in the Directory
[error] The Active Directory Domain Services is currently unavailable.

Notepad -> File -> Print -> Before you can print, you need to select a printer.
If you need to install a printer, either double-click the Add Printer icon or click the Find Printer... button located on the General tab of this dialog.
Print [dialog]
General [tab]
Find Printer -> Please select the network printer you want to use and click Select to connect to it [dialog]
The only item showing is an icon with the name of the system. Clicking on that shows one item: a printer called RolandVW that someone connected to the system years ago but is long gone. I go to Devices and Printers, select RolandVW and click Remove device. The device remains. RolandVW is a network printer but I don't know how to remove it.
Alternatively, in the Notepad dialog, if I click Add Printer I get an error message: Windows can't open Add printer. The local printer spooler service is not running. Please restart the spooler or restart the machine.
The question I have is why is it only looking for a network printer? I don't have a network printer, only a local printer but it's not giving me the option of using a local printer.

The printer appears in Devices and Printers:
Canon Inkjet i865
State: Default
Right-click -> Troubleshoot -> Troubleshooting couldn't identify the problem
Add a printer
Windows can't open Add printer. The local printer spooler service is not running. Please restart the spooler or restart the machine.

Administrative Tools -> Services -> Print Spooler -> Properties
Print type: Automatic
Service status: Stopped
I start the service, then try to add a printer -> Add Printer -> What type of printer do you want to install? -> Add a local printer -> choose a printer port -> Use an existing port [Drop down list of ports is blank and Create a new port is greyed out] -> Next [error] Operation could not be completed.
I then go back to Devices and Printers and again click Add a printer and again get the same error: Windows can't open add printer. The local printer spooler service is not running. please restart the spooler or restart the machine.
I return to Administrative Tools -> Services -> Print Spooler -> Properties
Print type: Automatic
Service status: Stopped

I opened a command prompt and tried the System File Checker:
sfc /scannow
Windows resource protection did not find any integrity violations.

I tried System Restore.
It completed successfully.
(no change)

At this point I am pretty much stumped. My printer is local but it appears that my system, thinks that it is located on a network. I googled extensively on the various error messages but nothing leads anywhere. Any help would be much appreciated.


My System SpecsSystem Spec
.
20 Apr 2017   #2
DealerMan

Microsoft Windows 7 Ultimate 32-bit 7601 Multiprocessor Free Service Pack 1
 
 

Barry, lets try the easy list first. Is this a USB-connected printer? Try a different port or cable if you have a spare. If that doesn't work, log on an Admin account and try the steps you've taken already (remove old entry/make sure spooler is running/etc). Let us know what happens. Good Luck!
My System SpecsSystem Spec
Reply

 Printer is local but computer looks on network




Thread Tools




Similar help and support threads
Thread Forum
Add a local vs add a network printer -- What does this mean exactly?
Hello, I'm puzzled as to how "add a local printer" and "add a network, wireless or bluetooth printer" are different. Under "Add a local printer", I can use an existing port or create a new port, under which I can set a TCP/IP address to connect to shared printer over network. What's the...
Network & Sharing
Not able to sync OneNote accross computer in local network SkyDrive
Hello I have setup my e-mail and pass and so on for MS Live and 25 GB Free SkyDrive My laptop is win 8 64 bit with office 2013 and my home server is win 7 64bit with office 2010 now the main location is in the server and it is synced with skyDrive on my labptop i am login to Onenote...
Microsoft Office
Local files showing in Network Locations in My Computer?
How can I get rid of this files/shortcuts showing in Network Locations located in My Computer? This image might explain more http://i.imgur.com/g8uCU.png If I try deleting the files, it deletes the file in the C drive as well.
Network & Sharing
Can't share printer on local network (0x00000012 error)
Hi all, I have a weird problem. And also complicated, 'cos not even my CISCO Network teacher has been able to give me a solution. I think I need some smart people here :( The thing is that I can't share my printer (connected by USB to my PC) with my laptop on another room, over the local network...
Network & Sharing
Can't print through local network to printer attached to XP computer.
Hi, my computer is running Windows 7 Professional. I have added and installed a shared printer to this computer. The printer is connected to an other computer that is running Windows XP, and the printer is shared. Everything seems ok. The installation completed without difficulties....
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App