Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External HDD take too much time to copy / loosing connection

20 Apr 2017   #1
CartmanOrTigger

Win 7 Premium x64
 
 
External HDD take too much time to copy / loosing connection

Hello,

all my extern HDD has these symptoms:

-it take a very long time until a copy process is done. At the end, it says it would be a couple seconds, but then it takes much longer when a process is nealy completely done.

-sometimes it says "searching for data" or "objects" or so, when i start to copy a file or try to delete something even if the size is not that big.

-it gets better after a disk cleanup via windows tool. but later it happens again.

Do you know why this happens? It happens withl all my 3 extern hdds the last time.


My System SpecsSystem Spec
.
20 Apr 2017   #2
RolandJS

Windows 7 Professional 64-bit
 
 

Are there other things going on during these extensive and not-so-extensive copying operations? Also, I'm wondering if security and monitoring programs might be a little too assertively set.
My System SpecsSystem Spec
20 Apr 2017   #3
Lady Fitzgerald

Win 7 Ultimate 64 bit
 
 

What kind of external HDD is this? 3.5"? 2.5"? Is it USB powered or does it have a separate power supply?
My System SpecsSystem Spec
.

Reply

 External HDD take too much time to copy / loosing connection




Thread Tools




Similar help and support threads
Thread Forum
Bluetooth mouse keeps loosing connection
I have searched everywhere but cannot find a solution. My Logitech bluetooth mouse keeps losing connection or just won't work with my laptop. I have tried disabling the powersave option, I have used the logitech combi to reset the mouse, I have bought a new mouse, changed batteries, reinstalled...
Hardware & Devices
Mapped Drive Loosing Connection after 6 to 8 hours
Ok, here is a problem I have been having lately and it is driving me crazy. I have a network with a server running 2008 Standard R2 and 4 workstations using Windows 7 Professional 64-bit. I also have 1 other station using Windows XP Professional. The software I run off the server is installed as a...
Network & Sharing
Loosing connection to network devices
Reposted from dlink forum:
Network & Sharing
Loosing internet connection... Help
I have been using Windows 7 on a new hard drive for around 2 months now on my PC and have had no problem with connecting to the internet. I am using a netgear DGN2000 ADSL2 + modem router and like i say i have had no problem with the internet then suddenly i would be on the internet then connection...
Network & Sharing
Loosing connection to servershares
Hi! I'm connecting networkshares from several 2003 servers to my W7-X64 workstation (build 7000). As the workstation is not a domain member I'm using my full domain credentials when mapping. The shares work fine for a variable span of time (variing from about 30 minutes to several hours or...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App