Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: new external drive format issues

27 May 2017   #1
modemport

win7 home premium 64 bit
 
 
new external drive format issues

so.
got myself a low end toshiba external portable 500gb hard drive.
plug it in. it works.
decide to do a format - cos my other drives are ntfs, i want this one also. i trigger it, and wait and wait and wait
and nothing is happening so i cancel.
and keep clicking to cancel and eventually it does.

i unplug the drive's usb cord from the drive, wait a bit, plug it in, pc message asks me to format i say yes, put in ntfs and i wait and wait and wait and nothing is happening.

i cancel etc.

hey i never claimed i'm a pc tech.
now after 2 reboots it's plugged in and out and in, i get a message now asking if i want to format i say yes, and eventually i get a message saying

Windows can't format M
Check to see that the disk and drive are connected properly, make sure that the disk is not read-only and then try again. For more information, search Help for read-only files and how to change them.

now i don't know what to do.
the default initially was exFat i'm thinking i should have left well enough alone.

but now i need to try to get it working..

please help


My System SpecsSystem Spec
.
27 May 2017   #2
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Hi modemport, welcome to the Forum.

Could you please supply a Disc Management screen shot. Make sure your external 500 gb drive is plugged in. The Forum tutorial below explains how to do this. Also follow the instructions in item 7 of the tutorial on how to upload the screen shot to this Forum.

Disk Management - Post a Screen Capture Image - Windows 7 Help Forums
My System SpecsSystem Spec
27 May 2017   #3
modemport

win7 home premium 64 bit
 
 

it won't let me.
when the drive is unplugged i can click on disk management.
with the drive plugged in i get a popup

You need to format the disk in drive M: before you can use it.
Do you want to format it?

Whether I click 'format disk' or ignore the popup to click on Disk Management, the information won't load
At the bottom of the screen is 'Connecting to Virtual Disk Service' and nothing happens.

With the drive unplugged I can call it up but M drive won't appear.
My System SpecsSystem Spec
.

27 May 2017   #4
modemport

win7 home premium 64 bit
 
 

I tried a reboot, had M drive unplugged because previously with it plugged in, it would not shut down properly.
When it was shut down I plugged it in and it would not boot properly.
It was unplugged, booted, I plugged it in, got a popup asking me if I wanted to format, I ignroed it
Called up the program, clicked appropriately and it wouldn't work.
My System SpecsSystem Spec
28 May 2017   #5
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Is this Toshiba drive a new one, or is it an old second hand one?. If it's a new drive you may be able to make a warranty claim. Is there any indication as to what format the drive was in before you tried to change it. From what you have said it may have originally been in FAT 32 format.
My System SpecsSystem Spec
29 May 2017   #6
modemport

win7 home premium 64 bit
 
 

the toshiba drive is new, bought off ebay, from an asian vendor. 500gb for 30usd

500GB Basics USB 3.0 Portable External Hard Drive For Toshiba Canvio Black HOT! | eBay

the pictures don't indicate it, but it did arrive in proper toshiba boxing, and the drive itself has toshiba stamped on it. i had thought praps due to the price it would be a clone, but i'm reasonably certain it's authentic toshiba.

as i said, prior to trying to change it to ntfs, it was indicating exFat. a quick google shows exfat generally is for e.g. flash sticks. this is a proper external portable hard drive, usb powered. it's usb v3.0. my own pc is only 2.0

i don't know what warranty it comes with, but let's be fair; i'm the one who ruined it, i'm not interested in returning it to the vendor and request either a refund or a new one.

if it can't be fixed, then i'll simply get another one.

all i wanted it for was to put in some of my files, approx 350gb, and send it to a friend. that's it. it's not for long time personal use; i was going to suggest to her that she copy the material off it to her own drive, then put my drive aside as a backup. so generally it's a one use drive.

if nothing can really be done, i think it's ok with me at this point.
My System SpecsSystem Spec
29 May 2017   #7
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

It does seem that your drive may be faulty. This Toshiba website says that HDD should be in NTFS file format already, so it would seem that someone may have changed the one you bought to some other file format.

Canvio Basics - 2.5" - 500GB - black - Toshiba
My System SpecsSystem Spec
30 May 2017   #8
modemport

win7 home premium 64 bit
 
 

the drive is junked so the issue has turned moot.
thank you for your help
My System SpecsSystem Spec
Reply

 new external drive format issues




Thread Tools




Similar help and support threads
Thread Forum
how can i format my external HD drive into FAT32 format
hi, i've purchased a seagate 1TB external hard drive and need to format it in FAT32 format. how can i go about doing this using windows 7?
Hardware & Devices
Format 3TB External Drive
I'm running Windows 7 (64-bit) with UEFI Bios and I just bought a Seagate 3TB Backup Plus External drive that I plan to use for data only (specifically to backup System Images using Macrium Pro). I don't care about the Dashboard software that comes with it so thought I should probably format the...
Hardware & Devices
External drive not working after format
Hi guys, I have a Buffalo HD-LB3 3TB external harddrive. My main goal is to get it to work with my xbox 360. I was able to get it to work on my blueray player but it is not found by my Xbox. I have formatted it to Fat32 and I have partitioned it into two pieces, 1.8 TB and 1.1 TB. Still nothing is...
Hardware & Devices
Trying to format 250 g external drive (laptop hd) but only getting 31g
So I am trying to get my external laptop drive to show that is 250 g but every time i format it only 31g show up.... I havn't set anything that i know of .... So some help would be great Kodiak:cry:
Hardware & Devices
Can't Format my External Drive.
I was trying to install an external drive to my router D-Link DIR 655 and gave up on that.after connecting my Ex-hard drive to my laptop with Win7 64 I could not get it to format after some time I moved the exDrive to my wife's laptop and was able to do the format but when I went back to the Win7...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App