Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Asus G75VW does not recognize USB ports

04 Jul 2017   #1
RocketFlamingo

Windows 7 Home Premium 64 bit
 
 
Asus G75VW does not recognize USB ports

I read a post from 2014 that was nearly identical. The answers, however, did not help the person asking for help.

Everything worked fine on Monday - no changes or installs were made. Come back to edit some images and my card reader and USB ports are gone. I tried what I could and did download Device Driver which installed all of the correct drivers and there are no exclamation points anywhere in the Device Manager.

I decided to see if it was the Hub or the machine. I took the machine to the Hub and one at a time, plugged each unit directly in to the computer. Nothing. I tried to plug a camera in - nothing. The Libraries never changed and none of the 3 external HDs were found nor was the card reader.

I would really appreciate any help. I did notice a suggestion to do a restore - and I would if I could but - the external hard drive that has everything is one of those USB devices and the networked 8TB WDUltra is considered a network device and the computer doesn't look for it as a source of backup.

Also, I have an elevated command prompt open, and the only 2 accounts on the machine are Administrator accounts; but it doesn't recognize either account as Administrator and won't run sfc /scannow either.

I miss my ports and thank any and all who can help.

Lisa


My System SpecsSystem Spec
.
04 Jul 2017   #2
RocketFlamingo

Windows 7 Home Premium 64 bit
 
 

I forgot to add that yesterday I was optimizing the BIOS - in an attempt to get my ports back - and changed the character from whatever it was to RAID. I don't know if that makes any difference; it was because the ports were gone that I tried that.

Lisa (again, sorry)
My System SpecsSystem Spec
04 Jul 2017   #3
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Once you installed IObits Advanced System Care you are pretty much screw.
It does all kinds of goofy things to any computer.

You could try using a restore point before you installed ASC.
It might help and it might not.

From your System Specs
Quote:
Antivirus Malwarebytes, Bitdefender, Advanced System Care
Jack
My System SpecsSystem Spec
.

04 Jul 2017   #4
RocketFlamingo

Windows 7 Home Premium 64 bit
 
 
Excuse me?

I don't use Malwarebytes or Advanced System Care; they are not installed on my machine. I use Bitdefender. Why would you think I used the others?

Did you read my post? I can't use a restore point because the expansion drive that has the backups are connected by USB. The other backup is a WDUltraMax that's on the network and the machine doesn't access the network for backup and restore points.

I regularly make backups and create restore points. This is the first time that won't help me.

Lisa
My System SpecsSystem Spec
05 Jul 2017   #5
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

Quote   Quote: Originally Posted by rocketflamingo View Post
... I don't use malwarebytes or advanced system care; they are not installed on my machine. I use bitdefender. Why would you think i used the others? ...

Lisa
From your System Specs

Asus G75VW does not recognize USB ports-capture.png


My System SpecsSystem Spec
05 Jul 2017   #6
RocketFlamingo

Windows 7 Home Premium 64 bit
 
 



I don't know where those sys specs you're referring to are. I went through regedit and found one reference to ASC which I deleted. The program itself was deleted - when I found it with Uninstaller.

These are the USBSTOR reg settings. Everything listed is correct. What's there that's preventing it from showing? I also get another error when I attempt to access "Properties". Images attached.

I will look for Malwarebytes as that was or should have been deleted a long time ago.

Thank you,

Lisa
My System SpecsSystem Spec
05 Jul 2017   #7
RocketFlamingo

Windows 7 Home Premium 64 bit
 
 

I'm rusty at this. The images referred to are attached for your review and reference.

Thank you,

Lisa


Attached Thumbnails
Asus G75VW does not recognize USB ports-parameters.jpg  
Attached Images
Asus G75VW does not recognize USB ports-usbstor.jpg Asus G75VW does not recognize USB ports-iobitprograms.jpg Asus G75VW does not recognize USB ports-cannotbeopened.jpg 
My System SpecsSystem Spec
05 Jul 2017   #8
Megahertz07

Windows 7 HP 64
 
 

Lisa, don't play with Regedit or you may end with an unusable computer.

Open Control Panel\All Control Panel Items\User Accounts. One account must be administrator.

I think you have to edit your hardware profile specs to match your system.


Attached Thumbnails
Asus G75VW does not recognize USB ports-lisa.jpg  
My System SpecsSystem Spec
05 Jul 2017   #9
RocketFlamingo

Windows 7 Home Premium 64 bit
 
 
Reply

Megahertz07,

Can you elaborate on that reply?

How do you see my specs and how do I match them to the hardware?

Also, following your advice, I went to User Accounts then Manage Accounts. There are only 2 users and both are Admins. Both are password protected.

Thank you,

Lisa
My System SpecsSystem Spec
05 Jul 2017   #10
Megahertz07

Windows 7 HP 64
 
 

Lisa,
Every post you do, at the bottom left has a small arrow. You hit it and it will expand with the hardware specs.
To edit your profile, click your mouse over your nick name (RocketFlamingo) - View public profile -
Once you're on your page, at the top you have Quick links -User control Panel - Edit System Spec

To run sfc /scannow, open a CMD window with admin right (right click on CMD shortcut - run as administrator) type sfc /scannow

Found this link https://www.sevenforums.com/profile.php?do=extra
My System SpecsSystem Spec
Reply

 Asus G75VW does not recognize USB ports




Thread Tools




Similar help and support threads
Thread Forum
USB ports won't recognize external drives on Win 7 but will on Ubuntu
Hello. This is my first post here so I apologize if my format is off. I've used the forums here quite a bit and they've fixed many problems in my workplace. I have an issue with a Dell Latitude E5510 Laptop with Win. 7 Pro x64 that is hindering work. The laptop will not recognize any flash...
Hardware & Devices
Asus g75vw with only 2 days :: Blue screen (bsod)
Hello everyone! I bought Asus G75VW two days ago and i got for four times blue screen of death error! Can anyone help me figured out what is going on? Because if it is something serious i need to change fast the computer. I have the minidump file here : 011113-10951-01.dmp
BSOD Help and Support
Asus g75vw Windows 7 Ultimate x64 SSD installation issue
Hi, I just bought my Asus g75vw, it comes without OS, so i got Windows 7 Ultimate x64 to install. Now at the partition selection when i select to install to SSD partition the "next" button freeze and i forced to use HDD partition. How can i install windows on my SSD ? I tried to find a...
General Discussion
Asus g75vw Windows 7 Ultimate x64 SSD installation issue
Hi, I just bought my Asus g75vw, it comes without OS, so i got Windows 7 Ultimate x64 to install. Now at the partition selection when i select to install to SSD partition the "next" button freeze and i forced to use HDD partition. How can i install windows on my SSD ? I tried to find a...
Installation & Setup
USB ports won't recognize mouse
Hi, Hope this post is in the right forum. I have a 6 month old HP Pavilion dv6 Series laptop. Up until recently the USB ports on the right hand side of the machine (2 of) accepted my Trackball mouse, but now they don't. The USB port on the left side is fine, the mouse works ok in that one. The...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App