Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Saving my data from dying 2.5" Laptop HDD. 'Parameter incorrect' etc.

09 Aug 2017   #1

Windows 7 Ultimate x64
Saving my data from dying 2.5" Laptop HDD. 'Parameter incorrect' etc.

A week or so ago a friend came to me with a dead laptop. The drive had seemingly died on them and startup recovery proved ineffective - The drive couldn't be found.

I've since relocated the drive to one of my 2.5" bays in my PC to find that windows refused to boot with the drive inserted, requiring some tinkering to get working. After reinserting the drive, I was greeted with this:

I've since tried numerous methods to recover the lost data with varying success. Partition magic shows the drive, partition, and a file preview:

I've tried to use partition recovery with no results (the partition is already found), as well as rebuilt the MBR, which hasn't yielded any results either.

I've got GetDataBack simple, and I've been able to scan the whole drive with it over a couple of days:

Smaller files seem to copy off of the drive without a hitch, but on larger files the windows aren't responding for most of the time and I frequently run into I/O errors due to unreadable segments of the FS.

Some large files were recovered in this fashion, but ones stored on the drive most recently would get completely stuck.

I've tried running TestDisk's Boot Sector recovery according to instructions in other threads, which ran successfully but offered no improvement.

Chkdsk appears to work, but because of unreadable file record segments being retried many times, I'd estimate the full runtime to be a few months.

I wasn't able to use fsutil dirty set on the drive to schedule autocheck to run on boot, but managed to set it using Regedit and it fully completed in about ~48 hours (It ran through the unreadable segments significantly faster, so if this is possible in regular chkdsk I'd be able to run additional arguments). Afterwards my PC successfully booted through to windows, but the drive is still unusable, although I did get 'The request could not be performed due to a device i/o error' on trying to open the drive which was new, but nothing helpful. No notable improvements on GDB either.

After all that I'm honestly lost as to where to turn to next. If anybody can offer any advice or direction as to where to turn to next, I'd appreciate the input, even if it just gets me to the point where file recovery software will be able to recover the larger files.

Let me know if I can provide any more information, and Thanks in advance for any assistance.

My System SpecsSystem Spec
09 Aug 2017   #2

Linux Mint 18.2 xfce 64-bit (VMWare host) / Windows 8.1 Pro 32-bit (VMWare guest)

Go to and create a Ubuntu install disk. Boot from that disk, and tell it to run Ubuntu from the DVD (in other words, don't install Ubuntu on your computer).

If the drive is readable, this should allow you to read and copy the data from the drive.
My System SpecsSystem Spec
10 Aug 2017   #3

Windows 7 Ultimate x64

Alright I've gonna and tried that. It seems like Ubuntu can freely copy all of the files that have no issues, but will skip ones with issues entirely. Ill get back to you on whether the files are complete soon.
My System SpecsSystem Spec

10 Aug 2017   #4

Multiple Windows 7 and Linux

Quote   Quote: Originally Posted by bwtw77 View Post
Alright I've gonna and tried that. It seems like Ubuntu can freely copy all of the files that have no issues, but will skip ones with issues entirely. Ill get back to you on whether the files are complete soon.
I always keep a copy of Linux Macpup on hand for data recovery from dead hard drives, ultra lightweight and only runs on RAM.
My System SpecsSystem Spec

 Saving my data from dying 2.5" Laptop HDD. 'Parameter incorrect' etc.

Thread Tools

Similar help and support threads
Thread Forum
Samsung S3 failure - "E:\ is inaccessible the parameter is incorrect"
Hi, I have reviewed a number of posts on these forums and I am looking for some help to try and recover an external HDD that has failed. The device is a Samsung S3 (ST1000M025 1TB Disc) and has recently failed. I researched the drive and identified that the heads were stuck on the platter...
Hardware & Devices
Location Not available - Incorrect Parameter
Hi, So I'm trying to access a dead external through my PC, and everytime I click the drive, I get a message saying parameter is incorrect. I've done some googleing and apparently this code may help recover it chkdsk /f /r /c x:. Will this delete the contents of the drive? Any other...
Hardware & Devices
Problem restoring to factory setting, "the parameter is incorrect".
Hi all So I want to restore my computer to its factory settings because it is giving me a few annoying problems that I would like to get rid of. I go through the steps (given here), but I get stuck once I get to the step right before the system is about to be restored. I get an error message...
Backup and Restore
"Parameter is incorrect" shrinking volume
Hi guys, I'm trying to shrink my hard drive (500 GB) so I can try out Mandriva OS but I can't, whenever I try to do so i keep getting parameter is incorrect. Any suggestions guys? Running Windows 7 Ultimate 64-bit. Oh yeah, consider this my 2nd question, before I was trying to make a new partition...
Hardware & Devices
Help! "The Parameter is Incorrect" error
I have an error when trying to change the disk drive letter of my hard drive. Is there anything I can do, like download a hotfix or change some setting or something...?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:26.
Twitter Facebook Google+