Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ram being detected both by BIOS and softwares. 2 ram slots "dead".

11 Aug 2017   #1
Twizp

Windows 7 Ultimate x64
 
 
Ram being detected both by BIOS and softwares. 2 ram slots "dead".

Hello everyone, I had to make an account for this because I've spent the entire day searching through different forums and I can't find the solution to this. I hope this is the right place to put it, just figured to put it under Hardware altough it can be a software problem, just direct me if its not here.

I bought a new motherboard and processor back in 2016, I sent the computer back to check to the vendors because I noticed it was working badly. Thought it was the processor. They told me the processor was fine but that my computer was only using 2gbs of RAM and they had made it possible it would work at 4gbs of RAM (I had 8 at the moment and they all worked with the older motherboard). When I got the computer home I switched the RAMs, got the computer to work at 6GBs (which they couldn't do in an entire week). By doing this I realised that the problem was the 2 first slots of the motherboard, they simply didn't work. If I used one single stick of ram in one of them the computer wouldn't boot up, and yes, the first slot is the one that has to be put first. All the sticks of ram work in the 3rd and 4th slot (at the time I had 1x4 and 2x2 RAMs, so I could manage to get it to 6).

Last week when I was finally able to get the motherboard back to them (I know, a long time passed), today I got it back and they told me the motherboard "didn't present any problems", so I'm stuck with this problem on my own.

The bios detects 12 gbs of RAM, I'm using 1x8 and 1x4 in the DIMM1 and DIMM3 slots (the dual channel). GPU-Z also detects 12 gbs of RAM but only single channel, and windows says I can only use 3,95. The rest of the ram, the one stick of 8, is reserved for hardware. So I don't know where the problem comes from, all the sticks work perfectly fine, the motherboard works perfectly fine (with another computer), can the windows be the problem? it works perfectly fine with my older motherboard, the bios is up to date, all settings by default.

I've checked solutions like checking the virtual page, using regedit to clear the page file at shutdown, unchecking/checking the max memory with msconfig. Can't make anything work at all...
I also reinstalled the windows once I got the motherboard, also didn't work.

Motherboard: MSI 970A-G43 PLUS
Processor: AMD FX 8320E
Windows: Windows 7 Ultimate x64

Any help is appreciated.


My System SpecsSystem Spec
.
11 Aug 2017   #2
Megahertz07

Windows 7 HP 64
 
 

Welcome to the Forum.

Fist major rule for memory is that it has to have identical sticks on each channel. Same speed, timings and latency and if possible, same brand. If you mix speeds and / or timings and latency it will work at the lowest specs.

To work in dual channel you must have identical (matched pair) memory sticks on each channel. 8G on channel A and 4G on channel B won't work as dual channel.

Lets say you have 2x8 and 2x4
- (8+4)A and (8+4)B is right.
- (8+8)A and (4+4)B is wrong
- (8+4)A and (4+8)B or (4+8)A and (8+4)B is wrong

So I suggest you to buy another 8G stick (same brand and model -speed, timings and latency) and use the other 4G stick on another computer.
My System SpecsSystem Spec
11 Aug 2017   #3
Twizp

Windows 7 Ultimate x64
 
 

Thanks for the help.

So I get that I can't dual channel the ram, still, I can't get the 1st and 2nd slot to work. The technicians said that the motherboard works for them, that they tested one stick of ram in every slot and it worked out perfectly. But in my PC slot 1 and 2 don't work with perfectly fine RAMs.

I don't really care about the dual channel but I do want my PC to work at 16 gbs, all my sticks are the same frequency and clock speed, they just have different memory size.

I'm currently using my PC with 12 gbs, with the 1x8 and 1x4 sticks in the 3rd and 4th slot. I've taken the 2x2 rams out. If I put them in, the bios reads the 16 gbs, but windows only uses whatever I put in the 3rd and 4th slots, thats my mejor problem. Its like anything I put in the 1st and 2nd go to hardware allocated memory, and If I use only those slots (both or a single one), the computer doesn't even boot up.
My System SpecsSystem Spec
.

11 Aug 2017   #4
Megahertz07

Windows 7 HP 64
 
 

Did you try to put (8+4)A and (0+0)B or (0+0)A and (8+4)B?
My System SpecsSystem Spec
12 Aug 2017   #5
Twizp

Windows 7 Ultimate x64
 
 

Yeah. As I said, only the 3rd and 4th slots work. doesn't matter if I put only the 8 one in the first or the second, or only the 4 one in the first or second, it doesn't matter if I do 8+4 or 4+8. The 2 first slots just don't use the RAM. The bios registers them only if there is some RAM in the 3rd or 4th slots, and even then it just doesn't use them. Its like the 1st and 2nd slots are allocating their entire ram to hardware and they don't boot the PC if only those are being used.
My System SpecsSystem Spec
Reply

 Ram being detected both by BIOS and softwares. 2 ram slots "dead".




Thread Tools




Similar help and support threads
Thread Forum
Windows Media Player displays "Parental rating" How? They're both dead
When I select a playlist, it appears in the main body of WMP 12.0 - and the column "Parental Rating" is NOT displayed. When I start playing it, the main section is blanked and shows "You are currently playing this list. You can edit the list in the Play tab." At the same time, the columns...
Music, Pictures & Video
No "usb legacy support" "qfan" options on my asus laptop bios.
Entering the bios limits me to certain options. Is there anyway to access the other options? sorry, newbie here.
Performance & Maintenance
Need to get files from dead laptop- drive shows as "System Reserved"
Someone spilled a liquid on my wife's laptop damaging the keyboard and internals. It cannot boot but I need to get the files from the HD. I bought one of those USB to laptop HD cables, removed the HD and hooked the cable to my desktop Windows 7 PC. The drive came up as "System Reserved" with only...
Hardware & Devices
"hard drive not detected" but the hard drive shows in bios
Ok, so I got a new asus P8z68-V pro motherboard. Im re-using my current 750gb SATA drive. I plugged it into the sata port, and start the computer. When it starts it says "no hard drive is detected!" I go into the bios, and on the bottom it has a disk drive, and a SATA drive. It...
Hardware & Devices
sudden "disk boot failure". Drives not detected by BIOS
Hi all, Last night, my HTPC was happily working. However, the PC suddently froze and I had to manually force a shudown. Then, I tried to reboot and I got the following message: "disk boot failure insert system disk" I have 2 HDs and the BIOS and POST are not listing the HDs at all. I checked...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App