Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External HDD doesn't appear in devices nor disc management

17 Sep 2017   #1
5carlet

Windows 7 64-bit
 
 
External HDD doesn't appear in devices nor disc management

Hi,

I recently installed Windows 7 Home Premium x64 on an Acer Aspire ES1-531-C0XK laptop and have installed the majority of drivers except for three which are coming up as Unknown Device (I'll post the HIDs later since I'm rebooting now).

However I have noticed no USB external drives or SD cards, etc. actually work, they don't appear in disc management administrative tool either.

The HIDs:
ACPI\MSFT0101
ACPI\80860F14
IUSB3\ROOT_HUB30&VID_8086&PID_22B5&REV_0021&SID_10121025

Could someone guide me? ^^

Thanks!


My System SpecsSystem Spec
.
17 Sep 2017   #2
Megahertz07

Windows 7 HP 64
 
 

You probably have some missing drivers.
Open device manager and look for yellow alerts and missing drivers.
With the sniping tool take a snapshot and post here as an attachment. Use the paper clip to browse the file and upload.

With 4G of memory and a Celeron CPU you should have installed the 32 bits version.
My System SpecsSystem Spec
17 Sep 2017   #3
5carlet

Windows 7 64-bit
 
 

Already posted the hardware IDs and worked out that it's something to do with USB 3.0 drivers not being present, however I don't think there are any drivers for my hardware that are compatible with Win7 64.
My System SpecsSystem Spec
.

17 Sep 2017   #4
5carlet

Windows 7 64-bit
 
 

Double post...

I managed to solve my issue by installing the USB 3.0 device drivers from the 'Intel USB 3.0 Windows 7 Image Creator' or something like that.
My System SpecsSystem Spec
17 Sep 2017   #5
Megahertz07

Windows 7 HP 64
 
 

For the USB
https://www.sevenforums.com/attachme...ler_driver.zip

Waiting for the device manager snapshot.
My System SpecsSystem Spec
17 Sep 2017   #6
5carlet

Windows 7 64-bit
 
 

As I said it has already been solved. :P
Thanks for your help anyway ^^
My System SpecsSystem Spec
Reply

 External HDD doesn't appear in devices nor disc management




Thread Tools




Similar help and support threads
Thread Forum
Disc Management problem
Never attempted to use this win 7 feature until I just done my first build and installed Win 7. I have a 500 gb sata HD with just my C drive. Recently I wanted to add a partition for just my photos and etc and some small programs that I seldom use. Stupid me, I created a 100 MB partition. I think...
General Discussion
disc management
need some advice please i am going to do a back up with acronis i read somewhere that it should include a 100mb system reserve but mine is on a different drive, i thought it should be on the c drive thx...
Hardware & Devices
Cant become adminstrator, cant use regedit, disc management, etc ???
Running windows 7 Ulitimate 32-bit. In USER ACCOUNTS , Cant change from user profile from standard user to Adminstrator. Unable to create a new user account, ERROR - The specified account name is not valid, because account names cannot contain the following characters: /\":;|<>+=,? Overall this...
Performance & Maintenance
Doesn't show external drive anymore but visible in the disk management
I have a 2,5" 500GB external hard-drive with a single partition (NTFS). I can see it in the disk management utility (see attached screenshot) but it doesn't have a drive letter nor can't I assign one. Attached to another PC running Windows XP it says "unknown partition" but also error-free and...
General Discussion
Windows7: Disc Management (pic)
My computer had 3 partitions (2 of them were recovery/files that came with the system) During the clean install of windows 7, I deleted these partitions in order to have one large C drive. (i've made backup discs and system image on external drive). The hard drive has a 160 GB capacity . I went...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:07.
Twitter Facebook Google+