Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB joystick detects when plugged in, but fails to respond sometimes

23 Sep 2017   #1
Timsup2nothin

Windows 7 Home Premium 64bit
 
 
USB joystick detects when plugged in, but fails to respond sometimes

I have a Saitek/MadCatz joystick. I plug it in when I want to use it. Sometimes it works fine, other times it doesn't. I have a hard time with intermittent problems...if the hardware is bad, how does it work some of the time? Software is a series of steps...if the computer follows the same series of steps every time I plug the thing in, how does it arrive at a different place?

Anyway, when it goes bad this is the situation.

The stick shows up under devices and printers, properly identified. When I right click on it and go to game controller settings nothing on the stick responds. Frequently, unplugging and plugging back in fixes the problem, but sometimes it doesn't. Sometimes repetition two or three times gets it to work, and sometimes I give up after multiple attempts.

Stick runs on a standard Windows driver, which is up to date. Windows 7 64bit.

I've tried a lot of stuff like removing the stick through device manager and then scanning for hardware so it reinstalls, and so far everything seems to be just like unplugging and reconnecting...sometimes it works, and sometimes it doesn't.

Searching for solutions comes up with a whole lot for "not recognized," which don't seem to address my problem.

Any ideas?


My System SpecsSystem Spec
.
23 Sep 2017   #2
Megahertz07

Windows 7 HP 64
 
 

As administrator schedule a check disk (chkdsk c: /f)
If it doesn't find bad blocks or bad clusters, run a system file check (sfc /scannow). If it finds some issues run it 3 times, rebooting after each time.
My System SpecsSystem Spec
23 Sep 2017   #3
Timsup2nothin

Windows 7 Home Premium 64bit
 
 

Well, that's always good advice for pretty much everything...but much to my chagrin I solved the problem about ten minutes after I posted it.

As I was thinking about what I posted, and what more detail I could add if no one had any ideas...

Plug in joystick, sometimes it works and sometimes it doesn't...and over time the sometimes it doesn't was getting more frequent...

Tim, you dimwit...clean the contacts on the USB connector.

Thanks for the effort...this forum has never failed me.
My System SpecsSystem Spec
.

Reply

 USB joystick detects when plugged in, but fails to respond sometimes




Thread Tools




Similar help and support threads
Thread Forum
Joystick Calibration
I've recently decided to dig out my old Logitech Extreme 3D Pro joystick and put it to good use. However, it seems that Windows 7 either lacks the calibration wizard that Windows XP had or it's just hidden very well. I've google searched "Joystick calibration windows 7" and the like numerous times,...
Gaming
Cloned SSD fails to boot unless old HDD is plugged in via caddy
Hi, I have an old laptop that I've decided to refresh (Acer Aspire 6935G) with a lovely SSD. I used Macrium Reflect to clone the hard drive whilst the ssd was in the caddy, once cloned I swapped and put the ssd inside the laptop and the old hard drive in the usb caddy. The laptop fails to...
General Discussion
update fails, SP1 install fails, troubleshooter fails
I'm simply attempting to run update on my Windows 7 machine. Update will not run, downloading and running the SP1 update fails, downloading and running the Update Readiness Tool fails, trying to launch a troubleshooter fails. I ran sfc and have attached the log along with all the error codes...
Windows Updates & Activation
Sata drive bios detects, but os not detects neither windows or linux
This is an older via chipset 1.5 Sata with a sata 3.0 WDC 1TB drive, and I have the OPT limiter jumper in place Problems encountered installing SATA 3.0 Gb/s hard drives on SATA 1.5 Gb/s controllers Before I put the jumper on the drive, the bios ignored the WDC sata drive. With the jumper in...
Hardware & Devices
Windows detects speakers that aren't plugged in?
Would anyone know why Windows would be detecting speakers under playback devices when absolutely no speakers are plugged in? The result is I can not get sound out of any speakers I plug in, presumably because Windows is trying to use these phantom nonexistent speakers. USB headphones work...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:26.
Twitter Facebook Google+