Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mouse does not function properly

01 Oct 2017   #1
DeZolance

Windows 7 Ultimate x64
 
 
Mouse does not function properly

In my last thread about my mouse not working,the problem is actually from the mouse it's self
The mouse I have is a Mad Catz M.M.O 7 which is 4 years old,everything about it works perfectly fine except left clicking
A few days ago left clicking suddenly was not working properly,I tried everything to fix it.It might be a technical issue but I went to a couple of places and no PC repair service will help me with it

The problem is:
When I plug this mouse,clicking in general does not function as it should,I can't move icons or click on the taskbar or close windows.Here is a demonstration gif of me trying to click and do things
Imgur: The most awesome images on the Internet
And it will behave like this until I restart the pc with this mouse unpluged
If I use a different mouse everything is fine,but the moment I plug in the madcatz one it does what I just described

Please keep in mind while I was having this problem I tried to reinstall my Windows 7 and this mouse still has this clicking defect so there is no driver issue here

I really don't want to throw this expensive mouse away


My System SpecsSystem Spec
.
01 Oct 2017   #2
fireberd

Windows 10 64 bit
 
 

The mouse, from your description. is defective. You will have to replace it. Mice are, in most cases, not repairable or if it can be repaired the cost to repair it is more than the cost of the mouse.

If you can take it apart, maybe you can clean any contacts and repair it yourself. Since its not commercially repairable you are not losing anything attempting to repair it.
My System SpecsSystem Spec
02 Oct 2017   #3
Megahertz07

Windows 7 HP 64
 
 

Does the click noise is very low? Compare the right and left click noise.
I had a very good mouse that was doing the same thing. It was the micro switch.
I found a switch to replace and it worked again for years. Product Detail - Americas - OMRON
My System SpecsSystem Spec
.

02 Oct 2017   #4
DeZolance

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
Does the click noise is very low? Compare the click right and left noise.
I had a very good mouse that was doing the same thing. It was the micro switch.
I found a switch to replace and it worked again for years. Product Detail - Americas - OMRON
Nope,the the action of clicking is pretty fine but now that you have shown me this,maybe the whole problem is in the switch it's self and it could be fixed if replaced
My System SpecsSystem Spec
02 Oct 2017   #5
Megahertz07

Windows 7 HP 64
 
 

If you're going to open the mouse, look for hidden screws under the label and the sliding plastic.
My System SpecsSystem Spec
03 Oct 2017   #6
DeZolance

Windows 7 Ultimate x64
 
 

Ok so apparently the switch for my scroll wheel clicking blocked,stuck on the click and was interfering with the left click making it do all that,I took the mouse to a tech specialist and he fixed it,now left clicking works fine again but the scroll click will remain broken,I'm still glad this was resolved because I love my mouse,and hopefully it will last for another 4 years
My System SpecsSystem Spec
Reply

 Mouse does not function properly




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 won't function properly since update
Sorry for the double thread, I figured out this is a better place for help. Okay so this morning, turned on my PC, everything fine, then a Windows Update started by itself (Im on Windows 7) I said alright, whatever. Then my PC rebooted and this is where everything ****ed up. First, there was NO...
Windows Updates & Activation
Hibernate Button Does Function Properly
When I clicked Hibernate, the screen turns off then after a few seconds, the screen will now show the account log in. I'm running Windows 7 64-bit Ultimate. I suspected this happened after I installed (dual boot) openSuse in the same partition where my Windows 7 is. Any solution?
General Discussion
Programs Won't function/close down properly
Heya, I know that people have come across similar issues and I have looked through hundred of threads regarding each bit of software, but I now am thinking it is something for my case, stuffing everything up. My PC is fairly new, I know it's not my hardware. My problems I have are for...
Software
Firefox 4 doesn't function properly in the taskbar
This is quite a weird problem and it started when I replaced Firefox 3.6 with Firefox 4 (as in uninstall Firefox and install Firefox 4). Everytime I am browing now Firefox 4 doesn't function properly in the taskbar. I made a screenshot of it which shows the problem much better. As you can see...
Browsers & Mail
Can't Get AppLocker to Function Properly
Hello, I am trying to set up a user account that can be used to run Windows Media Center. I would like to restrict access to just about everything else on the operating system (files, programs, etc). It seems like AppLocker would be perfect for this. However, I cannot get AppLocker to...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:13.
Twitter Facebook Google+