Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: DVI Monitor problem

22 Nov 2009   #1
drkrffxx

Win 7
 
 
DVI Monitor problem

Hi, I'm new here, and I have one little annoying monitor problem with W7.

So I have an LG L194WT monitor on a GF7300LE, I have the latest nVidia driver, everything works fine if I only work with the VGA connector, the problem comes whenever I use the DVI connector, I get the bios image fine, then the W7 boot screen fine (I even installed W7 using DVI), but then it goes to a blank image when the logon screen shows up. The monitor works fine in OSX and WXP, so it is a W7 issue.

I have tried to force detect the DVI connection via the nVidia Control Panel, but it remains the same, a blank, the weird thing is that it detects 2 monitors (both, VGA and DVI cables connected at te same time), but both are listed as VGA display, in XP or OSX are detected as VGA and DVI whenever I plug in both cables... Any ideas about what could be happening?

BTW, to make the matter worst, when I boot in Safe Mode in W7, the DVI display works fine, just at a lower resolution as expected.


My System SpecsSystem Spec
.
06 Dec 2009   #2
drkrffxx

Win 7
 
 

So no one has any idea of what could be the problem?

Any input would be very appreciated
My System SpecsSystem Spec
06 Dec 2009   #3
reghakr

Windows 7 Pro & Vista Home Premium
 
 

Actually what's listed in Device Manager under display adapters?

Keep both analog and DVI connects to both the computer and monitor.

Now try updating you Nvidia drivers.
My System SpecsSystem Spec
.

06 Dec 2009   #4
drkrffxx

Win 7
 
 

Well at first it showed "Generic PnP Monitor" or something like that on both connections, then I force-installed the drivers LG supplies and now it says LG L194WT (Analog) and LG L194WT (Digital), but if I switch back and forth the drivers, so the analog gets detected as digital and viceversa nothing happens, the device just gets renamed.

The problem lies, I think, in the way the monitor gets detected, you see, when I go to the nVidia CP, both monitors plugged in are detected as VGA, no matter how many times I plug in or plug out the cables.

BTW, I already have the latest forceware drivers.
My System SpecsSystem Spec
06 Dec 2009   #5
reghakr

Windows 7 Pro & Vista Home Premium
 
 

Strange,

Can you disable the analog connection an see what happens.

You have Forseware drivers..but where do they show up?

Are you looking under Monitor or Display adapter?
My System SpecsSystem Spec
06 Dec 2009   #6
Qdos

 

Check your monitor drivers (these are seperate from your graphics card drivers).

If you continue to experience intermittant performance then consider the possibility that your DVI cable could be damaged, and/or the pins in any of the DVI female and male connectors may have become damaged.

Ultimately can you try the monitor with another computer using a DVI cable, this will at least let you establish where any fault lies if nothing else does.
My System SpecsSystem Spec
06 Dec 2009   #7
drkrffxx

Win 7
 
 

If I disable the analog connection the digital doesn't work at all, it just says "power saving mode".

In XP works fine as I stated before.

Quote:
You have Forseware drivers..but where do they show up?
I don't quite understand this question. Can you explain what you mean?

Quote   Quote: Originally Posted by Qdos View Post
Check your monitor drivers (these are seperate from your graphics card drivers).
I already installed the drivers, they are not specifically for W7 though.

Quote:
If you continue to experience intermittant performance then consider the possibility that your DVI cable could be damaged, and/or the pins in any of the DVI female and male connectors may have become damaged.
It is not damaged or anything, it works fine in other OSes

Quote:
Ultimately can you try the monitor with another computer using a DVI cable, this will at least let you establish where any fault lies if nothing else does.
Gonna try it, thanks for the advice.
My System SpecsSystem Spec
06 Dec 2009   #8
reghakr

Windows 7 Pro & Vista Home Premium
 
 

Yea, I did bend a pin one time. I was just hoping it wouldn't snap of when I was trying to re-posistion it.
My System SpecsSystem Spec
06 Dec 2009   #9
reghakr

Windows 7 Pro & Vista Home Premium
 
 

I;m getting old........

I thought the iorceware drivers were fr the Nvidi card.
My System SpecsSystem Spec
06 Dec 2009   #10
drkrffxx

Win 7
 
 

Quote   Quote: Originally Posted by reghakr View Post
I;m getting old........

I thought the iorceware drivers were fr the Nvidi card.
And you are right, I have the latest nv card driver meaning I have the latest forceware, and also I tried the drivers LG supplies for the monitor itself.
My System SpecsSystem Spec
Reply

 DVI Monitor problem




Thread Tools




Similar help and support threads
Thread Forum
Image distorted on monitor, problem with Windows or monitor?
Hi, my brother said that he started getting this problem when he bumped his desk. The screen went black with streaks of red running down the screen after he had bumped it. His computer is connected by DVI, and when he used the HDMI port in the monitor for XBox the image was working fine. He hasn't...
General Discussion
Dual monitor problem - 2nd monitor is blank
I have dual monitors set up for extended displays. The monitors are correctly positioned in the virtual display. When I move a window to the second monitor, it disappears from monitor 1 but doesn't show up in monitor 2 - that screen is black. Thanks
Graphic Cards
DUAL MONITOR PROBLEM- second monitor not working!
Hello, I'm new to the forum! Thanks for building this forum! Here is my problem: I have a "regular" Intel Graphics card on my HP desktop. It has a VGA port and a DVI port. When I connect one monitor (a VIZIO 26" LED/LCD TV) to the VGA port, everthing is good... I tried to connect a...
Graphic Cards
Dual Monitor (Monitor+HDTV) Setup, HDTV Resolution Problem
I apologize if this issue has been brought up before, I tried searching but it's tough trying to find stuff sometimes. But here's the problem, like the subject says I have a dual monitor setup. I can move windows media center to my 40" HDTV from my 26" LCD Monitor and it's fine. I can play...
Media Center
Dual Monitor Problem - Only 1 monitor working
I have recently built a new box with a clean install of Windows 7. Initially I only had 1 monitor and things worked fine. I decided to add a second monitor and that is when the problems started. When the system boots both monitors display all of the bootup information and and both monitors...
Graphic Cards
dual monitor problem (primary monitor disappears)
I've searched some forums and while i have found all sorts of dual monitor problems i haven't found this one. I have a MSI M670 laptop ( with nvidia 6100Go graphics card ) and a Samsung SyncMaster T240HD. I always connected my monitor with a VGA cable on my windows xp and everything worked fine....
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App