Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: How to replace Intel USB3.0 controller?

4 Weeks Ago   #1
martinlest

Windows 7 Home Premium SP1 64-bit
 
 
How to replace Intel USB3.0 controller?

Hi. It is well recorded across various forums (including Saitek's own) that Saitek gaming hardware (eg X52) has a big issue (leading to BSODs) with Intel USB 3.0. Another here:

Saitek X52 Pro on USB3.0 (Intel Z97 chipset)

For almost two years I disabled USB3.0 on my PC so as to be able to use the X52, but I now need USB3.0 and so re-enabled it in the BIOS.

Several weeks have gone by and I just got my first BSOD, BAD_POOL_HEADER 0x00000019. Not sure now if this is what I was getting before, but I would like to replace the Intel controllers if possible. Problem is, I am not really sure how to go about this. Could someone please help here? My M/B is an Asus H971-PLUS. In the Asus manual, under USB I can only see mention of 'Intel H97 Express Chipset'. Can't see any mention of a native controller. Is it possible for me to download, say, an ASMedia USB3.0 controller (with which, it is said, the Saitek devices work fine) and use it to replace the Intel controller. How exactly would I go about that? I run Windows 7 x64.

Thanks for any help.


My System SpecsSystem Spec
.
4 Weeks Ago   #2
gldndragn

Windows 7 Home Premium (64 bit)
 
 

the only way to "replace" that controller is to buy an add on usb controller. The Intel H97 chipset supports both usb 3.0 and 2.0.
The 3.0 ports are blue and 2.0 are black(in the rear of board). try using the 2.0 ports instead. Installing other brand drivers will NOT work, as the hardware these drivers are for is not on your board.
My System SpecsSystem Spec
4 Weeks Ago   #3
martinlest

Windows 7 Home Premium SP1 64-bit
 
 

It doesn't matter whether the hardware is plugged into a USB2 or USB3 port, it's having the Intel USB3 controller active that causes the problem.

So you are saying that this Asus board will not be able to use any other controller other than the Intel one? Not the impression I got from other threads on this subject, I must admit. In that case, how would 'buying an addon USB controller' work then?

Thanks...
My System SpecsSystem Spec
.

4 Weeks Ago   #4
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Martin,

As USB3 is not standard for W7, then from your device manager,
you also have 2 options,
(note if the problem is a BIOS enabled problem this will not work)

Update the driver directly from intel
or
dissable it


Roy
My System SpecsSystem Spec
4 Weeks Ago   #5
martinlest

Windows 7 Home Premium SP1 64-bit
 
 

Yes, I am afraid this has to be done in the BIOS...
My System SpecsSystem Spec
4 Weeks Ago   #6
Megahertz07

Windows 7 HP 64
 
 

As mentioned, the hardware of the USB is built inside the chipset (H97). The USB 2.0 and 3.0 use the same driver.
You must disable all USB on BIOS and buy an add on card. As most USB devices can't even get close to USB 2.0 limit (480 Mb/s or 60 MB/s) I would buy a USB 2.0.
My System SpecsSystem Spec
3 Weeks Ago   #7
martinlest

Windows 7 Home Premium SP1 64-bit
 
 

OK, thanks. I have a suspicion (that I will try to test out at some stage) that my USB 3.0 speeds are not all that much better than those for my USB2.0. In which case, if I do get BSODs again (the one yesterday may have been a coincidence, nothing to do with the Saitek - I hope!), I'll just disable USB3.0 again.

The device for which I re-enabled USB3.0 is actually USB-C - but I am not sure if it's worth buying a USB-C card?
My System SpecsSystem Spec
Reply

 How to replace Intel USB3.0 controller?




Thread Tools




Similar help and support threads
Thread Forum
Are USB3 controller cards and/or add-ons a probelm?
I wasn't sure how to title this. I ran into a problem installing the USB3 drivers when I swapped MB's with the same chipset (AMD 970). All the other devices were handled Ok, along with loading drivers for new devices, but the on board USB3 ports. Long story short, there were registry entries...
Drivers
Drives will not connect to USB3 host controller
I just got a new Dell Precision T7810 at work. When I plug in USB3.0 external hard drives to the SS USB 3.0 ports, they connect as USB2, and get the balloon popup "This device can perform faster". I have tried everything - uninstalling and re-installing the latest USB3.0 controller drivers and...
Hardware & Devices
Updating USB3 controller driver
I tried to update my USB3 controller to the latest level of driver, using the update from the ASUS site for my motherboard (as recommended by the supplier of my PC). The install was an Intel program, which left me without a driver for my mouse/keyboard, requiring a System Restore... Is it a good...
Drivers
USB port not working Intel USB3 xhci Driver for Intel® 8/9 Series
Hi, Just wondering if anyone has been having the same issue. Windows 7 x64 series 8 motherboard. ASUS z87-expert. My USB3 and USB2 are not working right after I install the Intel USB3 xhci Driver for Intel® 8/9 Series version 3.0.1.41. I have used the setup.exe to install the driver...
Drivers
Replace Intel Celeron 440 @ 2.0 GHz With Intel Core 2 Quad @ 3.0 GHz
I have this: ARK | Intel® Celeron® Processor 440 (512K Cache, 2.00 GHz, 800 MHz FSB) I want to replace it with this: ARK | Intel® Core I've tried simply physically replacing one with the other, but as you may guess, it's not that simple. What do I need to do? I'm on a budget of zero. ...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App