Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Touchpad and USB port drivers both will not install

25 Nov 2017   #1
nimrod99

Windows 7 Home Premium 64-bit
 
 
Touchpad and USB port drivers both will not install

I'm completely stumped over here and hope someone can help. I have a Toshiba Satellite L655 running Windows 7/64-bit. After running Windows Update, the touchpad and the associated mouse buttons don't work, and the USB ports fail to recognize any devices.

Device Manager shows the yellow triangle ["Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"] for Synaptics PS/2 Port TouchPad under Mice and other pointing devices and the same error for both USB Composite Device and USB Mass Storage Device under Universal Serial Bus Controllers. Uninstalling the drivers removes them from Device Manager until I restart, then they reappear with the same error. I've downloaded and installed the most recent drivers from the Toshiba website: The touchpad installation says it completed successfully, but the touchpad stil doesn't work, and Device Manager still shows the bad driver above. The USB drivers from the Toshiba website won't even begin to install after the self-extractor runs.

Pressing the touchpad button or toggling the function key combination doesn't have any effect (the function key combo says the touchpad is enabled), and there doesn't appear to be a relevant setting in the BIOS.

I've tried running System Restore to no avail. Interestingly, when I boot into System Recovery, the touchpad works fine.

I'm not sure that these two problems (the touchpad and the USB ports) are related, but they did begin to occur at the same time. Not being able to use a USB mouse, I don't have any mouse functionality at all. Regrettably, I don't have a disk image other than the factory image, which I'm hoping to avoid having to use.

I can't find anything online that addresses these specific problems. If anyone has any thoughts, I would really appreciate hearing them. Thank you!


My System SpecsSystem Spec
.
25 Nov 2017   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello and welcome nimrod mate have you checked in the BIOS to see if the touchpad is enabled?? and I persnally would be updating the USB and chipset drivers Satellite L655-S5150 Support | Toshiba

If yo get to any part of this site which requests it there willbe a sticker on the bottom of you machine that says PART NO: it is relevant to where the machien was made and where for so always use that if it is requested.

Funny and odd that system restore didn't do anything though so please run these if you haven't already because your AV is pretty ordinary to be honest. So you may be better off running MSE if nothing else there are plent of free ones liek the Kaspersky and Bitdefender brands and because I have run Kaspersky on my Windows amchines for year I would recomned that one first
https://www.kaspersky.com.au/free-antivirus?ksid=c8fe6818-65d5-40da-bf93-2b6ad4001ea3&ksprof_id=422&ksaffcode=101414&ksdevice=c&kschadid=80470528359230&kschname=bing&kpid=Bi ng%7C298199521%7C1287528185808201%7C80470528359230%7Ckwd-80470553438145:loc-9la-%7Bcriterionid%7D%7Cc if that is not the entire lin then just Google Kaspersky free (I am on one of my Linux machines right now and sometimes one cannot highlight the entire URL address)


p { margin-bottom: 0.25cm; direction: ltr; color: rgb(0, 0, 0); line-height: 120%; }p.western { font-family: "Times New Roman", serif; font-size: 12pt; }p.cjk { font-family: "Calibri", sans-serif; font-size: 12pt; }p.ctl { font-family: "Times New Roman", serif; font-size: 12pt; }a:link { color: rgb(0, 0, 255); } https://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html
https://www.sevenforums.com/tutorials/433-disk-check.html < if necessary include the /f and /r in the command line as per Option2
Often said that the sfc is best run for three consecutive runs – doesn’t take long but it is your choice.


if no change then try these

http://www.superantispyware.com/
http://www.malwarebytes.org/products/malwarebytes_free/
http://www.bleepingcomputer.com/download/adwcleaner/
ADW download from bleeping computer delete any rubbish found with the malware scans
NB If anyone who has Kaspersky as their security they may find it will not like ADW running and to stop the nagging just temporarily disbale the Kaspersky while one runs ADW
My System SpecsSystem Spec
29 Nov 2017   #3
mrjimphelps

Linux Mint 18.2 xfce 64-bit (VMWare host) / Windows 8.1 Pro 32-bit (VMWare guest)
 
 

Try this:
  • Shut the computer down.
  • Remove the battery and unplug the A/C adapter.
  • Hold down the power button for about 30 seconds to discharge the capacitors.
Now put everything back together, power up, and try using a USB mouse as well as the touch pad.

That solution and others are here:
https://www.ifixit.com/Answers/View/...ts+not+working

A workaround that sometimes works is to get a docking station for your laptop which has PS/2 keyboard and mouse ports, and then use a PS/2 mouse (and keyboard if necessary). However, the only docking station I could find for your laptop has no PS/2 ports.

Twice in my life, I have had USB die on a computer. Each of those computers had PS/2 keyboard and mouse ports, and I had a PS/2 keyboard and mouse handy, so I was able to easily fix the problem. In the first case, I uninstalled the problematic USB listings in Device Manager, and I then reinstalled the USB drivers. In the second case, I installed a USB controller card, providing four USB3 ports for my computer. I used those ports for a while; then one day, for some unknown reason, the onboard USB ports started working again!
My System SpecsSystem Spec
.

29 Nov 2017   #4
mrjimphelps

Linux Mint 18.2 xfce 64-bit (VMWare host) / Windows 8.1 Pro 32-bit (VMWare guest)
 
 

Here are the Windows 7 keyboard shortcuts, which you can use if your mouse isn't working:

https://support.microsoft.com/en-us/help/12445
My System SpecsSystem Spec
Reply

 Touchpad and USB port drivers both will not install




Thread Tools




Similar help and support threads
Thread Forum
BSOD whenever i use my touchpad ELAN PS/2 Port Smary-pad
How can i fix the problem? i was on windows 10 then i restored my laptop to windows 7. this is the info. Problem signature: Problem Event Name: BlueScreen OS Version: 6.1.7601.2.1.0.768.3 Locale ID: 13321 Additional information about the problem:
BSOD Help and Support
Acer Synaptics Touchpad - Finding Internal PS/2 port in Device Manager
I just had to replace the top cover, including touchpad, on an Acer 5741 running Windows 7 64 Home Premium, because the old cover had cracked near the hinge. The new cover appears identical to the old one, and everything works, but the symantics touchpad software doesn't recognize the...
Hardware & Devices
Synaptics PS/2 Port Compatible TouchPad
I did a clean install of win7 (yeah for me!) on my acer aspire 5336-2524. I also downloaded the device driver for Synaptics PS/2 Port Compatible TouchPad, unzipped it, and I think I installed it? I did an auto search for the best driver and result was the best driver was installed. My problem...
Drivers
Turbo Boost and touchpad drivers
So, I just got my new laptop in the mail yesterday. (copy/paste from my email) Anyway.. it's all gravy and whatnot, but I reformatted because I wanted to install my 7 Professional on it, which went along pretty well, but I'm facing a severe issue right now: I can't use the double-tap...
Drivers
Drivers de Synaptics TouchPad en Windows 7
Tengo una Toshiba Satellite A210-11T (PSAEGE). Cansado de Windows Vista instalé desde cero Windows 7 y quedé maravillado. Tuve algunos pequeños problemas de drivers/compatibilidad que pude solucionar, pero hay dos que aun no logro encontrarles la solución. El primero es el Synaptics TouchPad...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:08.
Twitter Facebook Google+